Post by tobisanx » Wed Nov 23, 2016 4:27 pm

Hi everyone,

could anyone please assist me with a problem I have on my 1.5.6.4 page
I originaly had Dependant Options mod, works fine
https://www.opencart.com/index.php?rout ... n_id=15724

However, I then purchased 'Product Option Image' mod
https://www.opencart.com/index.php?rout ... n_id=12976
because the description states "Compatibility
- OpenCart 2, OpenCart 1.5.1.3-1.5.6, MijoShop, JooCart
- Dependent Options, Option SKU extension"

However, when I enable it at the same time as Dependant Options, the product catalogue edit screen, shows the columns mixed around the wrong way (see image column has depndant option choices, and dependant option column header is above the image selections)
http://i.imgur.com/p48nMbg.png

So they intertwine, and then dependant options fails to work when the image mod is on, even though the image mod says it is compatible with dependant options in its description.

Am i entitled to a refund here? how do I get a refund on a mod? can someone alter the code so that they work together or am I out of luck on such a request?

Thanks, this is first mods I've bought so please forgive lack of knowledge on how this process works.

Thank you.


Posts

Joined
Wed Nov 23, 2016 4:23 pm

Post by Johnathan » Wed Nov 23, 2016 11:27 pm

I'd first contact the developer of the Product Option Image extension, and see if they have a fix for the issue. If they do not, and are unwilling to look at it, I'd say you would be entitled to a refund, since their extension explicitly states that it is compatible. (You should take a screenshot of that page, in case they modify the extension description.)

I'm not on the OpenCart support team, so you will still have to go through them to see if you qualify for a refund. You can use the Contact Us link in the footer to reach them.

Another option would be hiring someone to modify the Product Option Image extension to fix the incompatibility. That could be easy to do, or it could be costly, depending on what the cause of the issue is. If you need to find a developer, you should post a request in the OpenCart "Commercial Support" forum, which is checked by a number of OpenCart developers. You can also try checking out the OpenCart "Partners" area.

Image
Image Image Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by mmosolution » Tue Dec 20, 2016 1:22 pm

Agreed. First, contact the developer of the Product Option Image extension, and see if they have a fix for the issue, or else if they will fix the incompatibility issue for free. Many reputable developers of extensions will do this for you!

Image
MMOSolution.com
"Changing your challenges into opportunities!"


User avatar

Posts

Joined
Mon Dec 05, 2016 11:58 am
Location - Vietnam

Post by IP_CAM » Wed Dec 21, 2016 12:06 am

tobisanx wrote:could anyone please assist me with a problem I have on my 1.5.6.4 page
well, an OpenCart 1.5.6 product file will probably not exactly match a 1.5.6.4 file, and the seller did NOT mention v.1.5.6.4 with a single word. !
And those kinds of extensions can be difficult to handle, so far, I did not find a single (free) one, beeing able to really function in full on one of my also partly VqMod enhanced 1.5.6.4+ test site Product Pages. Especially, when it comes to Product Pages, where other VqMod Extensions are trying to do their Job as well!

Just to mention this! ;)
Ernie

Ernie's OpenShop 1.5.6.5 with free responsive OC Bootstrap Themes:
http://www.evelo.li - http://www.jti.li/ocshop/ - http://www.hitline.info/ocshop/
Image


User avatar

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by mmosolution » Wed Dec 21, 2016 10:23 am

Ernie, these days people really really try to NOT mix VqMods woth OCMods; that's the cause of conflicts more often than not. Stick with one or the other. Note that OCMods are becoming the preference these days.
By the way: did you check your Error Log in Admin?

Image
MMOSolution.com
"Changing your challenges into opportunities!"


User avatar

Posts

Joined
Mon Dec 05, 2016 11:58 am
Location - Vietnam

Post by Johnathan » Wed Dec 21, 2016 11:35 pm

I'd just like to chime in that I've seen HUNDREDS of installations that have both ocMod and vQmod installed, and they work together just fine. Yes, two mods can still conflict, but that can happen just with ocMod or just vQmod. It's fine if people want to avoid using vQmod files, but I don't want misinformation out there -- using an ocMod version of a vQmod file will still cause the same issue if it already conflicts with another mod that is installed.

Image
Image Image Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am