Post by Qphoria » Sun Jun 13, 2010 2:34 am

The only major update that should affect extensions in 1.4.8 is the new admin token system.

Unfortunately, because there is no longer a url class, each individual url in the admin section must have the token appended to it.

The easiest way to do it is to do a Global Find/Replace on the "admin" folder of any extension.

BE SURE YOU ARE ONLY WORKING IN THE "ADMIN" FOLDER OF MODS & EXTENSIONS! THE TOKEN SHOULD NOT BE ADDED TO FILES THAT GO IN THE "CATALOG" FOLDER


FIND:

Code: Select all

index.php?route
REPLACE WITH:

Code: Select all

index.php?token=' . $this->session->data['token'] . '&route
You will need a good text editor like Notepad++ that has a "Find In files/Replace in Files" feature. The dialog would look like this:
Image

That would change all links from
index.php?route=extension/payment'

to
index.php?token=' . $this->session->data['token'] . '&route=extension/payment'

Then they would be 1.4.8 compatible

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by peteVA » Sun Jun 13, 2010 7:53 am

OK, did that.

And where before the offline CC settings were not sticking in the Extensions/Payments page, now they do.

And where the option was not showing at closeout, now it does.

Thanks!

A Trusted Wholesale Dropshipper
Web Hosting Under $ 5.00 Month! FREE Shopping Carts!
25,000+ Real Wholesale & Dropship Sources!


User avatar
Active Member

Posts

Joined
Mon Jul 20, 2009 8:25 am

Post by flairtek » Mon Jun 14, 2010 11:35 pm

Fatal error: Call to a member function getLanguages() on a non-object in /home/shopreva/public_html/cart/catalog/controller/module/mymodule.php on line 11

New member

Posts

Joined
Mon Jun 14, 2010 10:28 pm

Post by Qphoria » Mon Jun 14, 2010 11:42 pm

flairtek wrote:Fatal error: Call to a member function getLanguages() on a non-object in /home/shopreva/public_html/cart/catalog/controller/module/mymodule.php on line 11
This is a mymodule issue
http://forum.opencart.com/viewtopic.php ... =15#p77243

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by hireconor » Tue Jun 22, 2010 10:35 pm

Does the Offline CC mod split the CC # between server and email now to make it PCI compliant?

User avatar
New member

Posts

Joined
Mon Mar 15, 2010 9:31 am

Post by dada » Thu Jul 08, 2010 8:19 pm

Hello.

I've tried to follow instructions and upgrade web2pay extension from 1.4.7 to 1.4.8, but something is still not right.
When i try to enable or change and save any settings on the extension i'm just forwarded to dashboard page with no errors or something. I wrote my problem on forum here http://forum.opencart.com/viewtopic.php?f=113&t=16943 .

I've attached files, could you please take a look at it. Thanks.

Attachments

Original 1.4.7 extension


Newbie

Posts

Joined
Fri Jul 02, 2010 1:08 am

Post by barbiesam » Wed Jan 04, 2012 1:52 am


Can someone out here help me to install earthball in my Open Cart. I have the latest version of Open Cart and I have already installed it but getting errors........It is about a 10 minute job. HELP
thnx guys
Barb (newbie)

Newbie

Posts

Joined
Mon Jul 12, 2010 11:39 pm

Post by veerji » Thu Sep 27, 2012 8:07 pm

I am very interested in MultiSeller Solution for Mixed Product Shop, and you want to send e-mail exchange.

"steward"


Newbie

Posts

Joined
Thu Sep 27, 2012 8:01 pm

Post by reticlesystems » Sun Feb 10, 2013 4:23 am

Hello there..

How can i upgrade the free plugin at the repositry of oc called "Wholesale price list" for 1.5.5.?

New member

Posts

Joined
Tue Dec 25, 2012 10:40 am

Post by Hannah00 » Thu Sep 15, 2016 5:14 pm

Maybe the problem is on this extension that supports version 1.4.8 or not.

Opencart migration & upgrade tool


User avatar
New member

Posts

Joined
Wed May 04, 2016 5:09 pm
Who is online

Users browsing this forum: No registered users and 11 guests