Post by soufianeboutahlil » Tue Nov 06, 2018 2:37 am

Hi,
I use OpenCart when I want to access Admin, I find PHP errors :-[ :-[ :-[ .

Warning: require_once(): open_basedir restriction in effect. File(/var/www/vhosts/madeinhome.ma/homefood.ma/system/startup.php) is not within the allowed path(s): (/var/www/vhosts/homefood.ma/:/tmp/) in /var/www/vhosts/homefood.ma/httpdocs/admin++/index.php on line 19

Warning: require_once(/var/www/vhosts/madeinhome.ma/homefood.ma/system/startup.php): failed to open stream: Operation not permitted in /var/www/vhosts/homefood.ma/httpdocs/admin++/index.php on line 19

Fatal error: require_once(): Failed opening required '/var/www/vhosts/madeinhome.ma/homefood.ma/system/startup.php' (include_path='.:/opt/plesk/php/5.6/share/pear') in /var/www/vhosts/homefood.ma/httpdocs/admin++/index.php on line 19.


Posts

Joined
Tue Nov 06, 2018 2:23 am

Post by paulfeakins » Tue Nov 06, 2018 5:46 pm

Well just read the error message:

File(/var/www/vhosts/madeinhome.ma/homefood.ma/system/startup.php) is not within the allowed path(s)

Which means you have some strange settings going on, either in your /config.php, /admin/config.php files or with file permissions on the server itself.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by OSWorX » Tue Nov 06, 2018 6:13 pm

Because of this: open_basedir restriction in effect
Means, there are some restrictions on this server (paths) and your file(s) is/are not within these allowed paths.

Forum Rules: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by straightlight » Tue Nov 06, 2018 7:23 pm

Contact your host to resolved this issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by soufianeboutahlil » Wed Nov 07, 2018 8:13 pm

Thank you for replies :D
I've uploaded my site to localhost and i fixed the problem, I just downloaded admin folder and I changed by my old admin and I changed config.php and admin / config.php.


Posts

Joined
Tue Nov 06, 2018 2:23 am
Who is online

Users browsing this forum: DigitCart, NorfolkBits and 16 guests