Post by rzaprianov » Sun Jun 17, 2018 1:21 am

Hello,

I need to fix an error which appears when I try to install something from the Marketplace - Extension Marketplace in OC3.

The error is:

Code: Select all

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

<b>Warning</b>: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in <b>/home/yourblin/public_html/onlinebulbs.eu/admin/controller/marketplace/marketplace.php</b> on line <b>871</b><b>Warning</b>: file_get_contents(https://opencart-extension.s3.amazonaws.com/5ac626b7ebb61.zip?response-content-disposition=attachment%3B+filename%3D%22dblogmodulecompiledoc3.0.2.0.v3.0.12.ocmod.zip%22&amp;AWSAccessKeyId=AKIAJAKN3JSFG324O44A&amp;Expires=1529169514&amp;Signature=GGE4Iut6SvAarmOOEAEK3gxTLsM%3D): failed to open stream: no suitable wrapper could be found in <b>/home/yourblin/public_html/onlinebulbs.eu/admin/controller/marketplace/marketplace.php</b> on line <b>871</b>{"extension_install_id":13,"text":"Installing","next":"http:\/\/onlinebulbs.eu\/admin\/index.php?route=marketplace\/install\/install&user_token=f0Rg7gz9BMwGLW3LMTsqlQyaMlBFhIrr&extension_install_id=13"}
Please help me fix that error and take into account I'm not a developer so please have patient with me :) and explain me simply what I need to make.

I attached screenshot as well. Thanks in advance!

Regards,

Rumen

Attachments

error.png

error.png (348.82 KiB) Viewed 348 times


Newbie

Posts

Joined
Fri Feb 23, 2018 5:16 pm

Post by sw!tch » Sun Jun 17, 2018 1:41 am

Contact your webhost and ask them to enable allow_url_fopen in your PHP.ini.

Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm

Post by rzaprianov » Sun Jun 17, 2018 2:11 am

It is enabled see the screen shot

Attachments

error2.png

error2.png (16 KiB) Viewed 327 times


Newbie

Posts

Joined
Fri Feb 23, 2018 5:16 pm

Post by sw!tch » Sun Jun 17, 2018 2:21 am

Are you using cPanels multi-php? if so you need to edit the correct PHP.ini for the version used.

Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm

Post by rzaprianov » Sun Jun 17, 2018 3:22 am

Sorry, I'm not sure I got you right. If you ask if there are other sites on this host the answer is - YES. Do you mean that in this case I should allow this for all other sites as well? Is that what you mean?

And ... hey thanks for the help :)

Newbie

Posts

Joined
Fri Feb 23, 2018 5:16 pm

Post by rzaprianov » Sun Jun 17, 2018 4:01 am

I got the error!!! It was 7.1 on the Multy PHP and 5.6 in the other :)

SOLVED!

Newbie

Posts

Joined
Fri Feb 23, 2018 5:16 pm

Post by sw!tch » Sun Jun 17, 2018 4:57 am

Glad its resolved. ^ Yes I was referring to this and MultiPHP in cPanel, its a common issue where people enable stuff for the wrong version they are using.

Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm
Who is online

Users browsing this forum: No registered users and 16 guests