Post by Cloudy9 » Wed Jun 13, 2018 1:45 am

Hi

I have a good few products with a good few options, however now when I try to add an option to a product and click save I get a page not found error and I cannot add options t the product ?

The url it goes to on save is

http://MY WEB PAGE.co.uk/admin/index.php?route=catalog/option/edit&user_token=rJpNK9snlpyc2wWAbKfwmrycDnF3ObPJ&option_id=52&page=2

Newbie

Posts

Joined
Mon Jun 09, 2014 5:21 am

Post by straightlight » Wed Jun 13, 2018 2:04 am

No OC version posted. However, this issue may be caused by an SEO extension installed or improper configuration to your .htaccess or config.php / admin/config.php files. Also ensure not to have any extensions altering core routes. Otherwise, your browser may no longer be able to find them until setting the correct route name when saving your values.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Cloudy9 » Wed Jun 13, 2018 2:57 am

Sorry OC 3.0.2

Extensions:

Google Address Autocomplete GJ.VVU - Gengjun.Wu@gmail.com 3.0 Enabled 23/04/2018
iSenseLabs GDPR iSenseLabs 1.0 Enabled 04/06/2018
Option Image Equotix 5.0.0 Enabled 07/06/2018
Power Image Manager Sharley's Web Development 3.5 Enabled 10/06/2018
Restrict Checkout Clear Thinking, LLC v302.3 Enabled 04/06/2018
htacess is pretty default with set enabled

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

Newbie

Posts

Joined
Mon Jun 09, 2014 5:21 am

Post by Cloudy9 » Wed Jun 13, 2018 2:59 am

config php and the admin one looks ok,

If I use the word test as an option it saves it, if I make the string long I get the error so not sure its a config issue

Newbie

Posts

Joined
Mon Jun 09, 2014 5:21 am

Post by sw!tch » Wed Jun 13, 2018 3:28 am

If it saves using a simple word like test. Then check if your server is using mod-security might be flagging a rule. That can produce a 404.

Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm

Post by paulfeakins » Wed Jun 13, 2018 5:11 pm

sw!tch wrote:
Wed Jun 13, 2018 3:28 am
Then check if your server is using mod-security might be flagging a rule. That can produce a 404.
+1 for this, I think this is a likely cause.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by ostechnologies » Thu Jun 14, 2018 8:04 pm

To Fix Open Cart 404 Page not found error add these codes to your top of your .htaccess
add this code at the top.
# Prevent Direct Access to files
<FilesMatch “.(tpl|ini|log)”>
Order deny,allow
Deny from all
</FilesMatch>
# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base
RewriteRule ^download/(.*) /index.php?route=error/not_found
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1

Please let me know if you are still facing any problem.

Opencart Expert | sales[at]ost.agency
Skype - manish.osuniverse | Gtalk - manishmt

Extensions for Opencart @ https://www.ost.agency/product/product- ... extensions
ost.agency - ecommerce website design, development and digital company


User avatar
Active Member

Posts

Joined
Mon Apr 06, 2015 1:30 pm

Post by Cloudy9 » Fri Jun 15, 2018 5:26 pm

ostechnologies wrote:
Thu Jun 14, 2018 8:04 pm
To Fix Open Cart 404 Page not found error add these codes to your top of your .htaccess
add this code at the top.
# Prevent Direct Access to files
<FilesMatch “.(tpl|ini|log)”>
Order deny,allow
Deny from all
</FilesMatch>
# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base
RewriteRule ^download/(.*) /index.php?route=error/not_found
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1

Please let me know if you are still facing any problem.
Makes no difference

Newbie

Posts

Joined
Mon Jun 09, 2014 5:21 am

Post by straightlight » Fri Jun 15, 2018 9:23 pm

Check your server access logs after implementing this solution and notice all recent 404 error messages.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Cloudy9 » Wed Jun 20, 2018 1:50 am

Host says nothing in the logs and server configured fine, to be fair I have another OC (but 2) shop on the same server and it has no issues

Is there anything I can check on OC3 ? Or an OC 3 bug ?

Newbie

Posts

Joined
Mon Jun 09, 2014 5:21 am

Post by sw!tch » Wed Jun 20, 2018 2:37 am

1. Was this an upgrade from OC 2 did you import products/options?

2. You are saying if you use a simple option name like "test" it saves fine with no 404 error?

3. Try disabling that Option Image mod, might be that doing it.

Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm

Post by Cloudy9 » Thu Jun 21, 2018 12:15 am

1. No brand new oc3.0.2 install
2. yes
3. Tried and still get 404

Newbie

Posts

Joined
Mon Jun 09, 2014 5:21 am

Post by sw!tch » Thu Jun 21, 2018 6:23 am

You may want to post in the commercial section for someone to further help you. Only other suggestion I can make is check your PHP settings, maybe you have something really low.

- Good luck.

Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm
Who is online

Users browsing this forum: No registered users and 16 guests