Post by tbaforum » Thu May 31, 2018 6:23 pm

My new page has been made offline on a local host and has just been uploaded to a test server. I changed the config.php files in root and admin folders. I'm having an issue where the page can go to categories and products with SEO urls off in the settings but getting a 404 error when seo urls are on. My research seems to say it's a htaccess issue but I really don't know. If there is a htaccess issue it may be to do with the fact that I used Bitnami to install OC3 on the local host and they do some weird thing where they move the config out of the htaccess to a different file in another location. This doesn't seem to follow the page online though, as I did a ban all access code in the htaccess online an that worked (so the default htaccess did respond).
Here is my htaccess file. That is the default location one, not the one bitnami were making active on the local host.
# STARTNITRO
Header unset ETag
Header unset Last-Modified
FileETag None

#CSS JS XML TXT - 1 MONTH
<FilesMatch "\.(xml|txt)$">
Header set Cache-Control "max-age=2678400, public"
</FilesMatch>

#JPG JPEG PNG GIF SWF SVG - 1 MONTH
<FilesMatch "\.(jpg|jpeg|png|gif|swf|svg|JPG|JPEG|PNG|GIF|SWF|SVG)$">
Header set Cache-Control "max-age=2678400, public"
ExpiresDefault "access plus 1 month"
Header set Last-Modified "Wed, 05 Jun 2009 06:40:46 GMT"
</FilesMatch>

#OTF WOFF TTF ICO PDF FLV - 1 MONTH
<FilesMatch "\.(otf|ico|pdf|flv|woff|ttf)$">
Header set Cache-Control "max-age=2678400, public"
ExpiresDefault "access plus 1 month"
</FilesMatch>
AddType image/svg+xml .svg
AddOutputFilterByType DEFLATE image/svg+xml
AddType application/x-font-woff .woff
AddOutputFilterByType DEFLATE application/x-font-woff
RewriteEngine On
RewriteBase /
RewriteRule .* - [E=HTTP_IF_MODIFIED_SINCE:%{HTTP:If-Modified-Since}]
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteRule ^(\/?(catalog.*\/assets).+)\.css$ catalog/view/theme/assets//serveFile.php?t=css&l=-1&p=$1&c=2678400 [NC,L]
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteRule ^(\/?(catalog.*\/assets).+)\.js$ catalog/view/theme/assets//serveFile.php?t=js&l=-1&p=$1&c=2678400 [NC,L]
# ENDNITRO
# This configuration has been moved to the application config file for performance and security reasons
It looks to me like the extension Nitro Cache added to it. I added the RewriteBase / but it doesn't help.

This is the one the I think bitnami were using before. It seems to be supplemented by 3 other files too though. Do I need to include parts of it or something? Am I missing htaccess information or something?
<Directory "D:/xampp/apps/opencart/htdocs">
# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /opencart/
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
</Directory>
<Directory "D:/xampp/apps/opencart/htdocs/system">
<Files *.*>
Order Deny,Allow
Deny from all
</Files>
<Files ~ "\.(js|css)$">
Order Allow,Deny
Allow from all
</Files>

</Directory>
<Directory "D:/xampp/apps/opencart/htdocs/system/storage/session">
Deny from all

</Directory>

#Snippet to fix fontAwesome not loading issue i