Post by sbmGroup » Sun Apr 22, 2018 1:50 am

i recenbtly added ssl to my site have have the store working properly on all my devices and browsers. my issuse is logining in to admin
i enter my admin address, it shows an unformatted login page, then when i login it shows an address of https://www.babybeatzz.com/admin/www.ba ... mmon/login
and an error of
Not Found
The requested URL /admin/www.babybeatzz.com/admin/www.babybeatzz ... /index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


my htaccess is
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteCond %{HTTP_HOST} ^(www\.)?mysite\.com
RewriteRule ^(.*)$ https://www.mysite.com/$1 [R,L]

RewriteCond %{HTTP_HOST} ^mysite.com [NC]
RewriteRule ^(.*)$ http://www.mysite.com/$1 [L,R=3


and my config.php in my admin directory is
<?php
// HTTP
define('HTTP_SERVER', 'www.mysite.com/admin/');
define('HTTP_CATALOG', 'www.mysite.com/');

// HTTPS
define('HTTPS_SERVER', 'www.mysite.com/admin/');
define('HTTPS_CATALOG', 'www.mysite.com/');

// DIR
define('DIR_APPLICATION', '/home/myuser/public_html/mysite.com/admin/');
define('DIR_SYSTEM', '/home/myuser/public_html/mysite.com/system/');
define('DIR_IMAGE', '/home/myuser/public_html/mysite.com/image/');
define('DIR_STORAGE', '/home/myuser/public_html/storage/');
define('DIR_CATALOG', '/home/myuser/public_html/mysite.com/catalog/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/template/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');

// DB
<!-- hidden -->

// OpenCart API
define('OPENCART_SERVER', 'https://www.opencart.com/');


what do i need to add/change?
thanks

Newbie

Posts

Joined
Wed Mar 07, 2018 6:51 am

Post by ashon » Sun Apr 22, 2018 3:58 am

Public_html/ Config.php change

From

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://www.***********.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.**************.com/');
to

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'https://www.***********.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.**************.com/');
same with public_html/admin config.php

htaccess

Code: Select all

# Force SSL and WWW
RewriteCond %{SERVER_PORT} 80 [OR]
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule ^(.*)$ https://www.*************.com/$1 [R=301,L]

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am
Who is online

Users browsing this forum: No registered users and 15 guests