Post by ashon » Thu Apr 19, 2018 6:25 pm

Today i setup full SSL on my site and i noticed this - http://prntscr.com/j7apt3 'this page is trying to load scripts from unauthenticated sources'

it only shows up on the home page of the site if i got to product or any other page it does not show ?? is a plugin i have installed using some sort or back end script maybe mining

update

i have looked more in to this and found this not sure if this is the problem or not

Code: Select all

Mixed Content: The page at 'https://www.***********.com/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Open+Sans:400,800,300,700'. This request has been blocked; the content must be served over HTTPS.

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by straightlight » Thu Apr 19, 2018 8:20 pm

This information can be Googled: https://developer.mozilla.org/en-US/doc ... ed_content . Ensure your config.php and admin/config.php files have all https rather than http on your URLs. This should resolved the issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ashon » Thu Apr 19, 2018 8:29 pm

straightlight wrote:
Thu Apr 19, 2018 8:20 pm
This information can be Googled: https://developer.mozilla.org/en-US/doc ... ed_content . Ensure your config.php and admin/config.php files have all https rather than http on your URLs. This should resolved the issue.
Thanks for the replay i have edited the config and admin one and changed to HTTPS
config.php

Code: Select all

// HTTP
define('HTTP_SERVER', 'https://www.*************.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.**********.com/');
admin/config.php

Code: Select all

// HTTP
define('HTTP_SERVER', 'https://www.*************.com/admin/');
define('HTTP_CATALOG', 'https://www.*************.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.*************.com/admin/');
define('HTTPS_CATALOG', 'https://www.*************.com/');
and i get this error

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by straightlight » Thu Apr 19, 2018 8:32 pm

What are your .htaccess configuration?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ashon » Thu Apr 19, 2018 8:35 pm

straightlight wrote:
Thu Apr 19, 2018 8:32 pm
What are your .htaccess configuration?

Code: Select all

# SEO URL Settings
RewriteEngine ON
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/


# Force www
RewriteCond %{HTTP_HOST} !^$
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteCond %{HTTPS}s ^on(s)|
RewriteRule ^ http%1://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

# Force SSL
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [R=302,L,NE]

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by straightlight » Thu Apr 19, 2018 8:44 pm

See if this solution is working: viewtopic.php?f=190&t=145781&p=720723&h ... ps#p720723 . As for this line in your .htaccess:

Code: Select all

RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
I would strongly suggest to follow these instructions: viewtopic.php?f=176&p=721388#p717782 and viewtopic.php?f=176&p=721388#p718325 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ashon » Thu Apr 19, 2018 9:08 pm

straightlight wrote:
Thu Apr 19, 2018 8:44 pm
See if this solution is working: viewtopic.php?f=190&t=145781&p=720723&h ... ps#p720723 . As for this line in your .htaccess:

Code: Select all

RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
I would strongly suggest to follow these instructions: viewtopic.php?f=176&p=721388#p717782 and viewtopic.php?f=176&p=721388#p718325 .
Dont understand what you mean by
.htaccess:

Code: Select all

RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by straightlight » Thu Apr 19, 2018 9:11 pm

This line in your .htaccess is implicit with what you provided on the above which means your storage folder may not be able to respond properly with the sass cache when modifying OC files unless following the instructions I provided on the above.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ashon » Thu Apr 19, 2018 9:18 pm

straightlight wrote:
Thu Apr 19, 2018 8:44 pm
See if this solution is working: viewtopic.php?f=190&t=145781&p=720723&h ... ps#p720723 . As for this line in your .htaccess:

Code: Select all

RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
I would strongly suggest to follow these instructions: viewtopic.php?f=176&p=721388#p717782 and viewtopic.php?f=176&p=721388#p718325 .

changed it to

Code: Select all

# Force SSL and WWW
RewriteCond %{SERVER_PORT} 80 [OR]
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule ^(.*)$ https://www.yourdomain.com/$1 [R=301,L]

but still getting the SSL Script Problem but only on the home page - http://prntscr.com/j7d8v0

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by straightlight » Thu Apr 19, 2018 9:33 pm

Look at the developers kit - > console (or Javascript) tab when loading the homepage. Do you see any error messages showing?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ashon » Thu Apr 19, 2018 10:13 pm

straightlight wrote:
Thu Apr 19, 2018 9:33 pm
Look at the developers kit - > console (or Javascript) tab when loading the homepage. Do you see any error messages showing?
http://prntscr.com/j7e556

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by ashon » Thu Apr 19, 2018 10:21 pm

straightlight wrote:
Thu Apr 19, 2018 9:33 pm
Look at the developers kit - > console (or Javascript) tab when loading the homepage. Do you see any error messages showing?
Found this is admin style sheets and in tmeplate/common custom_styles.twig

Code: Select all

{% for gfont in googlefonts %}
	<link href='//fonts.googleapis.com/css?family={{ gfont }}:400,300,200,700,800,500{{ cyrillic }}&amp;v1' rel='stylesheet' type='text/css' />
{% endfor %}

Code: Select all

@import url(//fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&subset=latin,cyrillic-ext,greek-ext,vietnamese);
Last edited by ashon on Thu Apr 19, 2018 10:23 pm, edited 1 time in total.

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by straightlight » Thu Apr 19, 2018 10:23 pm

So it is about font issues as mentioned on this topic: viewtopic.php?f=190&t=145781&p=720723#p720723 . Ensure the mentioned code for your .htaccess is properly added and on the right location.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Thu Apr 19, 2018 10:24 pm

Custom styles is also not a core file, it is part of an installed extension.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ashon » Thu Apr 19, 2018 10:27 pm

straightlight wrote:
Thu Apr 19, 2018 10:23 pm
So it is about font issues as mentioned on this topic: viewtopic.php?f=190&t=145781&p=720723#p720723 . Ensure the mentioned code for your .htaccess is properly added and on the right location.

i already updated the htaccess to the one you sent me to

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# Allow access from all domains for webfonts. 
# Alternatively you could only whitelist your 
# subdomains like "subdomain.example.com". 
<IfModule mod_headers.c> 
	<FilesMatch "\.(ttf|ttc|otf|eot|woff|font.css|css)$"> 
		Header set Access-Control-Allow-Origin "*" 
	</FilesMatch> 
</IfModule>

# SEO URL Settings
RewriteEngine ON
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

# Force SSL and WWW
RewriteCond %{SERVER_PORT} 80 [OR]
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule ^(.*)$ https://www.***************.com/$1 [R=301,L]

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]


### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
Last edited by ashon on Thu Apr 19, 2018 10:29 pm, edited 1 time in total.

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by ashon » Thu Apr 19, 2018 10:28 pm

straightlight wrote:
Thu Apr 19, 2018 10:24 pm
Custom styles is also not a core file, it is part of an installed extension.
its just my theme/skin dir /catalog/view/theme/Custom_Theme/template/common

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by ashon » Thu Apr 19, 2018 11:39 pm

fixed it can be closed

New member

Posts

Joined
Sat Apr 18, 2015 2:18 am

Post by paulfeakins » Fri Apr 20, 2018 6:45 pm

For anyone with similar problems, it can help to run the site through:
https://www.whynopadlock.com/

Will close.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 14 guests