Post by Sokonomi » Wed Mar 21, 2018 5:21 am

For some reason I can not update products anymore, and my error log is throwing a fit:

Code: Select all

2018-03-20 21:17:12 - PHP Notice:  Undefined index: product_seo_url in C:\xampp\htdocs\admin\controller\catalog\product.php on line 1193
2018-03-20 21:17:12 - PHP Notice:  Undefined index: points in C:\xampp\htdocs\admin\model\catalog\product.php on line 138
2018-03-20 21:17:12 - PHP Notice:  Undefined index: weight in C:\xampp\htdocs\admin\model\catalog\product.php on line 185
2018-03-20 21:17:12 - PHP Notice:  Undefined index: weight_prefix in C:\xampp\htdocs\admin\model\catalog\product.php on line 185
2018-03-20 21:19:09 - PHP Notice:  Undefined index: product_seo_url in C:\xampp\htdocs\admin\controller\catalog\product.php on line 1193
2018-03-20 21:19:09 - PHP Notice:  Undefined index: points in C:\xampp\htdocs\admin\model\catalog\product.php on line 138
2018-03-20 21:19:09 - PHP Notice:  Undefined index: weight in C:\xampp\htdocs\admin\model\catalog\product.php on line 185
2018-03-20 21:19:09 - PHP Notice:  Undefined index: weight_prefix in C:\xampp\htdocs\admin\model\catalog\product.php on line 185
Changes I make to a product just disappear after I hit save.
Anyone know what could be causing this?

Build is 3.0.2.0
Last edited by Sokonomi on Wed Mar 21, 2018 8:11 am, edited 1 time in total.

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am

Post by straightlight » Wed Mar 21, 2018 5:26 am

This error could be caused by the size limitation your server could allow per posts originating by a heavy weight of information sent via the admin products form. It would be suggested to increase your post size limit in your php.ini to temporarily resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Sokonomi » Wed Mar 21, 2018 5:33 am

That would seem to hint at something ive been trying to do. ::) The product in question that is refusing to save, is one where I entered an option with over 150 option values. That seems to make it hit a wall.

My PHP.ini looks like this:

Code: Select all

magic_quotes_gpc = Off;
register_globals = Off;
default_charset	= UTF-8;
memory_limit = 64M;
max_execution_time = 36000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.auto_start = Off;
session.use_only_cookies = On;
session.use_cookies = On;
session.use_trans_sid = Off;
session.cookie_httponly = On;
session.gc_maxlifetime = 3600;
allow_url_fopen = on;
;display_errors = 1;
;error_reporting = E_ALL;
Is there a problem with this setup?
Could there also be a mysql setting that might be cramming up the works?

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am

Post by straightlight » Wed Mar 21, 2018 5:44 am

Also ensure not to use too heavily loaded extensions that could compromise your admin products page. Do you use any extensions affecting this page particularly?

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Sokonomi » Wed Mar 21, 2018 5:45 am

None that affect the products page admin side.

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am

Post by straightlight » Wed Mar 21, 2018 5:56 am

Disable all extensions and see if you can re-save the form in your admin products page. If so, when reactivating one extension at a time, you should notice which extension may be causing the issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Sokonomi » Wed Mar 21, 2018 5:58 am

Ive just tested, it saves just fine without the colossal option list. Its definitely a limit im hitting by putting in an option with lots of option values. The question is; What limit is it, and how do I get around it.

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am

Post by straightlight » Wed Mar 21, 2018 5:59 am

What limit is it, and how do I get around it.
There are no specific limits except the one your server environment may tolerate.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

User avatar
Active Member

Posts

Joined
Fri Mar 16, 2012 10:18 am
Location - Canada, QC

Post by Sokonomi » Wed Mar 21, 2018 6:10 am

My PHP.ini does not have such a variable, can I just add it?
And if so, what should its recommended value be?

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am

Post by straightlight » Wed Mar 21, 2018 6:19 am

A good example can be found here: https://stackoverflow.com/questions/103 ... input-vars . This site suggests the use of 4000 as per demonstrated.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Sokonomi » Wed Mar 21, 2018 7:58 am

I have upped the value in my php.ini file and rebooted Apache.
Unfortunately it still wont save a product properly when there's an option with 176 entries in it.
It still generates the same errors:

Code: Select all

2018-03-20 23:54:16 - PHP Notice:  Undefined index: product_seo_url in C:\xampp\htdocs\admin\controller\catalog\product.php on line 1193
2018-03-20 23:54:16 - PHP Notice:  Undefined index: points in C:\xampp\htdocs\admin\model\catalog\product.php on line 138
2018-03-20 23:54:16 - PHP Notice:  Undefined index: weight in C:\xampp\htdocs\admin\model\catalog\product.php on line 185
2018-03-20 23:54:16 - PHP Notice:  Undefined index: weight_prefix in C:\xampp\htdocs\admin\model\catalog\product.php on line 185
Apache still seems to think 1000 is enough; Its error log tells me "Input variables exceeded 1000"

Could it be pulling the setting from somewhere else?

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am

Post by Sokonomi » Wed Mar 21, 2018 8:10 am

I have managed to solve it by opening 'httpd.conf' of apache, searching for 'AllowOverride' and adding 'php_value max_input_vars 4000' on a new line.

For some reason the one in PHP.ini did not stick.

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am
Who is online

Users browsing this forum: No registered users and 14 guests