Post by enduroforum » Sun Jan 07, 2018 9:38 am

Hi there

Within "My Account", "Wish List", "Address Book", "Downloads", ... all are empty (which is correct) and all sites show the correct head line. BUT: All sites say: "Your shopping cart is empty!"
I checked the language files. The correct phrase is in there for each site...
Any idea what could possibly cause such behavior?

Thanks,
Mike.

Newbie

Posts

Joined
Thu Nov 23, 2017 12:15 am

Post by straightlight » Sun Jan 07, 2018 8:44 pm

Followed is a solution to fix this issue: viewtopic.php?f=202&t=200617#p707947

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by enduroforum » Mon Jan 08, 2018 9:15 pm

Thanks for your reply.

I followed the instructions and added the line of code into category.php, search.php, special.php and manufacturers (found in \catalog\controller\product\). Subsequently, I cleared the cache from witihin the admin's dashboard.
Unfortunately, nothing changed. The issue still exists.

Am I missing a step?
The link you provided suggests "refreshing opencart modification afterwards". I am not sure what is meant by this.

Thanks.

Newbie

Posts

Joined
Thu Nov 23, 2017 12:15 am

Post by straightlight » Tue Jan 09, 2018 7:30 am

Also clear your cache from your admin - > extensions - > modifications - > refresh button.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by enduroforum » Wed Jan 10, 2018 12:51 am

Hi

I am sorry to say that but the issue still exists...

Newbie

Posts

Joined
Thu Nov 23, 2017 12:15 am

Post by Evilonion » Wed Jan 10, 2018 1:47 am

have you cleared your browser cache?
I did the same patch and worked ok for me?

Active Member

Posts

Joined
Sun Oct 30, 2016 8:07 pm

Post by enduroforum » Wed Jan 10, 2018 3:43 am

Yes, I did.
I even used another browser on a different computer...

Newbie

Posts

Joined
Thu Nov 23, 2017 12:15 am

Post by straightlight » Wed Jan 10, 2018 7:14 am

Ensure your system/storage folder is located outside your public_html and to modify your config.php and admin/config.php file for your new DIR_STORAGE as well as editing your .htaccess file by removing the ^system/storage's entire line . Then, re-clear your entire OC cache.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by enduroforum » Wed Jan 10, 2018 5:42 pm

OK, I did that.
Still: No change. :(

Newbie

Posts

Joined
Thu Nov 23, 2017 12:15 am

Post by straightlight » Wed Jan 10, 2018 6:17 pm

Ensure your storage folder has writable access with recursive settings from at least 0755.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by enduroforum » Thu Jan 11, 2018 2:53 am

This is also the case. But nevertheless: The issue remains. :-(
I just installed a fresh version of OC 3.0.1.1 which runs without this problem.

Newbie

Posts

Joined
Thu Nov 23, 2017 12:15 am

Post by dpanderson » Wed Apr 04, 2018 2:10 am

I had the same widespread issue as original poster. Your fix works for me for most locations, but not for "Wishlist" and "Address Book". Does anyone know what files need to be modified to keep the "Your shopping cart is empty" message from appearing in an empty wishlist or address book?

Newbie

Posts

Joined
Sat Mar 31, 2018 10:40 pm

Post by Devin1 » Thu Aug 02, 2018 1:28 pm

Hi
Also, it would be nice to have a list view of the refine search subcategory images & select the right choice the subcategory too - can this be done? I have a genuine reason to ask.

NORTH LAKE TAHOE


Newbie

Posts

Joined
Thu Aug 02, 2018 1:05 pm

Post by vladborozna » Fri Sep 21, 2018 2:06 am

Hi guys!! Go to system/config/catalog.php.

Change:
'controller/*/after' => array(
'event/debug/after'
)


To:
'controller/*/after' => array(
0=> 'event/language/after',
1=> 'event/debug/after',
)


Solved the problem in this way ;D

Newbie

Posts

Joined
Fri Sep 21, 2018 2:03 am

Post by glolar » Sun Jan 06, 2019 12:26 pm

Bravo vladborozna,

I always hate to modify core files, but your solution appears to have fixed this issue on all empty pages!

Thank you!

User avatar
Active Member

Posts

Joined
Thu Jul 29, 2010 12:35 pm
Location - San Diego, CA
Who is online

Users browsing this forum: No registered users and 15 guests