Post by dynamodaveo » Wed Sep 13, 2017 5:26 pm

Hi Fellas,

Emails going to Admin to inform them of a new order is not showing the OPTIONS values (Small / Medium / Large)

The new OC 3.0.2.0 uses the .Twig extension to generate a lot of stuff.
I understand there is an interface in Admin to edit these files.

However the file in question order_alert.twig
contains,

{% for product in products %}
{{ product.quantity }}x {{ product.name }} ({{ product.model }}) {{ product.total }}
{% if option %}
{% for option in product.option %}
- {{ option.name }} {{ option.value }}

But there aint no options showing up on the admin order.
They are present on the info going to the Customer though.

Anyone got a fix or experiencing same?
Thanks a mill,

D

Newbie

Posts

Joined
Mon Jan 18, 2010 11:49 pm

Post by straightlight » Tue Nov 14, 2017 9:58 am

A clue.

In catalog/view/theme/<your_theme>/template/mail/order_alert.twig file,

find:

Code: Select all

{% if option %}
{% for option in product.option %}
	- {{ option.name }} {{ option.value }}
{% endfor %}
{% endif %}
replace with:

Code: Select all

{% for option in product.option %}
    {% if option %}<br />
	- {{ option.name }} {{ option.value }}
    {% endif %}
{% endfor %}
This should rectify the issue,

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Wed Nov 15, 2017 8:54 am


The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 10 guests