Post by ilyaspark » Sat Aug 12, 2017 7:14 pm

I changed a design of "common/column_left.twig" template to make my category page look better. I finished and my category page works good, but then I decided to check my homepage and saw this:

'Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'Unable to find template "common/column_left.twig" (looked into: /home/fyewhzjp/mykeystore.ru/catalog/view/theme).' in /home/fyewhzjp/mykeystore.ru/system/library/template/Twig/Loader/Filesystem.php:215 Stack trace: #0 /home/fyewhzjp/mykeystore.ru/system/library/template/Twig/Loader/Filesystem.php(139): Twig_Loader_Filesystem->findTemplate('common/column_l...') #1 /home/fyewhzjp/mykeystore.ru/system/library/template/Twig/Environment.php(312): Twig_Loader_Filesystem->getCacheKey('common/column_l...') #2 /home/fyewhzjp/mykeystore.ru/system/library/template/Twig/Environment.php(378): Twig_Environment->getTemplateClass('common/column_l...', NULL) #3 /home/fyewhzjp/mykeystore.ru/system/library/template/twig.php(33): Twig_Environment->loadTemplate('common/column_l...') #4 /home/fyewhzjp/mykeystore.ru/system/library/template.php(51): Template\Twig->render('common/column_l...', '1') #5 /home/fyewhzjp/mykeystore.ru/system/engine/loader.php(125): Template->render('com in /home/fyewhzjp/mykeystore.ru/system/library/template/Twig/Loader/Filesystem.php on line 215'

I don't understand what is wrong because "common/column_left.twig" exists and works on my category page but seems like do not work everywhere where I don't use left column. Please help me.
I even tried to change column_left.twig back to original but it didn't work.

Newbie

Posts

Joined
Tue Jul 25, 2017 4:15 pm

Post by WaxedPerfection » Mon Aug 14, 2017 2:05 am

Could be of help
Johnathan wrote:
Fri Aug 11, 2017 6:57 am
Twig has caching, which is super annoying when you're developing. You can turn off the caching by going to the admin Dashboard area, and clicking the gear icon in the upper-right corner. You can turn the caching off (and refresh it) in there.
put your original file back and clear the TWIG Cache

New member

Posts

Joined
Sun Mar 26, 2017 8:23 pm
Who is online

Users browsing this forum: No registered users and 5 guests