Post by serhio.ko » Fri Nov 02, 2018 1:08 am

HELLO!

When I confirm my order it goes internal server error 500. It is not always, but half the time.
Error in the browser console:

Code: Select all

VM45:1 GET http://SITE/index.php?route=extension/payment/cod/confirm 500 (Internal Server Error)
following the link:

Code: Select all

<b>Notice</b>: Undefined index: payment_method in <b>/data/www/SITE/catalog/controller/extension/payment/cod.php</b> on line <b>10</b>[]
or

Code: Select all

{"redirect":"http:\/\/SITE\/index.php?route=checkout\/success"}
Please tell me a solution.

Newbie

Posts

Joined
Thu Oct 18, 2018 6:26 pm

Post by straightlight » Sat Nov 03, 2018 4:23 am

Ensure your config.php, admin/config.php and .htaccess files are properly configured with SSL. Posted in Bug Reports, not a bug.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by serhio.ko » Sun Nov 04, 2018 5:40 pm

I figured it out. The cause of the error is the module that was installed earlier. The error disappeared then I turned off the module.

Newbie

Posts

Joined
Thu Oct 18, 2018 6:26 pm
Who is online

Users browsing this forum: No registered users and 4 guests