Post by Counting Pounds » Fri Apr 13, 2018 8:41 pm

Hi, I persevered with OC because I had v1.5 and it was excellent. If I was a new user, I'd have ditched OC as buggy software. This is because the OC installer didn't detect a hosting permission problem, installed ok but wouldn't process orders.

  • I have a "default" shared hosting setup.
  • I made a "default OC install". {PHP 5.6}.

The Ajax based cart failed to process an order, getting as far as order placement before hanging. It seems that my hosting Co's PHPmailer setup has the wrong permissions.

During install, the OC cart installer should check this and advise. Furthermore, I am sure that email issues could arise after a working system has been commissioned, so , a good mod would be an error message built into the cart that advised the email problem, rather than it just hanging. It would also have been handy to have been able to send a "test email" from within the OC Admin area to Admin which proves email is working.


Posts

Joined
Wed Nov 06, 2013 7:55 am

Post by straightlight » Fri Apr 13, 2018 8:49 pm

I am not sure I understand how relative this inquiry would be relative to an OC bug since you are using PHPMailer which this extension does not come inclusively in the ZIP file of Opencart when downloading the platform.

In addition, as you said, there was a host restriction issue on your end that prevented to use a specific feature in Opencart but this restriction has not been reported for everyone but simply on your end which means this issue is rather specific.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 5 guests