Post by knightuit » Sat Sep 16, 2017 5:52 pm

Hi all & supporter!
I have an error with affiliate module Opencart V3.0.1.1.
I don't have create affiliate profile and error notice: Undefined property: Proxy::getAffliateByTracking in /admin/controller/customer/customer.php on line 1077.
:( :( :( :(
Can you help me?

Attachments

Screen Shot 2017-09-16 at 4.44.39 PM.png

Error - Screen Shot 2017-09-16 at 4.44.39 PM.png (94.72 KiB) Viewed 507 times


Newbie

Posts

Joined
Sat Sep 16, 2017 5:46 pm

Post by straightlight » Tue Nov 14, 2017 9:36 am

It would be best to upgrade to the latest release of Opencart since the affiliate feature is no longer being used as a stand-alone solution.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by jpedroza2k » Thu Dec 28, 2017 2:33 am

I am running the current version of OpenCart (3.0.2.0 at the time of this writing) and this error is still present. When trying to save a user with Affiliates as the group the following error is thrown:

Code: Select all

Notice: Undefined property: Proxy::getAffliateByTracking in /var/www/opencart/admin/controller/customer/customer.php on line 1077
Edit: I tested the same installation on a server with PHP 7 and the error is not thrown. Is this possibly a PHP version issue?

Edit II: I grepped for the function in the opencart directory and the only instance was in the customer.php where the function is called. Then I checked on my staging server and there was also a definition of the function in opencart/admin/model/customer/customer.php. I copied that file to production, replacing the customer.php file, and now it works. Verify that you have a good copy of that file.

New member

Posts

Joined
Wed Jul 12, 2017 1:45 am

Post by straightlight » Thu Dec 28, 2017 3:00 am

Edit II: I grepped for the function in the opencart directory and the only instance was in the customer.php where the function is called. Then I checked on my staging server and there was also a definition of the function in opencart/admin/model/customer/customer.php. I copied that file to production, replacing the customer.php file, and now it works. Verify that you have a good copy of that file.
Part of the periodic change required by the Opencart team announced on one of my recent topics in the General Discussion section of the forum. Thanks for your feedback on this.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 9 guests