Post by gottabjoaken » Wed Sep 06, 2017 4:27 pm

Version testing: 3.0.2.0
1.
When you try to edit an inserted Language Edit, on Save the form is blanked out and returns an Error "Key must be > 3 and < 64 characters.
The change is not made.
2.
If the text you are changing has line breaks (<p....</p>), you cannot put these into your replacement text, and you lose the paragraph spacing.

for eg: account/logout key: text_message: "<p>You have been logged off your account. It is now safe to leave the computer.</p><p>Your shopping cart has been saved, the items inside it will be restored whenever you log back into your account.</p>"

regards
Ken Hall-Patch

New member

Posts

Joined
Tue Apr 24, 2012 7:03 am

Post by straightlight » Thu Sep 28, 2017 10:41 am

Regarding step 1. do you notice any appearing error logs when you try to make those changes from the language editor?

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by gottabjoaken » Fri Sep 29, 2017 5:54 pm

Error messages... Not that I know about.
Ken

New member

Posts

Joined
Tue Apr 24, 2012 7:03 am

Post by straightlight » Fri Sep 29, 2017 10:08 pm

For number 1, more information would be needed. As for number 2, that is correct and also not a bug. HTML characters cannot be set in those fields when assigning your routes. Only text characters.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by gottabjoaken » Sat Sep 30, 2017 7:47 am

Thanks Starlight.

1. I am not sure how to provide more information. Try a vanilla demo system and the problem is experienced.
I did that as soon as I found it on my test site.
When you get a fatal error on first use of something new you don't feel inclined to persue it too much. Back to the developer.

For the second problem with the inability to input or even save existing html., if you say this is not a bug then the problem has to be categorised as a serious design error. (I would prefer to have my design error called a programmig bug thanks).

You are unable to save an existing text correctly, let alone add some pleasantly formatted text.

This definitely needs attention if the Language Editor is to be functional.

Ken

New member

Posts

Joined
Tue Apr 24, 2012 7:03 am

Post by boyjah » Sat Nov 04, 2017 3:06 am

I am having the same problem, OpenCart Version 3.0.2.0. Trying to edit language modifications already made leads to error. On Save all fields are cleared and I get an error telling me that fields cannot be empty.

Newbie

Posts

Joined
Tue May 02, 2017 12:55 pm

Post by straightlight » Sat Nov 04, 2017 3:45 am

boyjah wrote:
Sat Nov 04, 2017 3:06 am
I am having the same problem, OpenCart Version 3.0.2.0. Trying to edit language modifications already made leads to error. On Save all fields are cleared and I get an error telling me that fields cannot be empty.
I do not see the exact text in v3.0.2.0 release where it has the criteria: cannot be empty . Can you provide the exact error message please?

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by boyjah » Tue Nov 07, 2017 10:32 am

I am able to make a new translation string by clicking the + button on the Language Editor. I can save it and I can see the new language string on the site. But when I try to edit that text string, all fields are cleared when I save it and the error message is "Key must be between 3 and 64 characters!". It says this because that field (along with others) are now blank. I have cleared all caches, refreshed modifications numerous times, quit browser and restarted computer and still the same result.

Attachments

CreatedTranslation.png

Successfully created new translation - CreatedTranslation.png (39.97 KiB) Viewed 248 times

SavingTranslation.png

Result when I try to edit and save - SavingTranslation.png (40.22 KiB) Viewed 248 times


Newbie

Posts

Joined
Tue May 02, 2017 12:55 pm

Post by straightlight » Tue Nov 07, 2017 12:29 pm

Recent modifications were made on Github to the admin/view/template/design/translation_list.twig and translation_form.twig files. Replace these two files from:

https://raw.githubusercontent.com/openc ... _form.twig
https://raw.githubusercontent.com/openc ... _list.twig

Clear all caches. See if that resolves the issue afterwards.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by boyjah » Tue Nov 07, 2017 2:07 pm

YES! That solved the problem. THANK YOU VERY MUCH!!!

Newbie

Posts

Joined
Tue May 02, 2017 12:55 pm

Post by straightlight » Tue Nov 07, 2017 7:59 pm

Outstanding. Other topics have now been notified about these fixes.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by CSR » Mon Nov 13, 2017 10:38 pm

Thank you for your input. I had noticed the same issue when trying to edit the language files from within the Admin area. This error has now been resolved :)

CSR
Newbie

Posts

Joined
Sun Mar 19, 2017 3:12 am
Who is online

Users browsing this forum: No registered users and 8 guests