Post by labeshops » Tue Jul 25, 2017 3:21 am

When moving the storage folder manually after you install 3.0.2.0, there is an un-needed .DIR_SYSTEM in the path that needs to be removed.

You need to delete the .DIR_SYSTEM . in front of the path on the line in both config files. What is happening is though the instructions tell you to change the line to reflect the correct position of storage after you move it, with it calls the system directory, it mangles the link to repeat your root directory twice.

So in both config.php and admin/config.php change:

define('DIR_STORAGE', DIR_SYSTEM . '/path/instructions/giveyou/storage/');

to

define('DIR_STORAGE', '/path/instructions/giveyou/storage/');

Otherwise you get a lot of unable to locate errors in both front and backend.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by straightlight » Sat Dec 02, 2017 3:25 am

You need to move your system/storage folder outside your public_html / www / htdocs folder(s) and create your storage folder by setting the folder permissions recursively to 0755 (if not working with 0755 - 077). Then, in your config.php and admin/config.php files, you need to make the adjustments accordingly for the new storage folder path. This should rectify the issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by showandshine86 » Sun Dec 03, 2017 8:05 am

How do you do this is there a how to guide. Also could this be the reason behine me getting these errors on my site

Http:www.edautosupplies.co.uk


Posts

Joined
Sun Dec 03, 2017 6:04 am

Post by IP_CAM » Tue Dec 05, 2017 11:26 am

This could possibly solve your problem!
Good Luck!
Ernie
Remove "Important Security Notification" 3.x
https://www.opencart.com/index.php?rout ... n_id=31807

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Lloydinator » Thu Jul 19, 2018 4:24 am

THANK YOU!!!!! This was hurting my head and I thought I was some kind of n00b for not understanding file systems or something. It just never made sense how Opencart couldn't find the folder.

Newbie

Posts

Joined
Thu Jul 19, 2018 3:28 am
Who is online

Users browsing this forum: No registered users and 11 guests