Post by Ki2bz8NnWWc2Vl7Kei6R » Wed May 18, 2016 3:10 am

I confirm it, too.

Adding ssl:// in front of the host name solves the problem.
OpenCart Version: 2.1.0.1


Posts

Joined
Wed May 18, 2016 2:57 am

Post by Sinto001 » Wed Jul 13, 2016 10:42 pm

I tried this method but I am still getting error in Opencart contact form. I am using Opencart 2.1.0.2. And the error I am getting on form submission is:
Notice: Error: RCPT TO not accepted from server! in /home/sfxc1Xdfr4/public_html/onlineshop/system/library/mail.php on line 346
Last edited by straightlight on Wed Aug 10, 2016 12:42 am, edited 1 time in total.
Reason: Added quote tags.

New member

Posts

Joined
Thu Oct 16, 2014 6:29 pm

Post by gowtham.dandu » Tue Aug 09, 2016 9:45 pm

Still, I am getting the same error
**Notice: Error: MAIL FROM not accepted from server! in /var/www/html/order-online/system/library/mail.php on line 328**
My OC-Version - **2.1.0.1**

**My Mail Settings are**
Mail Protocol : SMTP
Mail Parameters : -fadmin@restroappz.xyz
SMTP Hostname : ssl://smtp.yandex.com
SMTP Username : admin[at]restroappz[dot]xyz
SMTP Password : ******
SMTP Port : 465
SMTP Timeout : 5
Last edited by straightlight on Wed Aug 10, 2016 12:43 am, edited 2 times in total.
Reason: Added quote tags and edited email address.

Newbie

Posts

Joined
Tue Aug 09, 2016 9:39 pm

Post by alirj2010 » Wed Jan 18, 2017 4:13 am

As crazy as it would sound, if you have not changed anything yet please try only setting the first tap to mail instead of SMTP in opencart setting. somehow this was my solution without having to dig into the codes.

Newbie

Posts

Joined
Thu Jun 02, 2016 5:49 am

Post by Khal » Mon Feb 20, 2017 5:04 pm

I am getting the same error on my OC2.0.1.1 when trying to set up SMTP. I have tried all the fixes given on this thread, except changing the server name in mail.php, but I am still getting the same error message: Error: EHLO not accepted from server!

Has anyone found another fix that works other than those given here?

Thank you

Active Member

Posts

Joined
Thu May 24, 2012 9:24 pm
Location - Teesside, UK

Post by peppesbodega3 » Sat Mar 11, 2017 7:29 am

Confirm that it worked for me to with OpenCart 2.3.0.2 on Inmotion Hosting server.

I put the ssl:// before my hostname:
SMTP Hostname: ssl://securexxx.inmotionhosting.com

Only tried on the contact page so hope it works on the rest as well. Nothing worked before.

Newbie

Posts

Joined
Sun Jan 29, 2017 1:41 am

Post by jepi » Thu Oct 19, 2017 7:12 am

Hi guys, I had set mail server like you guys, but it still send to spam folder, any idea?

Newbie

Posts

Joined
Thu Sep 14, 2017 5:38 am

Post by atlterry » Wed Dec 13, 2017 10:02 am

I'm using 1and1 and I tried all the combinations - support informs me to set auth = true in the smtp.php script but I find that suspect.

ocart Version 3.0.2.0

My settings...
SMTP
-fsales@domain.com
tls://smtp.1and1.com (tried ssl)
sales@domain.com
passwd
587
5

Error.log
[Wed Dec 13 01:37:53.890852 2017] [proxy_fcgi:error] [pid 63256:tid 139974158489344] [client 73.54.186.228:46096] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught exception 'Exception' with message 'Error: EHLO not accepted from server!'

Newbie

Posts

Joined
Wed Dec 13, 2017 3:09 am

Post by straightlight » Wed Dec 13, 2017 11:38 pm

Error: EHLO not accepted from server!'
Contact your host or google for your email account parameters settings.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by slewman » Wed Aug 15, 2018 12:43 pm

#dwsalter settings worked for me also. V2.0.1.2

Newbie

Posts

Joined
Thu Aug 29, 2013 12:12 am
Who is online

Users browsing this forum: No registered users and 21 guests