Post by greensolef » Thu Oct 25, 2012 11:04 am

Hi,
I need your help guyz!

After clicking the button in contact page, I get this this error that says:

Code: Select all

Notice: Error: EHLO not accepted from server! in /home/kraftpap/public_html/system/library/mail.php on line 200
I have already setup the smtp mail settings on the opencart admin:
I have attached the screenshot mail setup.
(http://forum.opencart.com/download/file.php?id=14208)

Please help.

Attachments

screenshot.png

screenshot mail setup - screenshot.png (63.27 KiB) Viewed 51011 times


New member

Posts

Joined
Tue Jul 03, 2012 2:20 pm

Post by matthewkris » Tue Nov 06, 2012 1:15 am

I'm having this exact same issue. Has anyone successfully used Google to send mail?

Newbie

Posts

Joined
Wed Oct 31, 2012 9:33 am

Post by rph » Tue Nov 06, 2012 3:36 am

You probably don't have a fully qualified domain name (possibly related to SERVER_NAME). Ask your host for help.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by nav_vij » Wed Nov 07, 2012 4:07 pm

I'm facing the same issue guys. Mail is received while i'm using the forgot password option, but getting this error while registering new user. When i use Mail then i don't receive any mails. I'm using smtp now, and its giving me this error.
I'm stuck with this for last couple of days, please help me guys

Newbie

Posts

Joined
Wed Nov 07, 2012 3:16 pm

Post by rph » Thu Nov 08, 2012 1:09 am

As a possible workaround, edit /system/library/mail.php and change:

Code: Select all

fputs($handle, 'EHLO ' . getenv('SERVER_NAME') . $this->crlf); 
To (assumes server using IPv4):

Code: Select all

fputs($handle, 'EHLO [' . getenv('SERVER_ADDR') . ']' . $this->crlf); 
You should also use phpinfo to find out what your SERVER_NAME and SERVER_ADDR values are (they'll be in the Environment table).

More info on HELO/EHLO standards can be found in RFC 2821 Section 4.1.1.1.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by SiriusBlackx » Wed Jan 09, 2013 7:56 pm

Try This:

Hi,
i have the same problem so i found this answer to my problem:
What port number you have set in SMTP field? Try port 465 if you have default 25 as SMTP port.

In case use gmail account was SMTP:

Mail Protocol: SMTP
Mail Parameters: (blank)
SMTP Host: ssl://smtp.gmail.com
SMTP Username: (yours)
SMTP Password: ****
SMTP Port: 465
SMTP Timeout: 5

SMTP Host: ssl://smtp.gmail.com

The ssl:// before the host makes all the diference.

Newbie

Posts

Joined
Sat Dec 15, 2012 1:12 am

Post by imsir » Mon Feb 11, 2013 8:04 am

I want to send email through gmail smtp.

My settings:

smtp: smtp.gmail.com
port: 25

Notice: Error: AUTH LOGIN not accepted from server! in D:\server\Apache2.2\htdocs\amonshop\system\library\mail.php on line 217

When I use ssl smtp:

ssl://smtp.gmail.com
port: 465

Than I get other error:
Warning: fsockopen() [function.fsockopen]: unable to connect to ssl://smtp.gmail.com:465 (Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?) in D:\server\Apache2.2\htdocs\shop\system\library\mail.php on line 153Notice: Error: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP? (10) in D:\server\Apache2.2\htdocs\shop\system\library\mail.php on line 156

When I set to "mail" instead of smtp, contact form works, but i don't get any email.

Any advices?

New member

Posts

Joined
Tue Jan 29, 2013 12:20 am

Post by imsir » Mon Feb 11, 2013 8:42 am

Ok. I tried gmail and hotmail servers. They do not work.

I downloaded argosoft mailserver and setup my localhost mail server and stuff works. What would be the problem for me that gmail or hotmail doesn't work? Am I blacklisted or something? Gmail worked on wordpress like 1 week ago.

New member

Posts

Joined
Tue Jan 29, 2013 12:20 am

Post by natedeveloper » Thu Feb 21, 2013 12:39 am

I am running into this problem. Just tested SMTP auth from command line. Seems the handshake is not waiting for proper 220 before sending HELO. My server is failing this referencing section 3.1 of RFC 2821.

Newbie

Posts

Joined
Wed Jan 23, 2013 4:17 am

Post by imsir » Thu Feb 21, 2013 1:41 am

try your isp's smtp. gmail and hotmail are so unreliable.

New member

Posts

Joined
Tue Jan 29, 2013 12:20 am

Post by andersonnarciso » Sun Mar 10, 2013 11:33 am

rph wrote:As a possible workaround, edit /system/library/mail.php and change:

Code: Select all

fputs($handle, 'EHLO ' . getenv('SERVER_NAME') . $this->crlf);
To (assumes server using IPv4):

Code: Select all

fputs($handle, 'EHLO [' . getenv('SERVER_ADDR') . ']' . $this->crlf);
You should also use phpinfo to find out what your SERVER_NAME and SERVER_ADDR values are (they'll be in the Environment table).

More info on HELO/EHLO standards can be found in RFC 2821 Section 4.1.1.1.
Thanks man, work for me in page forget password, but for send e-mail of contact page "Notice: Error: MAIL FROM not accepted from server! in /home/storage/f/52/81/shop/public_html/system/library/mail.php on line 298"

New member

Posts

Joined
Mon Jan 16, 2012 12:12 pm

Post by rph » Tue Mar 12, 2013 12:19 am

Probably has to do with the way your host configured things. OpenCart sends enquiry emails out as being "from" the person submitting them even though it's actually from you.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by carlpotts » Fri Aug 16, 2013 5:20 pm

Thanks folks, I also ran into the same problem a bit of tinkering with my SMTP settings resolved the issue for me

Newbie

Posts

Joined
Mon Aug 05, 2013 8:44 pm

Post by itezora » Sun Nov 24, 2013 4:59 pm

I had the same issue using Justhost, adding ssl:// to my server name fixed it !

Newbie

Posts

Joined
Sat Oct 12, 2013 6:29 am

Post by jet737 » Thu Jul 17, 2014 3:32 pm

Hello guys,

isn't there any fully functional solution? I didn't have any problem until a few weeks ago and then suddenly this mail server problem has been occured. Exceptional, once or twice I replaced mail.php from my backup and fixed it but now it doesn't work.

I'm using ISP based mail server and there wasn't change any settings on my ISP. All settings are the same since I had setup emails.

I didn't try to change SERVEr_NAME to SERVER_ADDR becouse I don't think so it does work, what could be change about server definition? also doesn't work port value!

I really begin to hate this opencart program! When I think about "oh great everything is fine"...then a problem occurs!
I hope you guys find a solution.

Newbie

Posts

Joined
Wed Feb 12, 2014 9:42 pm

Post by haxcop » Thu Sep 11, 2014 4:43 pm

HEllo to this issue HELO is very simple if you have a vps.
just add ssl:// before your server name and its done.
ie
smtp
yourserver.hostingprovider.com
should be
ssl://yourserver.hostingprovider.com

lookyourbike.com

Save Time and the hassle of the legal stuff on your site with this Amazing Guys of
Iubenda http://bit.ly/2xKZBKh


New member

Posts

Joined
Tue Jan 14, 2014 9:38 pm
Location - Dublin

Post by dwsalter » Thu Feb 12, 2015 12:57 am

Here is what finally worked for me ...
Capture.PNG

Capture.PNG (23.09 KiB) Viewed 39190 times


Newbie

Posts

Joined
Wed Jan 28, 2015 12:53 pm

Post by rahilkasimi » Tue Sep 15, 2015 10:11 pm

Excellent!! This settings worked for me too... Great!

Newbie

Posts

Joined
Tue Sep 15, 2015 10:10 pm

Post by civanescu » Thu Feb 25, 2016 12:58 am

I confirm that the solution "ssl://mailserver" is working!

Thanks,
K

Newbie

Posts

Joined
Wed Dec 09, 2015 6:28 pm

Post by afaslan » Tue May 10, 2016 10:46 pm

I confirm that it worked for me too! My configuration is as in the image. My system is in Turkish. But you can guess all parameter meanings. :)

My opencart version is 2.2.0.0

Attachments

gmail_settings.PNG

gmail_settings.PNG (25.42 KiB) Viewed 28407 times


Newbie

Posts

Joined
Tue May 10, 2016 10:38 pm
Who is online

Users browsing this forum: No registered users and 18 guests