Post by stakon » Sat Jun 23, 2018 6:24 pm

Dear sirs, hi from greece

I manage an opencart store under the domain yourcare.gr

The store hosted on a Hetzner vps, but after a power failure on Hetzner datacenter I comletely lost the server, and migrate to a new one. On the new server i reinstall everything from backup.

Everything worked fine except the search feature of opencart..

So when you try to search something like http://yourcare.gr/index.php?route=prod ... rch=Korres

You get an error Page starting with the following lines

encoding|s:4:"gzip";device|s:7:"desktop";ssb_page_type|s:7:"product";language|s:2:"el";currency|s:3:"EUR";cart|a:0:{}ssb_page_data|a:66:{s:11:"breadcrumbs";a:2:{i:0;a:3:{s:4:"text";s:12:"Αρχική";s:4:"href";s:18:"http://yourcare.gr";s:9:"separator";b:0;}i:1;a:3:{s:4:"text";s:102:"Apivita Tonic Mountain


Any ideas how to resolve the issue????

I am running centos 7, with apache Web server 2.4.6. Opencart 1.5.6

Thank you for your time

Newbie

Posts

Joined
Wed Jan 29, 2014 2:22 am

Post by straightlight » Sat Jun 23, 2018 7:37 pm

OC upgrade required. Issue caused by abolished serialized function.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by stakon » Sat Jun 23, 2018 9:06 pm

Thank you for your answer..

For sure my site needs upgrade, but i think this is not the problem since my site worked fine with this configuration before the failure...

I think there is something else that i dont take care...

Newbie

Posts

Joined
Wed Jan 29, 2014 2:22 am

Post by straightlight » Sat Jun 23, 2018 11:24 pm

What is the PHP version installed?

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by stakon » Sun Jun 24, 2018 1:31 am

Php Version 5.4.16

Newbie

Posts

Joined
Wed Jan 29, 2014 2:22 am

Post by stakon » Sun Jun 24, 2018 1:57 am

I get that error in log file when i execute the search

[Sat Jun 23 20:34:14.812886 2018] [:error] [pid 16829] [client 66.249.81.127:41780] PHP Fatal error: Class 'Controllerproductsearch' not found in /var/www/html/yourcare.gr/public_html/vqmod/vqcache/vq2-system_engine_front.php on line 41, referer: http://yourcare.gr/

Newbie

Posts

Joined
Wed Jan 29, 2014 2:22 am

Post by straightlight » Sun Jun 24, 2018 2:16 am

Caused by an installed extension.

Code: Select all

Controllerproductsearch
should be:

Code: Select all

ControllerProductSearch
Also take note that PHP v5.4x has now become below OC requirements to operate the platform. Minimum v5.6 is now required as even PHP 7 will be an obligation in the future.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by stakon » Sun Jun 24, 2018 11:16 pm

Finally i resolve the issue...

just clean the vqmon cache...

Thanks for your help

Newbie

Posts

Joined
Wed Jan 29, 2014 2:22 am

Post by IP_CAM » Mon Jun 25, 2018 4:54 am

Minimum v5.6 is now required as even PHP 7 will be an obligation in the future.
Well, just to inform you, your OC v.1.5.6.4 should work flawless up to PHP Version v.7.1.x,
only the /system/library/encryption.php file needs an update. It's linked below:
Change library/encryption.php compatible to PHP 7.x
https://www.opencart.com/index.php?rout ... n_id=34060
---
The default OC Shop Install Routine also needs to be updated, if a new full installation
is made by use of 1.5.6.x and PHP v.7.x. And a couple of Extensions might not work as well,
but I only found two, and for one of them (SqlBuddy), I found an upgraded Version on the Web.

A working Installation Routine is available on request only, since my installation Code
needs to be hardcoded/linked to it's future Site Name, to function as planned, and
without a Site Link, eventually redirecting a User to install again ... ! :o
Ernie
---
Image

Attachments

system_settings_1565.jpg

system_settings_1565.jpg (56.56 KiB) Viewed 273 times


Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 66 guests