Post by synapseindia » Thu Jun 21, 2018 6:16 pm

Hi,

I am facing an issue in opencart 1.5.6 version .
Issue -
When we click on any product it is redirecting based on SEO Keyword correctly.
For example -
https://www.xyzanywebsite.com/Bubbles

When we go to search page and click on result products it is redirecting wrong (Added index.php?_route_=Name).
For example -
https://www.xyzanywebsite.com/index.php ... ch=Bubbles

Any fixes ?

Thanks in advance .

User avatar
Active Member

Posts

Joined
Thu Apr 05, 2018 2:27 pm

Post by MrPhil » Thu Jun 21, 2018 9:33 pm

Can you clarify something? If I understand you, you have SEO and domain/keyword goes to the right page. When you do a search for that keyword, what is the exact link returned by the search, and is that redirected/rewritten when you click on it? In other words, is the erroneous index.php?name etc. business in the link provided by search, or does it get redirected when you click on it?

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by synapseindia » Fri Jun 22, 2018 1:08 pm

From search page . It is redirecting with "_route_" parameter .
Example -
index.php?_route_=bubble

User avatar
Active Member

Posts

Joined
Thu Apr 05, 2018 2:27 pm

Post by MrPhil » Fri Jun 22, 2018 11:08 pm

So the link given by the search page already has the _route_ stuff in it, rather than your .htaccess is rewriting it? That sounds like a bug in SEO support in search, if it should be just giving a URI of "/Bubbles" or whatever.

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm
Who is online

Users browsing this forum: No registered users and 18 guests