Post by Penneeo » Thu Jun 21, 2018 12:19 pm

My site Summit31.com is Opencart 1.5. I can go to "contact us" and get an email from the part of the site but it is no longer sending mail from a new customer sign on or a new order. I have tried SMTP with my providers SMTP info and just mail. But nothing. What am I missing? ??? ??? ???

Newbie

Posts

Joined
Wed Jun 20, 2018 10:28 am

Post by straightlight » Thu Jun 21, 2018 10:54 pm

What am I missing?
- To provide the full OC version (4 decimals as per the opencart.com's downloads page describes)
- To check the error / access logs once the email transaction being sent or failed on being sent from your server
- The exact route location from where the issue you are describing is actually originating from
- Trying a newer OC version on a test server / folder noticing if the issue still persists

As a new forum user, please follow the forum rules before posting.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Penneeo » Sun Jun 24, 2018 10:56 am

Cheeky,
- version OC 1.5.6
- error report

2018-05-24 5:15:28 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-05-24 5:18:48 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-19 4:55:44 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-19 4:56:08 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-19 4:57:52 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-19 23:12:39 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-19 23:13:05 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-19 23:16:54 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-20 1:07:21 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-20 1:07:40 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-20 1:08:28 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-20 1:09:25 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-20 1:11:05 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-20 2:15:58 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-20 2:17:19 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-20 2:26:28 - PHP Notice: Error: DATA not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 380
2018-06-21 4:16:20 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
2018-06-22 2:00:16 - PHP Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/summi107/public_html/system/library/mail.php on line 153
2018-06-22 2:00:16 - PHP Warning: fsockopen(): unable to connect to 236.inmotionhosting.com:587 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /home/summi107/public_html/system/library/mail.php on line 153
2018-06-22 2:00:16 - PHP Notice: Error: php_network_getaddresses: getaddrinfo failed: Name or service not known (0) in /home/summi107/public_html/system/library/mail.php on line 156
2018-06-22 2:00:20 - PHP Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/summi107/public_html/system/library/mail.php on line 153
2018-06-22 2:00:20 - PHP Warning: fsockopen(): unable to connect to 236.inmotionhosting.com:587 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /home/summi107/public_html/system/library/mail.php on line 153


I contacted my host and said its a php issue and they said If I'm using php then its an opencart issue. I'm officially confused.

Newbie

Posts

Joined
Wed Jun 20, 2018 10:28 am

Post by straightlight » Sun Jun 24, 2018 8:55 pm

unable to connect to 236.inmotionhosting.com:587
When you contacted your host, either you did not provided these logs or you may have provided these logs but your host provided you the wrong information due to lack of hosting knowledge; an agent working on the wrong spot at the wrong call and that the wrong time probably - if the case. Based on the above quote, the issue you are encountering is with email configurations from your OC admin. Either the hostname or the hostname associated with the port number you've specified cannot be reached.

Ensure to use the right hostname and port number in your OC admin email configuration form. If you are unsure what the configurations are, either look on Google or contact your host to obtain the right email account information. Another location to look would be in your email hosting account information - the one you usually have when purchasing your hosting plans.

It may also be possible that your host may have blocked SMTP communications through that port or the entire mailbox from the web. If so, you may also want to try to initiate your email configuration with sendmail from your OC admin email configuration form. As an alternative solution, since you are using an old version of OC, you may also want to use an extension or replacing the email library class with a newer version noticing if the issue would be resolved - assuming your email configurations are correct and if they are correct.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Penneeo » Mon Jun 25, 2018 2:45 pm

Thank you for your reply.
The error log have been provided and all other details have been verified. We have tweaked and still the following message is still being registered:
2018-06-25 6:33:17 - PHP Notice: Error: EHLO not accepted from server! in /home/summi107/public_html/system/library/mail.php on line 200
What is EHLO?
The mail function use to work until 24 May.
Is this an OC error?

Thanks heaps!

Newbie

Posts

Joined
Wed Jun 20, 2018 10:28 am

Post by victorj » Mon Jun 25, 2018 3:38 pm

Eglo not accepted means your server email does not accept the the original of your mail.
This happens when you sensor a mail from a different domain as your site is a Google mail.
Make sure your shops mail adres is from your domain, as setup in email section of your hosting panel.

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Eigen productie en snelle levering.
https://123-deurrubbers.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by Penneeo » Tue Jun 26, 2018 4:52 pm

Thank you Victor
I'm not using gmail.
I'm using the email address as stated on my server. Its all the same as my hosting panel.

Newbie

Posts

Joined
Wed Jun 20, 2018 10:28 am

Post by straightlight » Tue Jun 26, 2018 8:04 pm

Your host may have done recent changes to the email servers. It would be suggested to contact them in order to obtain the updated email server configurations.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Penneeo » Sat Jun 30, 2018 8:31 am

This is horrible. I have followed the instructions to upgrade my opencart in hopes to fix the mail issue and now I have no site, see error. Please help!!!
Fatal error: Call to undefined function start() in /home/summi107/public_html/index.php on line 19

Newbie

Posts

Joined
Wed Jun 20, 2018 10:28 am

Post by straightlight » Sat Jun 30, 2018 9:32 am

Restore backups from your host console.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Penneeo » Wed Jul 04, 2018 7:09 am

thanks Straightlight that's what we've done.
But back to the drawing board now as the update as per the website crashed the system.

Newbie

Posts

Joined
Wed Jun 20, 2018 10:28 am

Post by straightlight » Wed Jul 04, 2018 8:01 am

It would then be suggested to create a new request in the Commercial Support section of the forum to complete this upgrade as a custom job.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 47 guests