Post by midwestshades » Wed Jun 13, 2018 1:32 am

Opencart version 1.5.6.4
Using paypal pro as payment api.
Hostgator hosting.
Both paypal and hostgator confirm that tls 1.2 is enabled as well as 1.0 and 1.1

During the testing my checkout after hitting confirm the order, it just hangs. I am wondering if something is forcing an earlier version of tls. I have tried editing and adding this (curl_setopt($curl, CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1_2);) to line 156 in catalog/controller/payment/pp_pro.php. Any help on this would be amazing. I am not sure if I need to update to a newer version of opencart before june 30th or if there is some settings I can change. I have a couple weeks until this new setting in paypal is required.

Help please!

Newbie

Posts

Joined
Wed Jun 13, 2018 1:25 am

Post by Johnathan » Wed Jun 13, 2018 5:27 am

TLS issues are NOT related to your OpenCart version, or even the payment gateway you're using. It's related to the SSL/TLS version your server uses for curl connections, which is something your web host controls.

What you'll want to do is contact Hostgator and ask them to make TLS 1.2 the default for all curl connections. If possible, ask them to completely disable TLS 1.0 and 1.1 on your server --- those are no longer considered secure, so they really shouldn't be used at all. There's no reason to keep them enabled (so I'm not sure why hosts are still doing that). Once your host makes TLS 1.2 the default connection, it should work fine in terms of security. You can leave the curl_setopt() line you added in, but it should be unnecessary if your server is properly configured.

If you still get issues after that, then something else is probably going on. For that, look at your System > Error Logs, and see if you can find any errors that happen when the issue occurs. (The easiest way to test this is to clear your log, run a test, then refresh the log page. It should show errors related to that specific attempt.) If you don't understand those errors you can post them here, and hopefully someone will be able to help you.

If you don't get any responses from that, you may have to hire someone to take a look at this issue for you. If you need to find a developer, you should post a request in the OpenCart "Commercial Support" forum, which is checked by a number of OpenCart developers. You can also try checking out the OpenCart "Partners" area.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by midwestshades » Wed Jun 13, 2018 8:16 am

Thank you so much for the reply! I really appreciate that.

Paypal said it must be some thing in my website that is making it use the wrong or outdated tls version. Recommended updating the opencart version.

Hostgator said they will not turn off the tls 1.0 or 1.1 on a shared server. Told me to upgrade to a dedicated server to be able to make that happen.

My buddy mentioned checking the php version and so I did and it was set to 5.2. I upgraded it to 5.4 and ran this test mentioned on this website link below. I failed the test on php 5.2 but passed the test after switching to php 5.4. Received header errors on 5.6. Switched back to 5.4

TEST: How do I check my server for G5 and TLS 1.2 PayPal compatibility? : https://www.aubergine262.com/how-do-i-c ... atibility/

I plan to run some tests on paypals sandbox tonight after the web traffic slows down and see if I have any more problems.

Thank you again!

Newbie

Posts

Joined
Wed Jun 13, 2018 1:25 am
Who is online

Users browsing this forum: No registered users and 17 guests