Post by silvermarbles » Mon Apr 16, 2018 8:39 pm

Hello all
I have removed VAT from the website by
1.) disabling it in Settings > options
2.) setting the tax class to zero
3.) Disabling in Order Totals also

The website now, still removes 20% from the products.
My website is http://puchipetwear.com/

The products on the homepage, or the first one, has the price at £29.17 when in the back office for the product it is £35.
Am i missing something?

Thank you!

User avatar
New member

Posts

Joined
Thu Jun 17, 2010 4:06 am
Location - Telford, Shropshire

Post by straightlight » Mon Apr 16, 2018 9:07 pm

No OC version posted. Forum rules.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by silvermarbles » Mon Apr 16, 2018 9:46 pm

Version 1.5.2.1

User avatar
New member

Posts

Joined
Thu Jun 17, 2010 4:06 am
Location - Telford, Shropshire

Post by Johnathan » Mon Apr 16, 2018 10:12 pm

Taxes are always added on top of prices in OpenCart, so my guess is that you have a mod installed that was taking the product price and assuming it was the taxed cost. Thus, it's taking the cost out when displaying it. Look into the mods you've installed, and see if you can find any that are designed to change the product price.

Image
Image Image Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by silvermarbles » Mon Apr 16, 2018 10:26 pm

Thanks for getting back to me. I've looked in Extensions > Modules and gone through the whole list. I cannot see anything there influences the price. I took a screenshot https://gyazo.com/14c3a2b9bbe45499a7ccf81227c2be75
Can i look anywhere else?

User avatar
New member

Posts

Joined
Thu Jun 17, 2010 4:06 am
Location - Telford, Shropshire

Post by Johnathan » Tue Apr 17, 2018 12:30 am

None of those seem like they would interfere, though I'm not familiar with all of them.

I'd suggest to double-check your vqmods as well, if you have any. Those would be in /vqmod/xml/ on your server. Some extensions have both a vQmod file and an admin panel interface, but some only have the vQmod file, so it may not show up anywhere in your admin panel.

If you can't find anything there, you may need to hire someone to take a look at the issue more in depth for you. If you need to find a developer, you should post a request in the OpenCart "Commercial Support" forum, which is checked by a number of OpenCart developers. You can also try checking out the OpenCart "Partners" area.

Image
Image Image Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by silvermarbles » Tue Apr 17, 2018 12:33 am

Thanks Jonathan, much appreciated. I will have a look through each xml file and see if there is anything here.

User avatar
New member

Posts

Joined
Thu Jun 17, 2010 4:06 am
Location - Telford, Shropshire

Post by silvermarbles » Tue Apr 17, 2018 2:39 am

I just deleted all the files in /vqmod/xml/ and the prices stayed the same. Any other suggestions?

User avatar
New member

Posts

Joined
Thu Jun 17, 2010 4:06 am
Location - Telford, Shropshire

Post by Johnathan » Tue Apr 17, 2018 10:57 pm

Most likely, this means the mod is hard-coded. You'll probably need to hire someone to search through the relevant files and find the code, then disable it.

It also *could* be a 1.5.2 bug, though I don't really think that's the case. I just tested in my localhost 1.5.2 store and it didn't have that issue, but it may be something internal to OpenCart. To fix that you'd need to search the 1.5.2 bug topic (if there is one) or set up a default 1.5.2 installation and see if it exhibits the same issue. You could also try updating to OpenCart 1.5.6.4, which may solve the issue.

Hope that helps

Image
Image Image Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am

Who is online

Users browsing this forum: No registered users and 28 guests