Post by Bzagorec » Mon Nov 20, 2017 5:00 pm

After setting up SSL certificate and creating redirects to https, our website is no longer rendering correctly on IE11 (and older versions - although not on WIN10 machines) and also on Google's Structured data highlighter.
I have attached a comparison image on how do they look on other internet browsers and on IE11.

Thanks in advance.
Cheers,
Blaž

Attachments

ie11_comparison.JPG

ie11_comparison.JPG (333.74 KiB) Viewed 268 times


Newbie

Posts

Joined
Wed Mar 15, 2017 6:03 pm

Post by straightlight » Mon Nov 20, 2017 11:06 pm

Switch back to the default theme and see if you can reproduce this issue. Since you're using a custom theme and using an older version of Opencart, I would still suggest to contact the theme developer from where you originally downloaded this theme in order to resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Bzagorec » Thu Nov 23, 2017 8:20 pm

Let's just say that the creators of the original site and template are no longer available.

I've found out that also in Microsoft Edge and Internet Explorers on Win10 machines, although they have no problem loading the site in general - I can't access the 'My Account' and Checkout page. It returns a INET_E_DOWNLOAD_FAILURE on Edge, and INET_E_INVALID_URL on IE11 (on Win10) when accessing those parts of the shop.

Back to the issue of completely not showing the page correctly in IE on Win7, I've opened up its debugger and refreshed the site.
It returned the error: "$ is undefined" and highlighted the part of code in the embedded picture.

Thanks in advance.

Attachments

s_undefined.JPG

s_undefined.JPG (123.92 KiB) Viewed 198 times


Newbie

Posts

Joined
Wed Mar 15, 2017 6:03 pm

Post by straightlight » Thu Nov 23, 2017 9:53 pm

Disable all extensions on your IE browser, clear all caches and see if you can reproduce this issue. Also try with other browsers to see if the same issue can be reproduced. Switch back to the default theme and see if you can also reproduce the same results from the developers tool.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Fri Nov 24, 2017 12:07 am

In addition, reset your IE settings and restart your browser afterwards if this issue you are reporting only reflects on IE.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Fri Nov 24, 2017 11:55 am

Well,
<base href="https:///www.alatimilic.hr/shop/" />
<link href="https:///www.alatimilic.hr/shop/image/data/HALA MALA.JPG" rel="icon" />

usually does not work this way :laugh: It takes a 'generous' Browser, to ignore such Missings!
And this is not much better either, technically at least, by use of white space Gaps in image titles... ::)
HALA MALA.JPG
Ernie
PS: It's this way in the Browser Source, and probably configured wrongly in the config.php files.

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Bzagorec » Fri Nov 24, 2017 5:00 pm

Couldn't find anything (to me) evidently wrong with the config files, but I've tried to uncheck the 'Use SSL' option in System->Server administration tab and it corrected the said links above.
Also after that change the site shows correctly in every internet browser
Because of the configured redirects in .htaccess it still always goes to the https, but not sure if it's the 'right way' to leave it configured like that.
Thanks.

Newbie

Posts

Joined
Wed Mar 15, 2017 6:03 pm

Post by straightlight » Fri Nov 24, 2017 10:14 pm

but not sure if it's the 'right way' to leave it configured like that.
It's clearly not since it discards the tracking results from search engines for those particular areas where you indicate the no follow rule.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Bzagorec » Mon Nov 27, 2017 4:18 pm

straightlight wrote:
Fri Nov 24, 2017 10:14 pm
It's clearly not since it discards the tracking results from search engines for those particular areas where you indicate the no follow rule.
Thank you for clarifying, could You give me some clues on what should I do or check for it to work (Use SSL) properly?
Could it be a wrongly configured redirect that when in tandem with the 'Use SSL' gives the 'https:///' links or something else?

Newbie

Posts

Joined
Wed Mar 15, 2017 6:03 pm

Post by straightlight » Mon Nov 27, 2017 9:56 pm

On Github Opencart, there has been recent re-work based on the SSL URL auto-detection strategies. In a future version of Opencart, this should no longer be an issue. If you do not wish to wait for a future release of Opencart to try it on a different folder of your live server, then you can always download the master file from Github Opencart and try it to see if that new tactic solves the issue. :)

However, with the current version of Opencart, you need to ensure to install all the recent bug-fixes that have been provided either on the forum and / or on Github Opencart as well as ensuring to properly configure your config.php and admin/config.php files in order for SSL to be instantiated properly within the browser, assuming SSL has been properly installed by your host for both suggestions.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: Alexa [Bot], Yahoo [Bot] and 92 guests