Post by dmlsolution » Sun Jul 23, 2017 12:18 am

Hi

I have a pretty basic understanding here... so go easy.

I watched, followed and executed a tutorial of how to move a site from one domain to another. Once done, entered the site name dmlsolution.com into my browser and was faced with the following error:

Warning: require_once(/home/public_html/system/startup.php) [function.require-once]: failed to open stream: No such file or directory in /var/sites/d/dmlsolution.com/public_html/index.php on line 23

Fatal error: require_once() [function.require]: Failed opening required '/home/public_html/system/startup.php' (include_path='.:/usr/local/lib/php') in /var/sites/d/dmlsolution.com/public_html/index.php on line 23

I edited both the config files to point them in the correct place as explained in the tutorial. What I am baffled with is the error is saying no file/directory in this location (/var/sites/d/dmlsolution.com/public_html/index.php) which I agree with, I do not have any of these folder(s) in my file manager.... nor was there in the site where it came from. I presumed this would be in the startup.php file)... but after hours of looking I cannot find where this is written and presumable needs changing to (/home/public_html/index.php)

any help would be greatly appreciated

Newbie

Posts

Joined
Tue Jul 18, 2017 10:00 pm

Post by straightlight » Sat Dec 02, 2017 1:26 am

Ensure your config.php and admin/config.php files are properly configured with their relative paths. When moving from one site to another, use your backup ZIP file of your previous store location and upload it to your new server by using your host file manager console. Then, extract the ZIP file. This can be done pretty fast.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by leony » Thu Aug 16, 2018 8:12 am

same problem here help me how to fix please

Warning: require_once(/home/public_html/system/startup.php): failed to open stream: No such file or directory in /home/orotimej/public_html/index.php on line 17

Fatal error: require_once(): Failed opening required '/home/public_html/system/startup.php' (include_path='.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home/orotimej/public_html/index.php on line 17

Newbie

Posts

Joined
Tue Aug 14, 2018 3:29 pm
Who is online

Users browsing this forum: No registered users and 15 guests