Post by stuart1976 » Thu Apr 20, 2017 11:41 pm

Hi

I am having a issue with my site.

Customers are buying items via the site, payment goes through ok and we receive admin email confirmation of orders, but customer does not get any success page displayed when they complete the order.

We are using SagePay IFrame, they enter there details and all is good, payment is done, the IFrame disappears but you are left at the checkout stage, no success page loads. So if customers i don’t check there emails, they don’t know if they have been successful or not and are then trying again.

It does this for:
Chrome
Firefox

But site works fine in Internet Explorer, they enter there details, payment and a success page loads fine.

The issue happens when using other browsers it does not work.

The error log displays the following if this is related or not:

- PHP Notice: Error: E-Mail to required! in /home/sites/oursite/public_html/system/library/mail.php on line 51

- PHP Notice: Undefined index: last_order_id in /home/sites/oursite/public_html/catalog/controller/checkout/success.php on line 68

I was wondering if it might be a java issue as both chrome and firefox no longer use Java but I.E does.

Thanks

Newbie

Posts

Joined
Thu Apr 20, 2017 11:29 pm

Post by oc-extensions » Thu Apr 27, 2017 6:22 am

Hi,

Here you need an developer to take a look

Get 65% OFF for Top 10 OC2.x extensions from OC-Extensions.com


User avatar
Active Member

Posts

Joined
Fri Jan 06, 2012 11:31 pm
Who is online

Users browsing this forum: No registered users and 58 guests