Post by SavSiteDesign » Fri May 03, 2013 9:40 pm

I have opencart running with the same extensions on multiple sites, but only one is giving me the following error... I am beyond perplexed.

When saving modifications on a product in version is 1.5.5.1 I receive the following...

Notice: Undefined index: points in /home/www/shop/admin/model/catalog/product.php on line 121Notice: Undefined index: weight in /home/www/shop/admin/model/catalog/product.php on line 167Notice: Undefined index: weight_prefix in /home/www/shop/admin/model/catalog/product.php on line 167Warning: Cannot modify header information - headers already sent by (output started at /home/www/shop/admin/index.php:85) in /home/www/shop/vqmod/vqcache/vq2-system_engine_controller.php on line 28Warning: Cannot modify header information - headers already sent by (output started at /home/www/shop/admin/index.php:85) in /home/www/shop/vqmod/vqcache/vq2-system_engine_controller.php on line 29

Thanks in advance!!!

Newbie

Posts

Joined
Tue Apr 17, 2012 6:32 pm

Post by ckati » Sat Jul 13, 2013 6:54 pm

Hi Guys

I Have same problem on my website pls help us :)

Notice: Undefined index: stock_status_id in /home/pmobilp4/public_html/admin/model/catalog/product.php on line 121Notice: Undefined index: weight_class_id in /home/pmobilp4/public_html/admin/model/catalog/product.php on line 121Notice: Undefined index: length_class_id in /home/pmobilp4/public_html/admin/model/catalog/product.php on line 121Warning: Cannot modify header information - headers already sent by (output started at /home/pmobilp4/public_html/admin/index.php:81) in /home/pmobilp4/public_html/system/engine/controller.php on line 28Warning: Cannot modify header information - headers already sent by (output started at /home/pmobilp4/public_html/admin/index.php:81) in /home/pmobilp4/public_html/system/engine/controller.php on line 29

ckati

Posts: 2
Joined: Fri Jul 12, 2013 1:36 am

Newbie

Posts

Joined
Fri Jul 12, 2013 2:36 pm

Post by vsdev » Tue Jan 21, 2014 2:50 am

same problem here.

Newbie

Posts

Joined
Tue Jan 21, 2014 2:45 am

Post by MarketInSG » Fri May 02, 2014 11:04 pm

just a quick one to anyone searching for this.

Try increasing your server max_input_vars limit and max_post_size limit


User avatar
Newbie

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by paynechia » Thu Oct 02, 2014 10:21 am

MarketInSG wrote:just a quick one to anyone searching for this.

Try increasing your server max_input_vars limit and max_post_size limit
Hi MarketInSG,

I have requested my host provider to change the values for me. The problem still exists. I noticed that the Local value is greater than the values in Master in the phpinfo();

magic_quotes_gpc
Local: Off ; Master: On

max_execution_time
Local: 300 ; Master: 30

max_input_vars
Local: 2000 ; Master: 1000

Do we need to set same value for both Local and Master for items above?

Highly appreciate for your advise.

Newbie

Posts

Joined
Mon Mar 24, 2014 2:49 pm

Post by MarketInSG » Fri Oct 03, 2014 10:51 pm

you need to set it such that the value shows max_post_size and max_input_vars with huge values enough for you to post your data. when you run phpinfo(), you should see the values you set reflected


User avatar
Newbie

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by primmarket » Thu Oct 30, 2014 5:29 am

I was experiencing the same errors and I believe it was due to a very high number of options attached to each product. Every time I edited a product and saved I'd get the errors. It's an easy fix though.

Edit the php.ini file inside the admin folder and add:
max_input_vars = 30000;
max_post_size = 30000;

Increase if needed but 30000 did the trick for me.

Newbie

Posts

Joined
Fri Aug 02, 2013 7:42 am

Post by stkontra » Sun Mar 19, 2017 11:21 pm

primmarket wrote:
Thu Oct 30, 2014 5:29 am
I was experiencing the same errors and I believe it was due to a very high number of options attached to each product. Every time I edited a product and saved I'd get the errors. It's an easy fix though.

Edit the php.ini file inside the admin folder and add:
max_input_vars = 30000;
max_post_size = 30000;

Increase if needed but 30000 did the trick for me.
Absolute lifesaver!!!! Thank you so much.
Worked for me.

Newbie

Posts

Joined
Sun Mar 19, 2017 11:19 pm
Who is online

Users browsing this forum: jillc and 48 guests