Post by Daniel » Thu Aug 16, 2012 10:19 pm

Finaly after 2 months opencart 1.5.4 is released with some important new features.

You can download it here:
https://github.com/downloads/opencart/o ... .5.4.1.zip

REQUIRES NEW VERSION OF VQMOD!
http://forum.opencart.com/viewtopic.php ... 37#p332037


ADDED
Fedex
Auspost
PayMate
View Customers Online
Searchable fields like isbn, upc, eam, etc..
Updated the doctype to html5
Update Authorize.net (AIM) for Shipping information
Added salt columns for better security
Using mCrypt for better encryption security (now requires PHP mcrypt extension).
better image re-sizing. if an images is the correct size it won;t be re-sized.

FIXED
Show stock warning only if enabled for individuals products.
Sending mail to customers fails when SSL enabled
Delete address from address book fix
customer_blacklist IPv6 fix
Use default PNG compression level of 6

A full list fo fixes you can be found here:

https://github.com/opencart/opencart/is ... ate=closed

A full list of changes can be found here:

https://github.com/opencart/opencart/commits/master

BNe Reporting here:

http://forum.opencart.com/viewtopic.php?f=161&t=81219

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by ncdad2four » Fri Aug 17, 2012 12:34 am

Thanks for the update Daniel. vQmod no longer works however.

New member

Posts

Joined
Sun Jul 10, 2011 8:23 am

Post by Daniel » Fri Aug 17, 2012 1:42 am

the update should not effect it. reinstall?

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by i2Paq » Fri Aug 17, 2012 2:33 am

Thanks for all the hard work!

Dutch Language is on its way ;D

Dutch Language for OpenCart 1.5.4 ::)

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by RuslanBrest » Fri Aug 17, 2012 3:11 am

Daniel, please use Git tagging for mark such version checkpoints!
http://git-scm.com/book/en/Git-Basics-Tagging

OCJ: OpencartJazz.com
http://rb.labtodo.com/category/opencart (lang: ru)


New member

Posts

Joined
Sat Nov 12, 2011 3:19 pm


Post by tvdv » Fri Aug 17, 2012 4:38 am

Hello,

Great to see a new update!

A couple of weeks ago, I bought a template written for version 1.5.2.1. Can you tell me if I still can use it in this new version 1.5.4 or are there changes which will cause trouble with a template written for 1.5.2.1?

Many thanks!
Tony

Newbie

Posts

Joined
Thu Dec 22, 2011 7:29 pm

Post by Tcalp » Fri Aug 17, 2012 5:21 am

A new vqmod has been released by Q to fix 1.5.4 OpenCart problems.

Get it here : http://code.google.com/p/vqmod/downloads/list

More info here: http://forum.opencart.com/viewtopic.php ... 40#p332037

Increase Page Speed (#1 rated commercial extension on OpenCart Marketplace)
15in1 Essential Extensions Value Pack Premium Customer Testimonials Reward Points Extended Admin Security Lockdown Suite

Image
irc.freenode.net #opencart


User avatar
Active Member

Posts

Joined
Wed Jul 06, 2011 1:49 pm

Post by JNeuhoff » Fri Aug 17, 2012 6:53 am

Just downloaded and quickly tested it, looks good so far.

Will go through my long list of bugfixes tomorrow to see whether they are all fixed.

The system/engine is still compatible to previous versions, which is good, because I have been working on an addon manager which I plan to use instead of VQmod, and it will work just fine with this latest Opencart version, too. Hope to release it soon under the GPL3.

Please do NOT use the Export/Import tool till I have upgraded it to this latest Opencart version. There are now additional fields in the database, mainly in the 'product' and 'product_description' tables, which I need to add to the Export/Import tool. Now available for OpenCart 1.5.4!
Last edited by JNeuhoff on Fri Aug 17, 2012 9:26 pm, edited 1 time in total.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


User avatar
Active Member

Posts

Joined
Fri Nov 27, 2009 3:40 pm
Location - Bangkok - Thailand

Post by bigal » Fri Aug 17, 2012 8:34 am

Great work Daniel.

Best Regards/Allen Chen


Active Member

Posts

Joined
Wed Sep 21, 2011 9:02 am

Post by Msun » Fri Aug 17, 2012 12:45 pm

Hey Daniel, just a minor fix in the site, at download page the GitHub repository title shows "Google Code Site".

Thanks for the new release.

Newbie

Posts

Joined
Mon Feb 20, 2012 3:02 am

Post by ADD Creative » Fri Aug 17, 2012 5:01 pm

Thanks Daniel.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by Johnathan » Fri Aug 17, 2012 8:18 pm

Thanks for the hard work, Daniel. Looking forward to testing it out.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by madimar » Fri Aug 17, 2012 9:10 pm

Thanks guys, I'm looking forward for 1.5.4.1 :smile: joking

M

Sent from my DesireHD.

-----------------------------------------------------------------------
My last mods: Partita IVA e CF | Pro EU VAT Number | Sales Agents | Pricelist Pro
-----------------------------------------------------------------------


User avatar
Active Member

Posts

Joined
Thu Sep 24, 2009 6:27 pm


Post by Daniel » Sat Aug 18, 2012 2:19 pm

guys i just uploaded another version. there was a bug in the encryption class of the last one. just re-download it and replace the system > library > encryption.php file.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by aaron1988 » Sat Aug 18, 2012 4:22 pm

Nice work daniel :) will try this later

Just one question do 1.5.3.1 themes work in 1.5.4.1 :)

Aaron

Active Member

Posts

Joined
Thu Jan 27, 2011 10:03 am

Post by ikhlief » Sat Aug 18, 2012 4:58 pm

Thanks for the hard work, but one question did you fix edit order to make items come back to stock automatically?
Thanks

Active Member

Posts

Joined
Wed Nov 24, 2010 9:15 pm

Post by vaio » Sun Aug 19, 2012 1:04 am

Hello Daniel,
thank you for hard work to you and all OC team!

I wanted to upgrade from 1.5.3.1 to 1.5.4.1, but step 5 says:
STEP 5. Browse to http://www.yourstore.com/shop/install/upgrade.php

But inside Install folder, there is no upgrade.php, only upgrade.sql (with 'upgrade' name inside).
I have dloaded it few minutes ago, so it is latest ZIP.

Thank you,
V.

EDIT: Just update instructions on STEP 5 to:
STEP 5. Browse to http://www.yourstore.com/shop/install/ or ...install/index.php

Newbie

Posts

Joined
Thu Mar 03, 2011 12:51 am

Post by Qphoria » Sun Aug 19, 2012 1:31 am

Yea.. I used an improved and updated version in 1.5.3 but the older upgrade.txt files were added back to 1.5.4. So they are out of date.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 12 guests