Post by OSWorX » Tue Oct 02, 2018 3:34 pm

Daniel wrote:
Sun Sep 30, 2018 10:03 pm
mixed ssl is gone. its ssl or non ssl. why did i do this? because google requires all sites to be full ssl and even gives high ranking to full ssl sites.

makes coding easier as well
Perfect decision - thx Daniel!

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by storiqax » Thu Oct 04, 2018 7:27 pm

Please bring back the following! :
Image
I still don't understand why this wonderful feature is not exist for 3.0.2.

User avatar
New member

Posts

Joined
Tue May 29, 2018 10:19 pm

Post by IP_CAM » Thu Oct 04, 2018 8:42 pm

Well, it never did, at least not be default. But the Contributor of this Extension
will be happy, to create one for you, if you're willing to pay for his engagement,
I assume... ;)
Ernie

For Sale: Top URL's, including OpenCart V-Pro installed, like seen here:
http://www.bigmax.ch - http://www.ipcam.li - http://www.opencart.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am

Post by storiqax » Fri Oct 05, 2018 8:15 pm

ADD Creative wrote:
Fri Oct 05, 2018 1:13 am
It was in version 2 by default. Removed in version 3.
Exactly :)

User avatar
New member

Posts

Joined
Tue May 29, 2018 10:19 pm

Post by IP_CAM » Fri Oct 05, 2018 9:10 pm

Oops, I only know it as an Extension, for my Version, but if it existed in OC-2,
it should not be so hard, to make it work in OC-3, I assume...
Ernie

For Sale: Top URL's, including OpenCart V-Pro installed, like seen here:
http://www.bigmax.ch - http://www.ipcam.li - http://www.opencart.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by purpletreesoft » Tue Oct 16, 2018 1:19 pm

Hi Daniel/Others ,
Do you know which areas are majorly redeveloped, and which kind of extensions can break on version 3.1?
We have some extensions and want to understand which ones we need to rewrite.

Purpletree Software LLP
New features launched for Multivendor Marketplace Extension


User avatar
New member

Posts

Joined
Thu Jun 22, 2017 10:17 pm


Post by OSWorX » Tue Oct 16, 2018 11:19 pm

purpletreesoft wrote:
Tue Oct 16, 2018 1:19 pm
Hi Daniel/Others ,
Do you know which areas are majorly redeveloped, and which kind of extensions can break on version 3.1?
We have some extensions and want to understand which ones we need to rewrite.
In 1 line: all.
Why?
Because if you look at the used icon libraries, nearly each icon name will change.
Samples (breadcrumbs):
OC 2.3.x

Code: Select all

<ul class="breadcrumb">
        <?php foreach ($breadcrumbs as $breadcrumb) { ?>
        <li><a href="<?php echo $breadcrumb['href']; ?>"><?php echo $breadcrumb['text']; ?></a></li>
        <?php } ?>
      </ul>
OC 3.0.x

Code: Select all

<ul class="breadcrumb">
        {% for breadcrumb in breadcrumbs %}
        <li><a href="{{ breadcrumb.href }}">{{ breadcrumb.text }}</a></li>
        {% endfor %}
      </ul>
OC 3.1.x

Code: Select all

<ol class="breadcrumb">
        {% for breadcrumb in breadcrumbs %}
          <li class="breadcrumb-item"><a href="{{ breadcrumb.href }}">{{ breadcrumb.text }}</a></li>
        {% endfor %}
      </ol>
Samples (warning):
OC 2.3.x

Code: Select all

<?php if ($error_warning) { ?>
    <div class="alert alert-danger"><i class="fa fa-exclamation-circle"></i> <?php echo $error_warning; ?>
      <button type="button" class="close" data-dismiss="alert">&times;</button>
    </div>
OC 3.0.x

Code: Select all

{% if error_warning %}
    <div class="alert alert-danger alert-dismissible"><i class="fa fa-exclamation-circle"></i> {{ error_warning }}
      <button type="button" class="close" data-dismiss="alert">&times;</button>
    </div>
    {% endif %}
OC 3.1.x

Code: Select all

{% if error_warning %}
      <div class="alert alert-danger alert-dismissible"><i class="fas fa-exclamation-circle"></i> {{ error_warning }}
        <button type="button" class="close" data-dismiss="alert">&times;</button>
      </div>
    {% endif %}
But what I do not understand: as a developer you can download at any time the lastest 3.1.x release and look into the code.
Or are you only lazy?

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by purpletreesoft » Tue Oct 16, 2018 11:42 pm

OSWorX wrote:
Tue Oct 16, 2018 11:19 pm
purpletreesoft wrote:
Tue Oct 16, 2018 1:19 pm
Hi Daniel/Others ,
Do you know which areas are majorly redeveloped, and which kind of extensions can break on version 3.1?
We have some extensions and want to understand which ones we need to rewrite.
In 1 line: all.
Why?
Because if you look at the used icon libraries, nearly each icon name will change.
Samples (breadcrumbs):
OC 2.3.x

Code: Select all

<ul class="breadcrumb">
        <?php foreach ($breadcrumbs as $breadcrumb) { ?>
        <li><a href="<?php echo $breadcrumb['href']; ?>"><?php echo $breadcrumb['text']; ?></a></li>
        <?php } ?>
      </ul>
OC 3.0.x

Code: Select all

<ul class="breadcrumb">
        {% for breadcrumb in breadcrumbs %}
        <li><a href="{{ breadcrumb.href }}">{{ breadcrumb.text }}</a></li>
        {% endfor %}
      </ul>
OC 3.1.x

Code: Select all

<ol class="breadcrumb">
        {% for breadcrumb in breadcrumbs %}
          <li class="breadcrumb-item"><a href="{{ breadcrumb.href }}">{{ breadcrumb.text }}</a></li>
        {% endfor %}
      </ol>
Samples (warning):
OC 2.3.x

Code: Select all

<?php if ($error_warning) { ?>
    <div class="alert alert-danger"><i class="fa fa-exclamation-circle"></i> <?php echo $error_warning; ?>
      <button type="button" class="close" data-dismiss="alert">&times;</button>
    </div>
OC 3.0.x

Code: Select all

{% if error_warning %}
    <div class="alert alert-danger alert-dismissible"><i class="fa fa-exclamation-circle"></i> {{ error_warning }}
      <button type="button" class="close" data-dismiss="alert">&times;</button>
    </div>
    {% endif %}
OC 3.1.x

Code: Select all

{% if error_warning %}
      <div class="alert alert-danger alert-dismissible"><i class="fas fa-exclamation-circle"></i> {{ error_warning }}
        <button type="button" class="close" data-dismiss="alert">&times;</button>
      </div>
    {% endif %}
But what I do not understand: as a developer you can download at any time the lastest 3.1.x release and look into the code.
Or are you only lazy?
Yeah you are right. I was being lazy and you caught me :D

Purpletree Software LLP
New features launched for Multivendor Marketplace Extension


User avatar
New member

Posts

Joined
Thu Jun 22, 2017 10:17 pm

Who is online

Users browsing this forum: No registered users and 13 guests