Post by Reptile » Fri Jul 07, 2017 5:32 am

Did something change in 3.0.1.1 compared to 3.0.0.0???
I just tested a extension I made compatible with 3.0.0.0 and somehow the vqmod changes made to the header.twig (front) do not work.
Vqmod isn't making the vqcache file.

All changes are made to other files by vqmod but not the header.twig.
I tried hardcoding the header.twig file and even then no changes to the front.
Am I missing a important change?

All our extensions: Click here or Click here
Need custom work done? Click here


User avatar
Active Member

Posts

Joined
Mon Jan 30, 2012 7:23 pm
Location - The Netherlands

Post by daniGo » Fri Jul 07, 2017 12:27 pm

You need to clear twig cache.

http://www.gombac.si


Active Member

Posts

Joined
Wed Mar 20, 2013 4:49 pm
Location - Slovenia

Post by doeme » Fri Jul 07, 2017 2:28 pm

was anyone able to move the storage-folder automatically when asked to? I've tried to move the files to a new folder (which did not exist) and get the message that the folder was not found. If I create the folder manually I get the message that the folder already exists....

But 3.0.1.1 looks promising, the only things I'm missing are one click update and the possibility to change the decimal symbol in the admin gui instead of the code ;)

New member

Posts

Joined
Wed Sep 19, 2012 4:22 am

Post by Louis7777 » Fri Jul 07, 2017 4:54 pm

doeme wrote:
Fri Jul 07, 2017 2:28 pm
But 3.0.1.1 looks promising, the only things I'm missing are one click update and the possibility to change the decimal symbol in the admin gui instead of the code ;)
(one-click update definitely)

I'll add to that, the ability to sort products by category and the ability to add employees/users to the back office with their own permissions and profile.

New member

Posts

Joined
Fri Oct 25, 2013 9:10 am

Post by Daniel » Sat Jul 08, 2017 6:35 pm

There will be no more framework changes. I had to change what I had to change to make opencart 'cloud ready'. if u check the how the extension system now works it allows extension to be installed and uninstalled without overwriting or doing any core code changes.

as for the upgrade script that is easy to do now i have done the extension installer. i would also have to include a system to check if currently installed extensions are available on the upgrade version.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Daniel » Sun Jul 09, 2017 12:03 am

also adding a cron job should help.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Worries » Sun Jul 09, 2017 2:51 am

I downloaded Version 3.0.1.2 The Config Files are Empty.

I am waiting for the version 1 Click Update, I do not know if version 3.0.1.2 included it

Newbie

Posts

Joined
Tue Jul 04, 2017 3:24 pm

Post by JNeuhoff » Sun Jul 09, 2017 4:07 am

Worries wrote:
Sun Jul 09, 2017 2:51 am
I downloaded Version 3.0.1.2 The Config Files are Empty.
No, they are not, the system/config/*.php files are fine!

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Sun Jul 09, 2017 6:37 am

Daniel wrote:
Thu Jul 06, 2017 12:18 am
@JNeuhoff

it could be this week or next before the cloud is launched. u can test your extension using the installer in the admin. im currently working on the documentation for extension building here:

https://github.com/opencart/opencart/wiki

i have already got isenses master card extension installing from the admin marketplace. its really going to sell a lot of extension once i start approving extensions. i will be restricting some php functions from being used in extensions such as eval to avoid being hacked.
I just tested the admin marketplace using the latest OpenCart 3.0.1.2, trying to install iSenseLabs MasterCard extension, and it always fails with a Signature hash does not match! . Could you please document on what a user is supposed to do with this?

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Worries » Sun Jul 09, 2017 10:25 am

JNeuhoff wrote:
Sun Jul 09, 2017 4:07 am
Worries wrote:
Sun Jul 09, 2017 2:51 am
I downloaded Version 3.0.1.2 The Config Files are Empty.
No, they are not, the system/config/*.php files are fine!
I mean upload/config-dist
and upload/admin/config-dist

Newbie

Posts

Joined
Tue Jul 04, 2017 3:24 pm

Post by JNeuhoff » Sun Jul 09, 2017 3:57 pm

Worries wrote:
Sun Jul 09, 2017 10:25 am
JNeuhoff wrote:
Sun Jul 09, 2017 4:07 am
Worries wrote:
Sun Jul 09, 2017 2:51 am
I downloaded Version 3.0.1.2 The Config Files are Empty.
No, they are not, the system/config/*.php files are fine!
I mean upload/config-dist
and upload/admin/config-dist
As they should be!

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by zengrafic » Mon Jul 10, 2017 4:35 am

JNeuhoff wrote:
Sun Jul 09, 2017 6:37 am
I just tested the admin marketplace using the latest OpenCart 3.0.1.2, trying to install iSenseLabs MasterCard extension, and it always fails with a Signature hash does not match! . Could you please document on what a user is supposed to do with this?
I got a 400 (bad request) error from the curl request? Any ideas?

Newbie

Posts

Joined
Mon Nov 14, 2016 11:17 pm
Location - Earth

Post by slavib » Mon Jul 10, 2017 3:48 pm

Hello
In version 3.x, there is a problem with placing the php code in the template.
Is there a solution.

New member

Posts

Joined
Wed Sep 11, 2013 4:13 am

Post by Worries » Mon Jul 10, 2017 7:52 pm

Open Cart 3.0.1.2

administration > Customers > Customers The Customer List not fitting well.

Thank you

Newbie

Posts

Joined
Tue Jul 04, 2017 3:24 pm

Post by zengrafic » Tue Jul 11, 2017 9:00 am

slavib wrote:
Mon Jul 10, 2017 3:48 pm
Hello
In version 3.x, there is a problem with placing the php code in the template.
Is there a solution.
Use twig, no php allowed

Newbie

Posts

Joined
Mon Nov 14, 2016 11:17 pm
Location - Earth

Post by Punit » Tue Jul 11, 2017 2:22 pm

@Daniel

3.0.1.2 package contains old version number (3.0.1.1) in index.php.
It should be updated or its 3.0.1.1 patch ?

Newbie

Posts

Joined
Mon Aug 05, 2013 3:36 pm

Post by Jsf » Tue Jul 11, 2017 7:38 pm

Normally most users holding Opencart in FTP with 0755 folders permissions, so how to install new extension from extensions installer? Always get permission error on installer.php because usually apache user does not have permission to create dirs or rename files...

Code: Select all

if (is_dir($file) && !is_dir($path)) {
	if (mkdir($path, 0777)) {
		$this->model_setting_extension->addExtensionPath($extension_install_id, $destination);
	}
}
	
if (is_file($file)) {
	if (rename($file, $path)) {
		$this->model_setting_extension->addExtensionPath($extension_install_id, $destination);
	}
}
What is the solution?

/*
My personal OpenCart modules list
*/


User avatar
Jsf
New member

Posts

Joined
Sun Jan 26, 2014 4:08 am

Post by jpedroza2k » Wed Jul 12, 2017 2:00 am

Is there an update/upgrade path from 2.x to 3.x releases? I am unable to find reliable documentation on the update process. The upgrade.txt says the instructions there are only for 1.5.x stores. Is this an oversight, and it should be 1.5.x or later stores? Performing the update on staging, but still don't want to bork it all up and waste time if the instructions are not correct.

Attachments

Screen Shot 2017-07-11 at 10.59.06 AM.png

Screen Shot 2017-07-11 at 10.59.06 AM.png (9.32 KiB) Viewed 1042 times


Newbie

Posts

Joined
Wed Jul 12, 2017 1:45 am

Post by oberheimer » Wed Jul 12, 2017 10:56 pm

When I upgrade from opencart 2.2 to 3.0.1.2 I get this error
SyntaxError: JSON Parse error: Unrecognized token '<' OK Notice: Undefined index: config_name in /home/XXXXXX/public_html/XXXXXXX/install/model/upgrade/1004.php on line 119{"success":"Patch 1004 has been applied (5 of 10)","next":"index.php?route=upgrade\/upgrade\/next&step=6"}

New member

Posts

Joined
Fri Jun 22, 2012 5:28 am

Post by jpedroza2k » Wed Jul 12, 2017 11:05 pm

Jsf wrote:
Tue Jul 11, 2017 7:38 pm
Normally most users holding Opencart in FTP with 0755 folders permissions, so how to install new extension from extensions installer? Always get permission error on installer.php because usually apache user does not have permission to create dirs or rename files...

Code: Select all

if (is_dir($file) && !is_dir($path)) {
	if (mkdir($path, 0777)) {
		$this->model_setting_extension->addExtensionPath($extension_install_id, $destination);
	}
}
	
if (is_file($file)) {
	if (rename($file, $path)) {
		$this->model_setting_extension->addExtensionPath($extension_install_id, $destination);
	}
}
What is the solution?
If you are going to install through the web interface, then the web user (apache on Cent/RHEL or www-data on Ubuntu) will need write permissions on the directory. This can be accomplished by chmod-ing the directories to 0775 and chown-ing the directories to the user:apache/www-data. If you run with 0755 permissions you will also run into issues with uploading files. You can still run 0755 on the other directories, but setting the upload and extension dirs to 0775.

Newbie

Posts

Joined
Wed Jul 12, 2017 1:45 am
Who is online

Users browsing this forum: No registered users and 8 guests