Post by nasser.man » Mon Jun 26, 2017 3:51 pm

rgbrewer wrote:
Tue Jun 20, 2017 9:28 pm
Twig is fantastic.
i like it, TWIG

اگر پیامتون در این انجمن ندیده باشم با من از طریق وبسایتم در تماس باشید.
http://ressan.ir


New member

Posts

Joined
Fri Oct 09, 2015 11:16 pm


Post by daveyoi » Mon Jun 26, 2017 4:39 pm

MarketInSG wrote:
Mon Jun 26, 2017 2:54 pm
Let's say we try to modify catalog/controller/common/home.php, it doesn't seem to work. Maybe I didn't test it right...possible to run a test on your end?

Looking at framework.php, it seems like there's still controller files that goes through action.php instead.
It should work - the dispatch call from framework.php is passing an action with route startup/router- the events are fired from in there.

I have used them successfully in 2.3 - will port my code sometime this week to see if working in 3.0

Image
Tristar Web Solutions


New member

Posts

Joined
Sun Oct 05, 2014 2:38 am

Post by pm-netti » Mon Jun 26, 2017 4:49 pm

My test was this bug:

1. I added new geo zone from admin
2. In table `zone_to_geo_zone` country_id is '0' for this added new line.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by MarketInSG » Mon Jun 26, 2017 4:50 pm

ah interesting. let me do more tests to see where went wrong on my end.

UPDATE: Had some typos...no wonder it didn't work. Now it works well ;)


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by pm-netti » Mon Jun 26, 2017 5:16 pm

This my test:

Code: Select all

Notice: Undefined index: country_id in C:\MAMP\htdocs\3000\admin\model\localisation\geo_zone.php on line 10Notice: Undefined index: country_id in C:\MAMP\htdocs\3000\admin\model\localisation\geo_zone.php on line 12
Ps. Reason: There must wait 5-10 seconds, then press Save. Slow down. Can this do better?
Last edited by pm-netti on Mon Jun 26, 2017 11:35 pm, edited 3 times in total.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by JNeuhoff » Mon Jun 26, 2017 11:02 pm

nasser.man wrote:
Mon Jun 26, 2017 3:49 pm
JNeuhoff wrote:
Mon Jun 26, 2017 9:32 am
nasser.man wrote:
Mon Jun 26, 2017 8:47 am
Is this version (3.0.0.0) suitable for production server?
No
I have an uncompleted store using opencart 2.3.x, should i go with version 2.3 ? is will be possible to export /import its data to version 3.x ?
We are still working on the Export/Import tool for OpenCart 3.0.0.0.

And yes, it will be possible to export and import products and categories data to 3.x, though it may require some copy/paste because of slightly different spreadsheet formats.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by bull5-i » Tue Jun 27, 2017 2:58 am

Does anyone know the reason why each page load takes half a minute with the new 3.0.0.0 release?

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by eurorackworld » Tue Jun 27, 2017 11:38 pm

Just want to say I love this! By coincidence installed the software via an autoinstaller while this new version just got released. So playing around with it for my new store. Really nice. Of course enough opinions on making it better, found quite some bugs, but still for now during setup still ok!

Can't wait to upgrade to have the biggest bugs fixed!

Newbie

Posts

Joined
Tue Jun 27, 2017 11:30 pm

Post by JNeuhoff » Wed Jun 28, 2017 1:40 am

bull5-i wrote:
Tue Jun 27, 2017 2:58 am
Does anyone know the reason why each page load takes half a minute with the new 3.0.0.0 release?
The twig template engine can slow it down. I might do a release with the php-template engine, IMHO twig was not a good choice.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by bull5-i » Wed Jun 28, 2017 2:08 pm

JNeuhoff wrote:
Wed Jun 28, 2017 1:40 am
bull5-i wrote:
Tue Jun 27, 2017 2:58 am
Does anyone know the reason why each page load takes half a minute with the new 3.0.0.0 release?
The twig template engine can slow it down. I might do a release with the php-template engine, IMHO twig was not a good choice.
I do not believe twig template engine is the cause. Literally every request (including pure AJAX request) takes more than 15 seconds to load. And this is a clean 3.0.0.0 installation on WAMP. The 3.0.0.0 alpha release they did does not exhibit this issue and loads reasonably swiftly.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by daniGo » Wed Jun 28, 2017 5:04 pm

Open system/config/admin.php and remove 'startup/sass' this speed up admin.

http://www.gombac.si


Active Member

Posts

Joined
Wed Mar 20, 2013 4:49 pm
Location - Slovenia

Post by bull5-i » Thu Jun 29, 2017 12:46 am

daniGo wrote:
Wed Jun 28, 2017 5:04 pm
Open system/config/admin.php and remove 'startup/sass' this speed up admin.
Good call! Removing SASS from startup got the page load time down to about 1.5s.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by Hackej » Thu Jun 29, 2017 10:50 pm

Hi!

After installing/upgrading 3.0.0.0 to 3.0.0.1 I get a pop-up warning in Admin saying:
Warning: You must move the storage directory outside of the web root directory!

Why is that?
Running local host (XAMPP at the moment).

BR
/Hackej

New member

Posts

Joined
Fri May 27, 2011 1:47 pm

Post by swguy » Sat Jul 01, 2017 4:51 am

nasser.man wrote:
Mon Jun 26, 2017 3:49 pm
I have an uncompleted store using opencart 2.3.x, should i go with version 2.3 ? is will be possible to export /import its data to version 3.x ?
Yes, go with 2.3. Version 3.x is just getting started - wait for it to mature. It's not ready for production stores yet.

Better Together: Buy one product, get another at a discount.
Discount Chooser: Buy a group of products, get another group at a discount.


User avatar
New member

Posts

Joined
Mon Apr 15, 2013 4:13 am

Post by skip » Mon Jul 03, 2017 4:24 am

when click on edit home layout show this error ,also for other layouts same

Notice: Undefined variable: language in /home/u725340828/public_html/30/admin/controller/design/layout.php on line 369
Fatal error: Call to a member function load() on a non-object in /home/u725340828/public_html/30/admin/controller/design/layout.php on line 369

Active Member

Posts

Joined
Mon May 09, 2011 9:57 pm

Post by melvin16 » Mon Jul 03, 2017 1:03 pm

Hello everyone,
I found on folder catalog>language>en-gb>checkout>cart.php on line 21,

$_['text_length'] = ' for %s payments'

It seems like uncompleted program, is any body having suggestions about it?
I'm so grateful for your kindly suggestions about it and thank you in advance for your kindly response.
Best regards, melvin16

User avatar
Newbie

Posts

Joined
Sat Nov 08, 2014 12:52 am

Post by Worries » Tue Jul 04, 2017 3:40 pm

Hello,

I am about to run a new online store, I read many posts talking about many bugs on the last version 3.0.0.0

Please tell me when the finished and none bugs update will be released?

Thank you

Newbie

Posts

Joined
Tue Jul 04, 2017 3:24 pm

Post by Emirates7 » Tue Jul 04, 2017 5:47 pm

I can't change template to other in opencart 3.0.1. Is there any one who has the same problem?

New member

Posts

Joined
Thu Nov 14, 2013 4:12 am

Post by Rockz » Tue Jul 04, 2017 9:31 pm

Admin Panel > Extensions > Themes > Default Store Theme > Edit

The default theme editing does not work.

Newbie

Posts

Joined
Tue Jul 04, 2017 8:59 pm

Post by opencartboost » Tue Jul 04, 2017 11:51 pm

Emirates7 wrote:
Tue Jul 04, 2017 5:47 pm
I can't change template to other in opencart 3.0.1. Is there any one who has the same problem?
May be you need to try OC 3.0.0.2 because opencart just releaze OC version 3.0.0.2.

Active Member

Posts

Joined
Thu Jul 09, 2015 5:59 am
Who is online

Users browsing this forum: No registered users and 9 guests