Post by straightlight » Mon Aug 01, 2016 9:49 pm

Opencart v2.3.0.2 has been released which fixes minor bugs from the v2.3.0.0 and v2.3.0.1 release. More information can be found on this topic: http://forum.opencart.com/viewtopic.php?f=2&t=165953 . Followed is the official topic to where bug reports can be posted: http://forum.opencart.com/viewtopic.php?f=191&t=166012 as well as on GitHub: https://github.com/opencart/opencart/issues

Changelog: https://github.com/opencart/opencart/re ... ag/2.3.0.2

New infrastructure methodology on handling Opencart extensions can be found on this topic: http://forum.opencart.com/viewtopic.php?f=183&t=165958

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Mon Aug 01, 2016 10:01 pm

I ran the core upgrade to test a successful result; 120 seconds exceeded error message appears. Since the experimental tool includes instructions on NOT to use it for future releases but only for the v2.2.0.0 release, we'll have to wait until the next patch is released. Increasing the post size may be another temporary option for those who can.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Mon Aug 01, 2016 10:28 pm

Update: Upgrade successful after integrating the experimental tool by myself with v2.3.0.2 downloaded from: http://forum.opencart.com/viewtopic.php?f=181&t=163546 . Download it and replace the install folder. From the v2.3.0.2 install folder, copy the install/opencart.sql and the install/model/upgrade/1008.php to the experimental's install folder. After making a full backup of your site - including database: http://forum.opencart.com/viewtopic.php?f=141&t=165659 . Set your site under maintenance from your admin - > systems - > settings - > edit store - > server tab - > Maintenance Mode: On. Then, run the /install folder on your browser.

Then, go to your admin - > users - > user permissions - > edit permission - > uncheck all and recheck all. Save changes.

Result should be provided as below at the end of the upgrade process:

Reverse site maintenance settings afterwards.

Attachments

opencart_2301_upgrade_success.png

Upgrade success. - opencart_2301_upgrade_success.png (12.7 KiB) Viewed 9801 times


The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by i2Paq » Thu Aug 04, 2016 5:26 pm

Please be aware that you need PHP 5.4+

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by straightlight » Thu Aug 04, 2016 7:17 pm

i2Paq wrote:Please be aware that you need PHP 5.4+
The PHP v5.4 restriction is already part of the installation. Although, not part of the upgrade unfortunately. :-\

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by i2Paq » Thu Aug 04, 2016 7:39 pm

straightlight wrote:
i2Paq wrote:Please be aware that you need PHP 5.4+
The PHP v5.4 restriction is already part of the installation. Although, not part of the upgrade unfortunately. :-\
Precisely, you will run into a BIG issue upgrading.....

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by straightlight » Thu Aug 04, 2016 7:42 pm

i2Paq wrote:
straightlight wrote:
i2Paq wrote:Please be aware that you need PHP 5.4+
The PHP v5.4 restriction is already part of the installation. Although, not part of the upgrade unfortunately. :-\
Precisely, you will run into a BIG issue upgrading.....
Not entirely true. Using the experimental upgrade from qphoria as mentioned above and to what the screenshot provides, you will still head to a successful event. :)

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by i2Paq » Thu Aug 04, 2016 7:58 pm

AH! I see.

My VPS has multiple PHP versions running and you can set which PHP version is active per site from the Control Panel.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by straightlight » Thu Aug 04, 2016 8:02 pm

i2Paq wrote:AH! I see.

My VPS has multiple PHP versions running and you can set which PHP version is active per site from the Control Panel.
A nice way to handle your site as a webmaster. :)

I have informed qphoria regarding the experimental upgrade restriction in effect to be set since the latest requirements on Opencart as the part where you are correct is even with a successful upgrade, limitations towards the stores that does not meet the requirements will still be limited to operate the latest version of Opencart which wasn't considered from my first post.

Hopefully, he will consider this idea.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by davidbfranks » Thu Aug 04, 2016 9:12 pm

Does this version play nice with PHP 7?

New member

Posts

Joined
Mon Mar 04, 2013 10:31 pm
Location - London

Post by straightlight » Thu Aug 04, 2016 9:15 pm

davidbfranks wrote:Does this version play nice with PHP 7?
No problem reported, so far, regarding PHP v7. However, I would suggest to keep an eye on the OpenSSL version. More information about this can be found on this topic: http://forum.opencart.com/viewtopic.php ... 20#p632250

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cyclops12 » Sun Aug 07, 2016 5:51 pm

straightlight wrote:Update: Upgrade successful after integrating the experimental tool by myself with v2.3.0.2 downloaded from: http://forum.opencart.com/viewtopic.php?f=181&t=163546 . Download it and replace the install folder.
Hiya straightlight,
Where is the tool to download in that link you supplied ??

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by straightlight » Sun Aug 07, 2016 7:32 pm

cyclops12 wrote:
straightlight wrote:Update: Upgrade successful after integrating the experimental tool by myself with v2.3.0.2 downloaded from: http://forum.opencart.com/viewtopic.php?f=181&t=163546 . Download it and replace the install folder.
Hiya straightlight,
Where is the tool to download in that link you supplied ??
It is already part of the topic I indicated: http://forum.opencart.com/viewtopic.php?f=181&t=159898

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cyclops12 » Sun Aug 07, 2016 9:40 pm

So is this suitable for 2.3.0.2 as it says do not use on future versions from 2.2.0.0
upgrade_install.JPG

upgrade_install.JPG (17.33 KiB) Viewed 9044 times

This upgrade is getting very confusing

Can we not have an upgrade post specifically for the latest 2.3.0.2 version, or an upgrade version that actually works.... I.E have the qphoria upgrade script included into the latest version

We already have 2.2 versions which have loads of bugs/errors which have been sorted in newer versions yet 2.3.0.0 and 2.3.0.1 are both bad builds apparently.

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by straightlight » Mon Aug 08, 2016 2:49 am

cyclops12 wrote:So is this suitable for 2.3.0.2 as it says do not use on future versions from 2.2.0.0
upgrade_install.JPG
This upgrade is getting very confusing

Can we not have an upgrade post specifically for the latest 2.3.0.2 version, or an upgrade version that actually works.... I.E have the qphoria upgrade script included into the latest version

We already have 2.2 versions which have loads of bugs/errors which have been sorted in newer versions yet 2.3.0.0 and 2.3.0.1 are both bad builds apparently.
Which Is why I released this post in case confusion would be brought up: http://forum.opencart.com/viewtopic.php ... 11#p631668 . I tested this myself with the experimental tool and provided the steps on how to complete the upgrade with v2.3.0.2 which differs to the warning message from the experimental topic tool.

A screenshot on the link I provided is also included to provide the results and the facts based on the succession of the upgrade. :)

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cyclops12 » Mon Aug 08, 2016 3:19 am

Straightlight, thank you for the confirmation that this works with 2.3.0.2

I may try an upgrade during the week

Hopefully all will go well

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by straightlight » Mon Aug 08, 2016 3:50 am

cyclops12 wrote:Straightlight, thank you for the confirmation that this works with 2.3.0.2

I may try an upgrade during the week

Hopefully all will go well
No problem. However, take note that this upgrade tool is only core-related. Each installed extensions must be compatible with the latest version inclusively.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by contactthedvla » Fri Oct 07, 2016 11:20 pm

Just upgraded without problems woohoo!


Posts

Joined
Fri Oct 07, 2016 11:19 pm


Post by iplocker » Wed May 24, 2017 1:35 am

Hello.
Is it crazy to ask why Daniel not apply those Qphoria changes so we will have a clean upgrade????
Sounds just crazy for me a component like OC without official upgrade instructions which works !
Thanks

Active Member

Posts

Joined
Sun May 26, 2013 6:39 pm


Post by EvolveWebHosting » Fri May 26, 2017 1:03 am

iplocker wrote:
Wed May 24, 2017 1:35 am
Hello.
Is it crazy to ask why Daniel not apply those Qphoria changes so we will have a clean upgrade????
Sounds just crazy for me a component like OC without official upgrade instructions which works !
Thanks
I haven't looked at the written documentation but the upgrade .sql file included with v2.3.0.2 is from Qphoria and it works.

Image
https://www.evolvewebhost.com
Unhappy with your current host? We can migrate your account today (usually for no fee)! Visit our website and signup and we'll take care of the rest!
24/7/365 support
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA
Who is online

Users browsing this forum: ptq470 and 9 guests