Post by straightlight » Sun Jul 31, 2016 3:15 am

Here it is, the big day has arrived for most of forum users; Opencart v2.3.0.0 stable release has now been released into the downloads section of this site: http://www.opencart.com/index.php?route ... d/download . Ensure to view the changelog on this site: https://github.com/opencart/opencart/re ... ag/2.3.0.0

* Update *

New instructions by Qphoria on this post: http://forum.opencart.com/viewtopic.php ... 53#p631440

Ensure to provide your feedbacks into the Bug Reports section of the forum: http://forum.opencart.com/viewforum.php?f=191 or on GitHub: https://github.com/opencart/opencart/issues if problematic issues have been found which exclude these events: http://forum.opencart.com/viewtopic.php?f=170&t=165657

If extensions under licensing terms were purchased from prior versions of Opencart, ensure to verify the downloads tab from the extensions store of each distributions before considering to activate any un-relative extensions versions on the new Opencart release.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by OpenCart Addons » Sun Jul 31, 2016 4:56 am

Congratulations on the release.

Edit
After looking through the code I noticed the backwards compatibility is implemented.

However, there is an issue with the language file loading for extensions that follow the old file structure. This is causing the incorrect extension name to appear in the extensions list.

I've submitted a PR on Github with the fix.
https://github.com/opencart/opencart/pull/4710


Regards,
Joel.
Last edited by OpenCart Addons on Sun Jul 31, 2016 5:42 am, edited 2 times in total.

Image
Canada's Leading Expert In OpenCart Development & Certified OpenCart Development Partner Image


User avatar
Active Member

Posts

Joined
Thu Nov 24, 2011 10:51 am
Location - Canada

Post by straightlight » Sun Jul 31, 2016 5:23 am

The first topic above is the way it has been suggested by the Opencart developers to upgrade in case the core upgrade would failed.

However, followed is my version on how I did proceed with the upgrade with the OC v2.3.0.0 release on a test server when failed to upgrade:

1 - Backup your previous database of Opencart version from your PHPMyAdmin

2 - Ensure to have created a new database table for Opencart v2.3.0.0 in your PHPMyAdmin

3 - From your SQL file exported from your previous version of Opencart, open it. Ensure that all URL locations points to the right locations for the new version.

4 - Copy your root config.php file and admin/config.php file and ensure to make the modifications for both database which should point to your new database name. Also ensure both files contains the right paths.

5 - From the opencart v2.3.0.0/install folder, copy the oc_cart and oc_banner_image table aside (CREATE and INSERT query - both).

6 - Either upload or paste the entire SQL backup content into your SQL query tab on the new Opencart database from your PHPMyAdmin and execute it.

7- Paste the aside copy from step 5 into the SQL query tab on the new Opencart database from your PHPMyAdmin and execute it.

8 - From your SQL backup file, it may be possible that you might need to copy and paste the user_group table query as well as the insert if the new database provides only the demonstration or empty results from that table on your new Opencart database. If so, simply copy both the CREATE and INSERT statements and paste them into the SQL tab on your PHPMyAdmin on your new Opencart database. Then, execute it.

9 - Log in to your OC admin. If unable to login, ensure to check your user database table from your new database to see if the administrative account is still there and active. If it is and even if it isn't and you're unable to login, copy your INSERT statement block from your user table from your SQL backup file and paste it into the SQL tab from your PHPMyAdmin. Then, execute it and refresh the admin page (twice). Then, try to login again.

10 - Go to your admin - > systems - > users - > user groups and ensure all pages are unchecked and checked where the most administrative rights applies.

11 - New ways of handling extensions: The admin extensions are now handled into a sub-folder for the 4 categories of the folders - controllers, language and view. Ensure that all extensions are compatible as mentioned on my first post with their relative paths: e.g: under the controller/extension/extension/<your_extension>.php file.

12 - The store-front end's extensions are now handled in e.g: controller/extension/<your_extension_folder>/<extension_file_name>.php file.

13 - In your admin - > systems - > settings - > edit store, ensure all settings (and new settings) are properly configured.

14 - In your admin - > extensions - > extensions page, use the dropdown menu. Ensure all relative extensions are active.
If this step does not work as it should by providing error messages from the screen, for instance, please read my first post regarding downloaded extensions with the latest release of Opencart. If not compatible and you're unable to remove them, use the 'search' tab feature in the PHPMyAdmin and type in every single filenames that the error message will provide you (just the last portion of the path). Then, delete the found entries accordingly and refresh your site.

15 - Once all the above have been configured, load your store-front end.

Note: Step 14 is of course a temporary error message until each extensions developers wlll fix the issues on their end. In addition, more information can be found regarding how to handle extensions location in Opencart v2.3 stable release: http://forum.opencart.com/viewtopic.php?f=183&t=165958

Followed is a screenshot based on the succession of the above operations.

Attachments

opencart_v2300_store_fe.png

Opencart v2.3.0.0 - Store Front-End - opencart_v2300_store_fe.png (180.92 KiB) Viewed 3754 times

opencart_v2300.png

Opencart v2.3 upgrade success - opencart_v2300.png (21.23 KiB) Viewed 3757 times


The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Sun Jul 31, 2016 6:03 am

OpenCart Addons wrote:Congratulations on the release.

Edit
After looking through the code I noticed the backwards compatibility is implemented.

However, there is an issue with the language file loading for extensions that follow the old file structure. This is causing the incorrect extension name to appear in the extensions list.

I've submitted a PR on Github with the fix.
https://github.com/opencart/opencart/pull/4710


Regards,
Joel.
The defined versions are showing as 2.3.0.0 since I downloaded it ... no beta entries in there from the mentioned files on GitHub. However, it is not a bad idea to verify in case.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Qphoria » Sun Jul 31, 2016 7:44 am

Upgrade is broken already.... the new 1008.php upgrade file hardcodes the "oc_" prefix so if you are using a prefix other than oc_ you will get an error. Oddly the fix for that was made on 7/7 but the release zip file was made on 7/30 and has the version of the file from 7/2 so not sure why they are so out of date.. in any case, you can download the corrected 1008.php here. Upload to install/model/upgrade and overwrite the existing 1008.php before attempting to upgrade.

Attachments

Corrected 1008.php for 2.3.0.0 upgrade


OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by straightlight » Sun Jul 31, 2016 8:39 am

The instructions has now been updated on my first post regarding the 1008.php file.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Mon Aug 01, 2016 1:32 am

It would seem an official release was announced by Qphoria: http://forum.opencart.com/viewtopic.php?f=2&t=165980 on NOT to use v2.3.0.0 release. The subject is now closed.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 12 guests