Post by sunsys » Thu Nov 05, 2015 2:52 pm

pm-netti wrote: This extension is not upload files. Files need uplaod himseft to server.
This is support to future version.
Sir I wanted to know what does your software or extension do (http://www.opencart.com/index.php?route ... n_id=24347) sorry but cannot understand by your language issues as to what you have written above.

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Newbie

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by pm-netti » Thu Nov 05, 2015 3:30 pm

sunsys wrote:
pm-netti wrote: This extension is not upload files. Files need uplaod himseft to server.
This is support to future version.
Sir I wanted to know what does your software or extension do (http://www.opencart.com/index.php?route ... n_id=24347) sorry but cannot understand by your language issues as to what you have written above.
This make about all things.
This does not remove the old third-party extensions.
Maybe also these can remove, if is use upgrade from 1.5 to 2.x?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Newbie

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by iplocker » Sat Nov 07, 2015 1:40 am

Iamdbat wrote:Same old story .... Opencart jumping over dead bodies to find a ring ..... THE BIGGEST ISSUE that should be concentrated on BEFORE anything else should be an upgrade engine

Now that I have some EXPERIENCE with the way that the Opencart project works ... I'll always be skeptical until I can be convinced otherwise

Opencart SHOULD be able to upgrade itself ... SIMPLE AS without issue - every OC user wants it - every OC user has complained about it but the notion is COMPLETELY IGNORED

Daniel - we have all bought into your system - why can't you be honest and simply address the obvious!
I totally agree with you my friend !!
And why this extension the pm-netti works on it are not in the core ??? I am sorry pm-netti if you are going to loose your orders but this is a number 1 feature in an eshop at 2015 !
Arastta which is the clone of the Opencart has upgrade feature, how about clone their mechanism , they took the whole Opencart why not you follow their Upgrade mechanism !

Newbie

Posts

Joined
Sun May 26, 2013 6:39 pm


Post by pm-netti » Sat Nov 07, 2015 5:18 am

iplocker wrote: I totally agree with you my friend !!
And why this extension the pm-netti works on it are not in the core ??? I am sorry pm-netti if you are going to loose your orders but this is a number 1 feature in an eshop at 2015 !
Arastta which is the clone of the Opencart has upgrade feature, how about clone their mechanism , they took the whole Opencart why not you follow their Upgrade mechanism !
Thanks your message. ;)
if I had copied Arastta code, would it correct to put it on sale?
Although I have made a free upgrade version, I am not very enthusiastic to help OpenCart team for free.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Newbie

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Iamdbat » Sat Nov 07, 2015 11:55 am

I think I speak for the myriad of Ordinary OC users who will make the effort to read this post - 'Jesus Christ' / Allah / Buddah or whoever ..... HERE WE GO AGAIN !!!! - Opencart updates ... but NO natural way of updating UNLESS you are a code guru with more than time on your hands ..... I don't know about you BUT

1: / Technos at OC need to get their head out of their arse! - USERS of OC are very much SICK and TIRED of new updates and NOT being able to implement them

2: / ORDINARY users haven't a bog's notion of what GIT HUB is !

3: / STOP promoting redundant extensions - if you need revenue - we'll pay a reasonable price for something we can USE!!!

4: / Instead of giving us a half completed default template in order for us to "Oh Jesus I need a better template than this urgency" (so but one quick from the template store stuff .... why don't you give us HALF A CHANCE .. to earn a little revenue with one that WORKS and proper mind you ... Why do we need to do a crash course in HTML and CSS just to do the ordinary?????

5: / POLICE the extensions you offer .... MOST of them aren't worth the mud on anybodies shoe!

6:/ LISTEN to suggestions for the overall architecture suggested and required of OC for TODAY'S ecommerce .. it's HIGH TIME you caught up and provide WHAT IS NEEDED in the back end - NOT what YOU want but WHAT WE WANT!!!

7: / Do us all favour and get EMAIL confirmations working correctly! - My God the amount of customers that say they don't get confirmation emails is rediculous - why do I have to be bothered by this nonsense and why do I have to do a crash course in server technology to SOLVE A BASIC FUNDAMENTAL of transacting online????

8: / Stop massaging your OC EGO .... it's good but it's sincerely lacking where it matters most!

9: / I'm fed up saying the same things over - if your going to have a suggestion site - well at least DO what people are suggesting !!!!

I'm going to finish up here albeit I could continue all night but this post will be rubbished anyway so .... there ya go ... not worth my time anymore and I'm sure OC Graduates won't spend any either so good luck ....

Newbie

Posts

Joined
Sat Jan 28, 2012 7:32 am

Post by i2Paq » Sun Nov 08, 2015 3:24 am

Iamdbat wrote: ....
It has all been said before..........

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by sunsys » Sun Nov 08, 2015 9:39 am

Iamdbat wrote: 1: / Technos at OC need to get their head out of their arse! - USERS of OC are very much SICK and TIRED of new updates and NOT being able to implement them

2: / ORDINARY users haven't a bog's notion of what GIT HUB is !

3: / STOP promoting redundant extensions - if you need revenue - we'll pay a reasonable price for something we can USE!!!

4: / Instead of giving us a half completed default template in order for us to "Oh Jesus I need a better template than this urgency" (so but one quick from the template store stuff .... why don't you give us HALF A CHANCE .. to earn a little revenue with one that WORKS and proper mind you ... Why do we need to do a crash course in HTML and CSS just to do the ordinary?????

5: / POLICE the extensions you offer .... MOST of them aren't worth the mud on anybodies shoe!

6:/ LISTEN to suggestions for the overall architecture suggested and required of OC for TODAY'S ecommerce .. it's HIGH TIME you caught up and provide WHAT IS NEEDED in the back end - NOT what YOU want but WHAT WE WANT!!!
@Iamdbat: I admire you for your rather scathing post without the fear of getting your account banned and blocked, yes it is true.

IMO, NO they will never do any of the things that you have very rightly and sensibly suggested above but they will surely and very promptly BAN AND BLOCK your account if you take a refund from Paypal and then they will never answer your mails, NEVER they will never do anything that is in public's interest but they will only do things that pampers their ARROGANT AND INFLATED EGO.

Hats off to i2Paq's concise answer which says it all.

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Newbie

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by anhto » Mon Nov 09, 2015 1:39 am

czorny wrote:
bill62 wrote:when OpenCart will release documentation of how to upgrades from 2.0.3.1 TO 2.1.0.1 ??????
I'm more worried, that they never provide even basic upgrade functionality or backward compatibility. Upgrade process doesn't even update your tables! You will have to add/remove/rename all columns manually.

Actually, upgrade from 2.0 to 2.1 is pretty painful. I wouldn't recommend you to do it, it you're not a developer. Cart and wishlist completely changed, every extension, which relies on them, will stop working. API settings and calls also absolutely different and once again, every extension, which makes API calls, will fail. And so on, and so on.

I'm struggling with it for two days already and still having issues, not all changes found. And I'm a professional developer myself.
The same with me, actually, im a developer and selling modules on market. After Opencart 2.1.0.1 is released, im so tired with that.

ALl code, structure is changed, oh my god, i cant believe Opencart System can do like this.

You should have a plan for developer upgrade extension of them before released.

I agreed OC 1.5 to 2.0 is new code, new structure, but from 2.0 to 2.1, new code new structure is SO BAD.

@Daniel: If you do not listen us, we will lost money, and you too.

Look at magento, before release Magento 2.0, they have a plan 2-3 years for Developers, learn, upgrade modules.

Haiz..

I just creating modules to Increase Your Sales.

Image Image


Newbie

Posts

Joined
Tue Jun 11, 2013 11:53 pm

Post by anhto » Mon Nov 09, 2015 1:49 am

Look at on system/library/cart.php, everything is changed. -> All extension is related with Cart Session for opencart 2.0 will be die.

In the short time, how to upgrade it??????

I just creating modules to Increase Your Sales.

Image Image


Newbie

Posts

Joined
Tue Jun 11, 2013 11:53 pm

Post by Salle32 » Mon Nov 09, 2015 6:42 pm

Wouldn´t it be great to inform us about that it isn´t possible to upgrade from 2.0.3.1 to 2.1.0.1? Or did I miss something while trying to upgrade? ???

Newbie

Posts

Joined
Fri Aug 31, 2012 5:30 am

Post by pm-netti » Tue Nov 10, 2015 5:52 am

Iamdbat wrote:I think I speak for the myriad of Ordinary OC users who will make the effort to read this post - 'Jesus Christ' / Allah / Buddah or whoever ..... HERE WE GO AGAIN !!!! - Opencart updates ... but NO natural way of updating UNLESS you are a code guru with more than time on your hands ..... I don't know about you BUT.
Ha-ha, my extension is unnatural way ;)
In any case, it is now available in the full version to good servers.

Ps. I did today upgrade to South Europe. Database upgrade and all files update total time was 40 seconds. :)

Ps 2: 24.11.2015 became the new world record :) Upgrade time to UK was 11 seconds.
Last edited by pm-netti on Sat Nov 28, 2015 1:36 am, edited 1 time in total.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Newbie

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by keegande » Thu Nov 12, 2015 12:57 pm

any bug in this version guys ? please answer
thanks

Banyak sekali wirausaha sukses dan wirausaha sosial yang bisa anda contoh. Profil wirausaha sukses dari beberapa tokoh inspirasi indonesia juga bisa anda jadikan panutan.


Newbie

Posts

Joined
Thu Nov 12, 2015 12:53 pm

Post by pm-netti » Thu Nov 12, 2015 4:23 pm

keegande wrote:any bug in this version guys ? please answer
thanks
http://forum.opencart.com/viewtopic.php?f=191&t=152650

Image
- - - OpenCart Upgrade Service - - -


User avatar
Newbie

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by thbr02 » Thu Dec 03, 2015 3:50 pm

How looks the plan for an updated bugfixed version of Opencart 2.1.0.1? Iv'e been waiting for almost 2 months for this. I would rather not upgrade to 2.1.0.1 after all I've read about all problems. I thought it would be wiser to wait for a new version, but it doesn't seem to come, or?

Newbie

Posts

Joined
Wed Jun 22, 2011 10:30 pm
Location - Sweden

Post by Alex Kov » Sun Dec 06, 2015 7:44 am

thbr02 wrote:How looks the plan for an updated bugfixed version of Opencart 2.1.0.1? Iv'e been waiting for almost 2 months for this. I would rather not upgrade to 2.1.0.1 after all I've read about all problems. I thought it would be wiser to wait for a new version, but it doesn't seem to come, or?
And I too am waiting...

Question to the administration.
When about to be ready the next release? This year?

Thanks!!

User avatar
Newbie

Posts

Joined
Sun Dec 06, 2015 7:30 am
Location - Ukraine

Post by JNeuhoff » Mon Dec 07, 2015 3:43 am

thbr02 wrote:How looks the plan for an updated bugfixed version of Opencart 2.1.0.1? Iv'e been waiting for almost 2 months for this. I would rather not upgrade to 2.1.0.1 after all I've read about all problems. I thought it would be wiser to wait for a new version, but it doesn't seem to come, or?
I am afraid there won't be a pure bugfix release for 2.1.0.1. Looking at the code of the upcoming 2.1.0.2 in the master branch, it may include some bugfixes, but it will also have some significant changes to the system core, such as using a new factory class to foster a factory design pattern for controllers and models, the usage of namespaces for classes located in subfolders of system/library, to name just a few of the upcoming changes.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool


User avatar
Newbie

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by thbr02 » Mon Dec 07, 2015 4:14 am

Do you think an upgrade from 2.0.3.1 to 2.1.0.2 version will be an good alternative for 2.1.0.1 or may this version cause more complex changes to get my installed extension to work properly?
Last edited by thbr02 on Mon Dec 07, 2015 6:33 pm, edited 1 time in total.

Newbie

Posts

Joined
Wed Jun 22, 2011 10:30 pm
Location - Sweden

Post by OSWorX » Mon Dec 07, 2015 6:10 pm

JNeuhoff wrote:I am afraid there won't be a pure bugfix release for 2.1.0.1. Looking at the code of the upcoming 2.1.0.2 in the master branch, it may include some bugfixes, but it will also have some significant changes to the system core, such as using a new factory class to foster a factory design pattern for controllers and models, the usage of namespaces for classes located in subfolders of system/library, to name just a few of the upcoming changes.
So more a 2.2.x than a 2.1.0.2 because it will break everything - correct?

Image


User avatar
Newbie

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by JNeuhoff » Mon Dec 07, 2015 6:19 pm

OSWorX wrote: So more a 2.2.x than a 2.1.0.2 because it will break everything - correct?
Not necessarily, at the moment it is still work in progress, it's all in the system/engine (classes DIContainer and Factory), most 3rd party extensions should work without any modifications.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool


User avatar
Newbie

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Alex Kov » Fri Dec 11, 2015 2:10 am

Hi! Many people are waiting for a new release.
Guys, what is your plan? The new version will be ready this year?

User avatar
Newbie

Posts

Joined
Sun Dec 06, 2015 7:30 am
Location - Ukraine
Who is online

Users browsing this forum: No registered users and 7 guests