Post by bill62 » Wed Oct 14, 2015 7:46 am

czorny wrote:
pm-netti wrote:True, changing data (serialize> json_encode) will cause unnecessary headaches to upgrading aspiring.
These "unnecessary headaches" can be solved by just one line in each index.php file.

Catalog:

Insert

Code: Select all

if (!json_decode($result['value'], true)) $config->set($result['key'], unserialize($result['value']));
After

Code: Select all

$config->set($result['key'], json_decode($result['value'], true));
Admin:

Insert

Code: Select all

if (!json_decode($setting['value'], true)) $config->set($setting['key'], unserialize($setting['value']));
After

Code: Select all

$config->set($setting['key'], json_decode($setting['value'], true));
Then just open and re-save all your settings, modules, totals etc. These 2 lines could save a lot of time and nerves to many people.

There's also another place, where similar check can be added, but once you've reopened and saved all your settings, it's not necessary to add anything.
how about updating the DB tables and so on?

New member

Posts

Joined
Sat Apr 19, 2014 8:19 am

Post by czorny » Wed Oct 14, 2015 1:34 pm

bill62 wrote:how about updating the DB tables and so on?
That was the easy part, I just updated them tables manually. Opened two SQL files and compared them: from my previous version and from 2.1.0.1.

New member

Posts

Joined
Sat Sep 08, 2012 2:37 am

Post by pm-netti » Wed Oct 14, 2015 6:26 pm

czorny wrote: These "unnecessary headaches" can be solved by just one line in each index.php file.
I do not recommend making changes to the index.php file.
One option admin user permissions:
File system/library/user.php and method "hasPermission":

Code: Select all

}else{
    return false;
}
change to:

Code: Select all

} else{
  return true; // return false;
}
And go to admin > user > user groups > add all pemissions to Top Adminstrartor.
Then change file library/user.php again.
( Ps. Elimination of this file is the next version? )

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by czorny » Wed Oct 14, 2015 8:08 pm

pm-netti wrote:
czorny wrote:I do not recommend making changes to the index.php file.
First of all, these changes are temporarily and absolutely harmless. Second, my quick fix was about re-saving settings in new JSON format. You can't do this easily without making changes in index.php files, because all settings are loaded right in them. This has absolutely nothing to do with permissions.

New member

Posts

Joined
Sat Sep 08, 2012 2:37 am

Post by sunsys » Sun Oct 18, 2015 9:04 am

OSWorX wrote:Just for those of us who want to know about database changes.

New:
api_ip
api_session
cart
customer_wishlist

Removed:
customer_ban_ip

When I have more time, I will check for possible changes on the remaining tables - or if someone else will do that post it here.
So we can safely assume whatever db table are carried forward from 2.0.3.1 to 2.1.0.1 there is no change in structure or even that could have changed, do you have any information on that.

Thank You.

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Active Member

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by OSWorX » Sun Oct 18, 2015 4:03 pm

One important change, nowhere mentioned until now: all config settings are stored from now on as
JSON instead as SERIALIZED
fields!

And alll backend customer actions are now under customer to find - was former under sale (this is more for developers).

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by czorny » Sun Oct 18, 2015 4:19 pm

OSWorX wrote:One important change, nowhere mentioned until now: all config settings are stored from now on as
JSON instead as SERIALIZED fields!
Nowhere mentioned, huh? Care to read posts above?

New member

Posts

Joined
Sat Sep 08, 2012 2:37 am

Post by iplocker » Sun Oct 25, 2015 3:25 am

Is just amazing that there is no Instructions to upgrade to the latest version .
And its very sad to see all the problems users have to upgrade to new version like
Upgrade Errors With V2.1.0.1

UserVoice 2nd choise
a Automatic Upgrade ignored and ignored as of course all the other features there! So no respect to ppls voted there !

Ppls asking how to upgrade and there is no official answer-instructions about something that it should be already in the upgrade.txt, but its not !

I said it once upon a time I am saying it again , Daniel consider to change your business model , make Opencart Paid Cart, 5 Euros per registration , and take the money to hire professionals coders and explode this software to the top .

Theo

Active Member
Online

Posts

Joined
Sun May 26, 2013 6:39 pm


Post by beipink » Sun Oct 25, 2015 9:07 pm

iplocker wrote:Is just amazing that there is no Instructions to upgrade to the latest version .

Agreed! More attention should be given to upgrade instructions that come with OC package.
iplocker wrote:
UserVoice 2nd choise
a Automatic Upgrade ignored and ignored as of course all the other features there! So no respect to ppls voted there !
they are working on some of the features, automatic upgrade is probably not possible. I for one would happily leave it out and provide instructions for manual upgrade. More so if an automatic upgrade feature requires a lot of resources to get it working every time. Once you have set up a shop that is stable you probably well be ok for few years.
iplocker wrote: I said it once upon a time I am saying it again , Daniel consider to change your business model , make Opencart Paid Cart, 5 Euros per registration , and take the money to hire professionals coders and explode this software to the top .
If this was a good business model wouldn't you have it done yourself? I think OC business model is superb and in fact more and more open-source projects become sustainable by following this same model.

Active Member

Posts

Joined
Tue Mar 20, 2012 7:43 pm

Post by OSWorX » Sun Oct 25, 2015 9:30 pm

beipink wrote:I think OC business model is superb and in fact more and more open-source projects become sustainable by following this same model.
If all would follow the non-existing release management like Opencart has, nobody would be able to create webshops anymore.
Next is adding non documented changes in the core and changing important core function in minor releases cannot be true at all.
Next is publishing extensions which are almost the same (difference may be only the version number) and earning money for such cannot be a serious 'business' model.
And finally a so called 'support' who do not know the code and answering support requests in a terrible unprofessional way is no support.

So where is the 'superb' model??

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by czorny » Mon Oct 26, 2015 4:42 am

OSWorX wrote:
beipink wrote:I think OC business model is superb and in fact more and more open-source projects become sustainable by following this same model.
If all would follow the non-existing release management like Opencart has, nobody would be able to create webshops anymore.
Next is adding non documented changes in the core and changing important core function in minor releases cannot be true at all.
Next is publishing extensions which are almost the same (difference may be only the version number) and earning money for such cannot be a serious 'business' model.
And finally a so called 'support' who do not know the code and answering support requests in a terrible unprofessional way is no support.

So where is the 'superb' model??
There's no problem with the business model itself: distribute the base engine for free, charge fee for extensions. It's quite good.

The main issue is with attitude to extension developers. This, indeed, is a problem. Lack of upgrade instructions or VQMod backward compatibility (whose idea was to replace VQMod with OCMod?!) is just a tip of the iceberg. Try to report the issue on OpenCart's Github and you'll get the clear picture of who you are: an annoying insect. When I reported about lack of RUB in PayPal modules, the only thing I got was "in your dream" reply. And this is despite the fact, that RUB is accepted in PayPal payments for 2 years!

Damn, we were promised license period feature for our extensions IN MAY! In the same email with notification about commission raise. Commission was raised right in time, but we sill can't set license period and getting support requests from people, who bought extensions in 2013!

New member

Posts

Joined
Sat Sep 08, 2012 2:37 am

Post by iplocker » Mon Oct 26, 2015 5:48 am

beipink wrote: they are working on some of the features, automatic upgrade is probably not possible. I for one would happily leave it out and provide instructions for manual upgrade. More so if an automatic upgrade feature requires a lot of resources to get it working every time. Once you have set up a shop that is stable you probably well be ok for few years.
beipink who are you and how do you know that they are working in some features and automatic upgrade is off?

So you are saying make a stable eshop and leave it like this for years huh ?! Dont care about security releases and other features comes in with the new releases of the eshop huh ?!
Get serious !
Not post me again if you are not in the Opecart team !
Of course we don't know who is in or who isn't in the team but this is another story..

Theo

Active Member
Online

Posts

Joined
Sun May 26, 2013 6:39 pm


Post by pm-netti » Tue Oct 27, 2015 8:24 pm

iplocker wrote: automatic upgrade is off?
I do not take a bit wider stand to between you :)
Automatic update is a big part of the night, of course, successful database update remotely. But then, should be a very large some kind of "virtual store" that eliminates error messages until the new version of the files have been uploaded.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by davidbfranks » Wed Oct 28, 2015 12:30 am

So how is Wordpress and Prestashop able to do automatic updates and have a huge amount of 3rd party extensions, but OpenCart has struggled with this for so long?

New member

Posts

Joined
Mon Mar 04, 2013 10:31 pm
Location - London

Post by pm-netti » Wed Nov 04, 2015 6:21 pm

davidbfranks wrote:So how is Wordpress and Prestashop able to do automatic updates and have a huge amount of 3rd party extensions, but OpenCart has struggled with this for so long?
It is here:
http://www.opencart.com/index.php?route ... n_id=24347

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by sunsys » Thu Nov 05, 2015 1:29 am

pm-netti wrote:
davidbfranks wrote:So how is Wordpress and Prestashop able to do automatic updates and have a huge amount of 3rd party extensions, but OpenCart has struggled with this for so long?
It is here:
http://www.opencart.com/index.php?route ... n_id=24347
Thank you for providing the extension. Please give a brief summary of how the upgrade works and what all is NOT upgraded(eg. is the customer list along with customer history/cart/wishlist and payment details also upgraded ?), is the upgrade 100% or is anything been missed out and that the user will not have any compatibility issues in future because if I am not wrong you are installing your own engine override software to make it work with your extension hence the question of accuracy and compatibility.

Thank You for your time.

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Active Member

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by pm-netti » Thu Nov 05, 2015 1:38 am

sunsys wrote:
pm-netti wrote:
davidbfranks wrote:So how is Wordpress and Prestashop able to do automatic updates and have a huge amount of 3rd party extensions, but OpenCart has struggled with this for so long?
It is here:
http://www.opencart.com/index.php?route ... n_id=24347
Thank you for providing the extension. Please give a brief summary of how the upgrade works and what all is NOT upgraded(eg. is the customer list along with customer history/cart/wishlist and payment details also upgraded ?), is the upgrade 100% or is anything been missed out and that the user will not have any compatibility issues in future because if I am not wrong you are installing your own engine override software to make it work with your extension hence the question of accuracy and compatibility.

Thank You for your time.
I am these did "new idea", all OC versions can use same controller/upgrade/upgrade.php file.
Small add-file is to versions 1.4.7 and 1.5.0 (these structure is small different in file library/language.php or document.php)
One thing, what is not can perfectly update, it is order report from versions 1.4.x.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Iamdbat » Thu Nov 05, 2015 9:17 am

Same old story .... Opencart jumping over dead bodies to find a ring ..... THE BIGGEST ISSUE that should be concentrated on BEFORE anything else should be an upgrade engine

Now that I have some EXPERIENCE with the way that the Opencart project works ... I'll always be skeptical until I can be convinced otherwise

Opencart SHOULD be able to upgrade itself ... SIMPLE AS without issue - every OC user wants it - every OC user has complained about it but the notion is COMPLETELY IGNORED

Daniel - we have all bought into your system - why can't you be honest and simply address the obvious!

Active Member

Posts

Joined
Sat Jan 28, 2012 7:32 am

Post by sunsys » Thu Nov 05, 2015 12:10 pm

pm-netti wrote:I am these did "new idea", all OC versions can use same controller/upgrade/upgrade.php file.
Small add-file is to versions 1.4.7 and 1.5.0 (these structure is small different in file library/language.php or document.php)
One thing, what is not can perfectly update, it is order report from versions 1.4.x.
I am not referring to something that old oc's, please inform about oc-1564 onwards to oc-2101, what is the condition there as far as your upgrade extension is concerned.

Thank you.

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Active Member

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by pm-netti » Thu Nov 05, 2015 2:41 pm

sunsys wrote:
pm-netti wrote:I am these did "new idea", all OC versions can use same controller/upgrade/upgrade.php file.
Small add-file is to versions 1.4.7 and 1.5.0 (these structure is small different in file library/language.php or document.php)
One thing, what is not can perfectly update, it is order report from versions 1.4.x.
I am not referring to something that old oc's, please inform about oc-1564 onwards to oc-2101, what is the condition there as far as your upgrade extension is concerned.

Thank you.
This extension is not upload files. Files need uplaod himseft to server.
This is support to future version.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland
Who is online

Users browsing this forum: No registered users and 13 guests