Post by blabberpen » Mon Dec 15, 2014 4:42 am

I am having the worst time of it installling an opencart store.

I keep stumbling right before the last step, though in different ways. I've gone over the instructions with a fine-tooth
comb-repeatedly-but am just ont getting it right. Those online instructions I'm reading have to do with an earlier version
of opencart; by any chance have the steps changed slightly for 2.0.1.1?

Thanks in advance.


Posts

Joined
Mon Dec 15, 2014 4:35 am

Post by yodapt » Mon Dec 15, 2014 5:47 am

Another (stupid?) question : will / is vQmod a standard on OC 2.x.x?

Need control over Slideshow, Banner or Carousel speed on OC2? Slideshow Settings Extended


User avatar

Posts

Joined
Fri Jun 17, 2011 6:39 pm

Post by JAY6390 » Mon Dec 15, 2014 5:51 am

vQMod is not part of the core of OC 2.X no, but the latest version of vQmod works with OC 2.X

ImageImageImage

SEO MEGA KIT PLUS - Get your site ranking higher in the search engines
Better Product SEO URL's - Perfectly structured product links
SEO URL's Route Editor PRO - Make ANY url on your site have clean keywords - even third party extensions (remove index.php)


Image


User avatar

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by DIHI » Mon Dec 15, 2014 6:48 am

blabberpen wrote:I am having the worst time of it installling an opencart store.

I keep stumbling right before the last step, though in different ways. I've gone over the instructions with a fine-tooth
comb-repeatedly-but am just ont getting it right. Those online instructions I'm reading have to do with an earlier version
of opencart; by any chance have the steps changed slightly for 2.0.1.1?

Thanks in advance.
Ask your host if you have access to Softaculous, if you do it is a very easy 1 click install.

HTH


Posts

Joined
Sun Nov 30, 2014 12:44 am

Post by Rainforest » Mon Dec 15, 2014 10:31 am

Hi zjs297,

Having upgraded my store a few times from (started on 1.48 and am now at 1.5.6) I'd recommend copying your store to a test server and practice the upgrade there. That's really the only way to know if things will go smoothly. You never want to upgrade on the live server, that's heart attack inducing stress you don't need.

When you've got the upgrade process all set, then pick a time to do it quickly so your store upgrade is in sync with recent orders.

I'm not sure if I'll upgrade to 2.x just yet.
It seems like there are loads of issues. I really want to because it looks really promising. I'm actually going to be opening up a new store and will be experimenting by using 2.0. This way I can get used to the quirks. My other shops, which are very busy will remain on 1.5.6 for the next 3 months because like David said, if it works, don't mess with it! :laugh:


Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by Iamdbat » Wed Dec 17, 2014 1:02 am

Daniel wrote:
virgotch wrote:can we use this new release finally in real store or we need to wait some time else?
is this 2.0.1.1 stable version ? i ask because in github everyday still bugs and isues reports continue
every project is the same.

the last release was stable. the only issues reported where minior ones.

there is no issues to stop people buying and selling.
To be fair I haven't installed the update yet but I have to take you up on the above statement - Version 2.0 is not useable as it was released with modules not sizing correctly etc and banners not working etc. I suppose before I can go any further I will have to try the latest release but please bear in mind Daniel that with each release comes a lot of time consuming effort and to be honest most of us including myself are too amateur to resolve small problems for ourselves - after all we are not in the programming business are we?

For those of us that are trying to run a business we need quick fixes and easy installs - any improvement with version 2 should be miles ahead of version 1 at this stage.


Posts

Joined
Sat Jan 28, 2012 7:32 am

Post by Rainforest » Wed Dec 17, 2014 1:14 am

Using 2.0.1.1

Fixed some errors using the forum but am having a real problem with the extension installer

There is this at the top of the page:

Notice: Use of undefined constant DIR_UPLOAD - assumed 'DIR_UPLOAD' in /home2/xxxx/public_html/admin/controller/extension/installer.php on line 38

Then when you upload you get a syntax error pop up (I'm installing the version 2.x of the Export/Import tool)

and lastly

When clearing the extension installer,another error.

There is nothing on my new site but products so this is clearly a 2.0.1.1 issue
Last edited by Rainforest on Wed Dec 17, 2014 5:40 am, edited 1 time in total.


Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by JNeuhoff » Wed Dec 17, 2014 1:19 am

@ Rainforest:

You need the

define('DIR_UPLOAD', '<......>/system/upload/');

in your config.php and admin/config.php files.

MHC Web Design

Override Engine for OpenCart - extend/override core methods, language files and templates
Integrated VQMod for OpenCart 2.x - dynamic modification system for core files, controlled by XML-specifications
SEO (multilingual) for OpenCart 2.x - the ultimate SEO package with multilingual support
Instant Option Price Calculator - use your own option price formulas


User avatar

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Rainforest » Wed Dec 17, 2014 1:39 am

You need the

define('DIR_UPLOAD', '<......>/system/upload/');

in your config.php and admin/config.php files.
Thanks that worked for the first errror.

Now when I upload the extension .zip (the export/import tool). I get the pop syntax error pop up that I posted above.

Is there anyway to add mods without this installer? I hope so. This really stalls the momentum of creating this new site.


Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by yodapt » Wed Dec 17, 2014 1:43 am

What extension are you using?

Need control over Slideshow, Banner or Carousel speed on OC2? Slideshow Settings Extended


User avatar

Posts

Joined
Fri Jun 17, 2011 6:39 pm

Post by Rainforest » Wed Dec 17, 2014 2:09 am

I'm installing the opencart 2.0 export-import tool.
(http://www.opencart.com/index.php?route ... sion_id=17)


I don't really have another OCmod to test. If you know of any please provide the link and I'll try uploading that.


I don't feel comfortable buying an OCmod extensions until I figure this out.


Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by thoughtfulthumb » Wed Dec 17, 2014 3:26 am

Rainforest wrote:I'm installing the opencart 2.0 export-import tool.
(http://www.opencart.com/index.php?route ... sion_id=17)


I don't really have another OCmod to test. If you know of any please provide the link and I'll try uploading that.


I don't feel comfortable buying an OCmod extensions until I figure this out.
Im not 100%, but make sure you have no empty cells. all cells need to be filled. i had a similar problem and was told further boxes needed to be filled, this cured all errors i was seeing. Also, when typing true and false they both need ' before the text. (caused a lot of fuss too!)

Visit Thoughtfulthumb.co.uk and I would be happy to receive any thoughts or problems you pick up on! I am a new business, have had successfull previous companies and New to developing a software based website. Thank you.



Posts

Joined
Mon Oct 20, 2014 3:54 am

Post by Rainforest » Wed Dec 17, 2014 3:28 am

Im not 100%, but make sure you have no empty cells. all cells need to be filled.
Thanks for the reply. I'm a bit lost on your response. What "cells" are you referring too?

*update. I tried another mod http://www.opencart.com/index.php?route ... n_id=19233
and that too fails to upload using the extension installer.

I get a syntax error


Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by JNeuhoff » Wed Dec 17, 2014 6:10 am

@Rainforest: Can we continue this discussion in the General Support section please? It looks like you have an issue with OpenCart's extension installer, and in order to give you support, please the post exact details of your syntax error message you got on 2.0.1.1.

MHC Web Design

Override Engine for OpenCart - extend/override core methods, language files and templates
Integrated VQMod for OpenCart 2.x - dynamic modification system for core files, controlled by XML-specifications
SEO (multilingual) for OpenCart 2.x - the ultimate SEO package with multilingual support
Instant Option Price Calculator - use your own option price formulas


User avatar

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by davidcropley » Thu Dec 18, 2014 10:02 am

I don't mean to be patronising but...
You should always backup your entire site contents (all http/ files) before upgrading including your sql and use the opencart backup feature on a regular basis. Making a big leap without a parachute is never a good idea and losing a few years of your hard work in a few minutes upgrading to a potentially untried platform will make you realise this.
Turning your own hard working site to jelly will make you want to cry and will be heart breaking at least.
I tried upgrading to 2.0 and got caught in an inescapable vqmod error trap so I was relieved when I managed to get 2 years hard work back by re-uploading my files with backups from Filezilla.

I do want to upgrade to version 2 as much as everyone else but will wait until it's safe to do so. I may not ever even do it. Remember the motto: "If it ain't broke don't try to fix it!"

O0


Posts

Joined
Thu Jul 12, 2012 2:18 am

Post by slingeraap » Sat Dec 20, 2014 3:22 am

I got erros after the update seemed okay, from updating OC 1.5.6 to OC 2.0.1.1.

I did not FTP config.php and admin/config.php as it says in upgrade.txt. But the text in that file also says 'OpenCart V1.5.x TO 1.5.x' and config.php and admin/config.php are not even there, only 2 config-dist.php files of 0 bytes.

So the upgrade didn't work.

A clean install does work.

I see it is still not possible to insert products with prices including VAT. And I see there is no extension yet that is compatible with OC 2, is it? I used this one http://www.opencart.com/index.php?route ... n_id=13409 on my previous OC 1.5.6 which was good. If someone knows a compatible extension for this with OC 2.0 it would be greatly appreciated. :)

Otherwise, I will restore my backup and will revert to OC 1.5.6 again, because, I have no choice. :)


Posts

Joined
Sun Dec 05, 2010 7:02 pm

Post by techtools » Sat Dec 20, 2014 4:00 pm

Has anyone had issues with banners not activating


Posts

Joined
Thu Oct 10, 2013 2:34 pm

Post by pm-netti » Mon Dec 22, 2014 5:07 am

SabirSmaa wrote:How can I install the new version from 1.5.6.4 to 2.0.1.1 ?
Can you help me pls?
http://www.opencart.com/index.php?route ... _license=0

Image
- - - OpenCart Upgrade Service - - -


User avatar

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Iamdbat » Mon Dec 22, 2014 7:26 am

techtools wrote:Has anyone had issues with banners not activating
YES YES YES ...... same problem


Posts

Joined
Sat Jan 28, 2012 7:32 am

Post by rmi » Thu Dec 25, 2014 5:46 am

slingeraap wrote:...

I see it is still not possible to insert products with prices including VAT. And I see there is no extension yet that is compatible with OC 2, is it? I used this one http://www.opencart.com/index.php?route ... n_id=13409 on my previous OC 1.5.6 which was good. If someone knows a compatible extension for this with OC 2.0 it would be greatly appreciated. :)

Otherwise, I will restore my backup and will revert to OC 1.5.6 again, because, I have no choice. :)
You might wan't to try Bulk Product Update Pro which includes feature "Adding ability to enter gross prices – simple Prices incl Tax helper"

rmi

Posts

Joined
Tue Nov 09, 2010 3:13 am
Who is online

Users browsing this forum: No registered users and 5 guests