Post by JNeuhoff » Thu Dec 11, 2014 4:15 am

akastaff wrote:Fresh install of 2.0.1.1

When go to Marketing/Mail and go to send a newsletter I get "E-Mail Message required!" error.

This is using IE 11 version 11.0.9600.17416

If I use Chrome and do exactly the same it sends the mail message fine ??????????????
Why on earth are people still use IE? ???

Please post it as a bug report on github.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by cuscomel » Thu Dec 11, 2014 4:44 am

Hello,

I have a problem with image upload.I can not open it when I press the pen button to upload or edit ?

Can you help me :(

Newbie

Posts

Joined
Thu Dec 11, 2014 4:42 am

Post by akastaff » Thu Dec 11, 2014 4:51 am

Because a lot of customers still do :-( ... Cant think of many shops that would not test across the browsers and whilst new to opencart it seems this mail form has been the bane of opencart for some time !!

Newbie

Posts

Joined
Wed Dec 10, 2014 9:28 pm

Post by OSWorX » Thu Dec 11, 2014 5:27 am

JNeuhoff wrote:Why on earth are people still use IE? ???
And why not (while I do not like and use that shit).
We cannot force every user to use only THAT browser OpenCart is gracefully allowing!

Reminds me many years back when many websites displayed something (stupid) like:
Optimized for Internet Explorer 4.0 and Navigator 2.1

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Jmin » Thu Dec 11, 2014 5:28 am

Do we follow the upgrade text file to upgrade from 2.0.0.0? The upgrade text file says it is for 1.5.X only ???
Thank you.

Newbie

Posts

Joined
Thu Dec 11, 2014 12:49 am

Post by atnaples » Thu Dec 11, 2014 7:35 am

1. do not update from 2.0.0.0 tooo many changes, some bugs/missings in 2.0.0. the best way is fresh install and simple sql script to copy date (routes, orders, etc. changed). need script - send e-mail at atnaples[at]gmal.com

2. ie is interesting question, but everything depends on what kind of goods you are selling.
- if cosmetics, fashion, etc. - you should expect people on the phone, tablets
- selling auto/atv parts - expect rednecks coming from windows xp and ie 8-9

3. is 2.0.1.1 ready for production?
missing this or that... is not a problem. but how many products you have or categories?
i would expect transactional database (InnoDB vs MyISAM). as soon as you have 3000 categories and 15000 products
the database server will be "run away" for many reason...

4. Thirst thing is need to be killed/replaced is summernote editor. Be ready you will not be able to edit everything
on your site

User avatar
New member

Posts

Joined
Thu Dec 11, 2014 7:20 am

Post by atnaples » Thu Dec 11, 2014 7:55 am

Jmin wrote:Do we follow the upgrade text file to upgrade from 2.0.0.0? The upgrade text file says it is for 1.5.X only ???
Thank you.
is there a moderation here?

do not upgrade: fresh install and copy data....

User avatar
New member

Posts

Joined
Thu Dec 11, 2014 7:20 am

Post by pm-netti » Thu Dec 11, 2014 5:57 pm

atnaples wrote:
Jmin wrote:Do we follow the upgrade text file to upgrade from 2.0.0.0? The upgrade text file says it is for 1.5.X only ???
Thank you.
is there a moderation here?

do not upgrade: fresh install and copy data....
@atnapies
Have you tested this?
http://www.opencart.com/index.php?route ... n_id=19572

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by virgotch » Thu Dec 11, 2014 6:52 pm

is 2.0.1.1 ready for production?
if in this forum over +100 people still talking about the oc 2 problems , bugs and others etc and if even 1 big template designer still wait and didnt upate any tempalte for oc 2 and if in the forum over +30 oc developer still recommend to use 1.5 versions and more and more ...... it means if you are not developer yourself oc 2 is not ready yet for online store production

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am

Post by pm-netti » Thu Dec 11, 2014 7:31 pm

virgotch wrote:
is 2.0.1.1 ready for production?
if in this forum over +100 people still talking about the oc 2 problems , bugs and others etc and if even 1 big template designer still wait and didnt upate any tempalte for oc 2 and if in the forum over +30 oc developer still recommend to use 1.5 versions and more and more ...... it means if you are not developer yourself oc 2 is not ready yet for online store production
Because many guy "planing" back and forth, add, remove, add, remove, and add to the API user, then I recommend this change to file admin/model/user/api.php line 4:

Code: Select all

                     $this->db->query("TRUNCATE `" . DB_PREFIX . "api`");

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by mrbill » Thu Dec 11, 2014 10:44 pm

What are the changes in this release? The changelog between 2.0.1.0 and 2.0.1.1 is empty.

Also, the upgrade.txt still talks about upgrading to 1.5.x.

New member

Posts

Joined
Mon Apr 02, 2012 5:18 pm

Post by Daniel » Fri Dec 12, 2014 12:32 am

akastaff wrote:Fresh install of 2.0.1.1

When go to Marketing/Mail and go to send a newsletter I get "E-Mail Message required!" error.

This is using IE 11 version 11.0.9600.17416

If I use Chrome and do exactly the same it sends the mail message fine ??????????????
and yet works first time for me

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Daniel » Fri Dec 12, 2014 12:35 am

Daniel wrote:
akastaff wrote:Fresh install of 2.0.1.1

When go to Marketing/Mail and go to send a newsletter I get "E-Mail Message required!" error.

This is using IE 11 version 11.0.9600.17416

If I use Chrome and do exactly the same it sends the mail message fine ??????????????
and yet works first time for me
ok just spotted the issue. will look into it. i recommend not using IE for the admin.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by weyodaHK » Fri Dec 12, 2014 4:13 am

csgit wrote:Just installed OC 2.0.1.1.
I report that on mobile using on Android (browser Chrome or Firefox) when checkout with phone in normal position (vertical) the quantity is hidden, so i must turn the phone.
Customers not understand how many items they are buying. May cause problems in purchasing.
We are starting a shop so i report my experince before go live. What do you think?
Some images below.

Hi Sir,

Any updates regarding the above issues?

Thanks,

weyodaHK

Newbie

Posts

Joined
Thu Dec 11, 2014 9:43 pm

Post by webtimus » Fri Dec 12, 2014 5:46 am

Sorry, but after installation I can not find a reference to the module!
Why the link is not added in the admin menu?
Opencart 2.0.0.0

Newbie

Posts

Joined
Fri Dec 12, 2014 5:41 am

Post by DIHI » Fri Dec 12, 2014 4:28 pm

Daniel wrote:
Daniel wrote:
akastaff wrote:Fresh install of 2.0.1.1

When go to Marketing/Mail and go to send a newsletter I get "E-Mail Message required!" error.

This is using IE 11 version 11.0.9600.17416

If I use Chrome and do exactly the same it sends the mail message fine ??????????????
and yet works first time for me
ok just spotted the issue. will look into it. i recommend not using IE for the admin.
This happens for me in version 2.0.0.0 using Firefox, I do not know about the latest version as I still do not know if I can or how to upgrade, please help me with this Daniel, I love this cart and have spent many hours configuring version 2.0.0.0 not knowing about any issues at the time, I really need to get this upgraded and you are the only person really that can help me achieve that.

Apart from a few changes tot he main stylesheet my store is default as it comes out of the box please provide a dummies guide to upgrading and keeping all my products and settings.

Please, please, please apart from begging I do not know what else I can do!

New member

Posts

Joined
Sun Nov 30, 2014 12:44 am

Post by mbeerli » Fri Dec 12, 2014 10:27 pm

After the upgrade from 1.5.6.4 to 2.0.1.1 I get the following error

Notice: Use of undefined constant DIR_MODIFICATION - assumed 'DIR_MODIFICATION' in /home/content/.../system/startup.php on line 53
Notice: Use of undefined constant DIR_MODIFICATION - assumed 'DIR_MODIFICATION' in /home/content/.../system/startup.php on line 57

Newbie

Posts

Joined
Fri Dec 12, 2014 10:24 pm

Post by Daniel » Sun Dec 14, 2014 12:57 am

weyodaHK wrote:
csgit wrote:Just installed OC 2.0.1.1.
I report that on mobile using on Android (browser Chrome or Firefox) when checkout with phone in normal position (vertical) the quantity is hidden, so i must turn the phone.
Customers not understand how many items they are buying. May cause problems in purchasing.
We are starting a shop so i report my experince before go live. What do you think?
Some images below.

Hi Sir,

Any updates regarding the above issues?

Thanks,

weyodaHK
I suggest you hire a developer to alter it to how you want!

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Daniel » Sun Dec 14, 2014 1:18 am

akastaff wrote:Fresh install of 2.0.1.1

When go to Marketing/Mail and go to send a newsletter I get "E-Mail Message required!" error.

This is using IE 11 version 11.0.9600.17416

If I use Chrome and do exactly the same it sends the mail message fine ??????????????

ok i just did a commit with the fix in

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by zjs297 » Sun Dec 14, 2014 9:40 pm

Hi,

I am new to all this so was wondering if someone can help me out with a quick question.

Basically we have been using OpenCart 1.5x for nearly a year with a successful store using the Journal theme, these guys have just released their theme to be compatible with OpenCart 2.0x and most of our extension developers have too made the change.

The store is currently very busy with live orders coming though and we have a large number of past order information and customer data stored in the relevant databases.

Now the question is I would not want to loose any order/customer information, any catalogue products/categories if I upgrade to OpenCart 2.0x. We just want to have a nice and smooth transition over to OpenCart 2.0x and continue using it as normal, and still have all the data there. Is this possible? Or is there a special process involved?

Any advice/suggestions will be greatly appreciated.

Thank you!

Newbie

Posts

Joined
Sun Dec 14, 2014 9:31 pm
Who is online

Users browsing this forum: No registered users and 9 guests