Post by socratease5 » Tue Feb 19, 2019 2:23 am

I am trying to install Open Cart on Ubuntu 16.04 server. I can install PHP5 and get everything to go green except cURL I get cURL 5.6 to install and still I cannot get a green check mark

Newbie

Posts

Joined
Tue Feb 19, 2019 2:17 am

Post by Johnathan » Tue Feb 19, 2019 2:57 am

Contact your web host and ask them to do it. It's something they should be able to fix for you, since it's a server-level thing.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by socratease5 » Wed Feb 20, 2019 4:34 am

I host my own server. This just for testing. What is the minimum PHP & cURL versions required for 3.0.3 or 3.0.2

Newbie

Posts

Joined
Tue Feb 19, 2019 2:17 am

Post by Johnathan » Wed Feb 20, 2019 10:10 pm

OpenCart 3 requires a minimum of PHP 5.4. There is no curl version limitation in the installer code, just that curl be installed.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by straightlight » Thu Feb 21, 2019 6:18 am

Opencart v3 overall used to require lower PHP versions. Nowadays, PHP 7.1 and above are highly recommended and, sometimes, even an obligation depending on the vendor / distributions of packages being provided with OC.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 9 guests