Post by BernieB » Thu Jan 31, 2019 3:06 am

Hello,

Am experiencing a 504 Gateway Timeout error at the install stage of upgrading OpenCart to v3.0.3:

Upgrading from OC Version 2.0.2.0
Theme: eAgencyT3
Extensions: Mailchimp Integration v220.3
vQmod: v2.5
Website: https://lucieheaton.com
Php Version: 5.4 (this is scheduled to be updated after the OpenCart upgrade is complete/successful)

Steps taken so far:
1) vQmod: updated to v2.6.3
2) OpenCart v3.0.3.1 download and ALL files uploaded via FTP (aside from config.php and admin/config.php).
3) Visited https://lucieheaton.com/install to complete the upgrade. Page hangs and then eventually displays a 504 Gateway Timeout error
4) Frontend and backend of website both became inaccessible as this point
5) Web hosting tech support have increased the php limit in php.ini but the issue still remains. They also updated from php version 5.4 to v7 but that didn't resolve the issue either. php version 5.4 has therefore been reinstated.

Does anyone know how to resolve this error?
Is it that the steps should be taken in a different order or that there's an issue when updating from OpenCart version 2.0.2.0. to 3.0.3.1?

Thanks in advance for any help on this matter.

Bernie

Newbie

Posts

Joined
Thu Jun 18, 2015 4:17 am

Post by xxvirusxx » Thu Jan 31, 2019 5:27 am

Don't upgrade to 3.0.3.1 has many bugs.
At least 2.3.0.2.

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by BernieB » Thu Jan 31, 2019 4:49 pm

That release is over 2 years old though. Surely there must be a workaround to update this site successfully using a more recent version?

Even the theme EAGENCY-T3 Responsive Opencart Template 2.0 isn't anywhere to be found on Google - does anyone know whether it's compatible with OpenCart 3.x.x?

Many thanks.

Newbie

Posts

Joined
Thu Jun 18, 2015 4:17 am

Post by EvolveWebHosting » Fri Feb 01, 2019 2:19 am

If you're current using v2.0.2.0, why are you still using PHP 5.4? You should atleast be able to run PHP 7.0 and then update to PHP 7.2 after the upgrade has been completed. Does v2.0.2.0 even run on PHP 5.4? I've never personally tried.

It sounds like the server that the site is on failed which caused the 504 error. Without some sort of server log, it's hard to say for sure. What step of the upgrade process did you get to?

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now - Experience a higher level of support and reliability
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by BernieB » Fri Feb 01, 2019 10:32 pm

Ha! I know!

Attempts were made to update from php 5.4 to 7 before the OpenCart upgrade but the website frontend disappeared and showed a fatal error. I think it was this one (can't be sure, I've slept since!) :

Fatal error: Uncaught Error: Call to undefined function DB\mysql_connect() in
/var/sites/l/lucieheaton.com/public_html/system/library/db/mysql.php:7
Stack trace: #0...

So we reverted back to 5.4.

Newbie

Posts

Joined
Thu Jun 18, 2015 4:17 am
Who is online

Users browsing this forum: No registered users and 12 guests