Post by Marzy1357 » Wed Oct 17, 2018 6:42 am

Hi guys, I am not very experienced in this ASCII or Binary upload method thing. I have installed OC3 in couple of my stores and what I noticed, that sometimes when I upload new installation of OC3 or uploading theme, etc it doesn't work as it should, I am getting errors, etc, when I re-upload it works, I don't do or change anything else, just re-upload, means files are getting corrupted somehow during the upload. But Filezilla doesn't say that file failed to upload, it shows as successful transfer. Other interesting thing I've noticed that file sizes doesn't match for example I have index.php file on my computer that is 1032KB if I upload it on server it will become 933KB or something like that. Can someone explain me what can cause this thing? Is it has something to do with ASCII mode? Shall I use binary? Or it has something to do with Filezilla itself?
Thanks in advance

Newbie

Posts

Joined
Sat Jan 16, 2016 6:09 pm

Post by opencart.my » Sat Oct 20, 2018 9:21 pm

Hi Marzy1357,

If you are unsure, always stick to Binary mode transfer.

ASCII mode will sometimes cause problem in line-ending encoding due to different Operating System(your PC windows vs server Linux).

Most modern text editor should have no problem handling both, so it shouldn't be a problem when you reopen the files again from the server.

Developing Quality OpenCart Extensions since 2011. View my Extensions.


User avatar
New member

Posts

Joined
Mon Jan 22, 2018 6:03 pm

Who is online

Users browsing this forum: No registered users and 3 guests