Post by Theking2 » Thu Oct 11, 2018 9:05 pm

Hi

We went through the steps to upgrade a 1.4.8 OpenCart shop - projekt.
what we end up seems to work but a few things are weird
1) there are load of test_????? entries on the site now. (text_wishlist, text_return, text_extra, text_service etc.) What are these and how can we replace these with something sensible. Btw it is a German shop, is that the cause?
2) We did the upgrade in a test server first. What is a bit unclear is if we can upgrade from 1.4.8 to 1.5.6 and than straight to the current 3.0.2.0. Do we have to upgrade through all major releases?
3) We plan to use a 3rd party template. In that case should we or shouldn't we do the optional STEP 17

In the readme there is an Install: section just at the beginning instructing to extract the entire "INSTALL" folder to the store. Is this the same instruction as in STEP 4a and SETP 4b? Is the order important? So firste copy 1.5.6 files over the existing shop and than copy the upgrade folder over that, or vise versa?

Thanks

Newbie

Posts

Joined
Mon Mar 12, 2018 10:08 pm

Post by straightlight » Fri Oct 12, 2018 4:16 am

To upgrade between such versions, it would definitely be recommended to create a new service request in the Commercial Support section of the forum to get this done as a custom job.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Theking2 » Fri Oct 12, 2018 2:30 pm

Many thanks straightlight

That makes me a bit fearful is this an undertaking that is not recommended. What do you mean by "commercial section?

Newbie

Posts

Joined
Mon Mar 12, 2018 10:08 pm

Post by xxvirusxx » Fri Oct 12, 2018 2:35 pm

It mean to post on commercial topic and to hire someone to upgrade.
viewforum.php?f=88

To upgrade you can, but you need to make more steps and backup after successful upgrade.

- 1.4.8 to 1.5
- 1.5 to 2.1
- 2.1 to 2.3
- 2.3 to 3.2

But not buyed themes, extension...etc.
Possible many of text_...because you need to reupload language for upgraded version.

Free converted extensions


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by Theking2 » Fri Oct 12, 2018 8:43 pm

That doesn't matter. We can do as many steps as required. As long as there is the proper amount of documentation.
But I understand there's quite a number of people earning there living to do upgrades. So documenting this clearly will probably put some out of a job :-)

Are 1.5.x to 2.1 documented ?
viewtopic.php?t=139838

Newbie

Posts

Joined
Mon Mar 12, 2018 10:08 pm

Post by Elevate » Fri Oct 12, 2018 11:07 pm

Theking2 wrote:
Fri Oct 12, 2018 8:43 pm
That doesn't matter. We can do as many steps as required. As long as there is the proper amount of documentation.
But I understand there's quite a number of people earning there living to do upgrades. So documenting this clearly will probably put some out of a job :-)

Are 1.5.x to 2.1 documented ?
viewtopic.php?t=139838
I don't believe there is good documentation for an upgrade this large. If you'd like it done 'commercially', please email us at hello@elev8your.com to receive a quote and we can take care of the upgrade for you.

ELEV8TE Website Development
https://www.elev8your.com


New member

Posts

Joined
Fri Jul 06, 2018 12:40 am
Location - Denver, Colorado, USA

Post by Theking2 » Mon Oct 15, 2018 7:28 pm

I've taken question 1) to viewtopic.php?f=37&t=207617

(Interestingly is BE now in German, but FE in English (with only a partly translation))

I should not have asked three questions in one thread, I apologize.

Newbie

Posts

Joined
Mon Mar 12, 2018 10:08 pm
Who is online

Users browsing this forum: No registered users and 6 guests