Post by sandraolt » Thu Jun 28, 2018 12:37 pm

Hello I just upgraded my multi-store <https://olacs.us/cshsl/ec/> to Version 3.0.0.0.
I have a separate single store <https://olacs.us/cshsl/reg/> that is in Version 3.0.0.0 and it works completely as expected.
Both have only the default theme, and the newly upgrade multi-store has no add-ons or modifications.
When I first installed the multi-store, I added 1 product to the cart and when it loaded into the menu/header cart I could see that 1 product had been added but the "total" was still 0. When I click on it, it shows the product and price but no sub-total or total. I had read in a forum or somewhere that I needed to make sure that the setting 'login display prices' was set to 'no'. (it is)

I am attaching two images, one shows the single store with the expected header cart and the other shows the mulit-store (duplicate files - different database) on the exact same server with the header cart missing information.

Has anyone else run into this, and if so do we know which files I can modify to fix the problem? I am using:
Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.4.16
Database client version: libmysql - mysqlnd 5.0.10 - 20111026 -
PHP version: 5.4.16

Attachments

Screen Shot 2018-06-28 at 12.28.23 AM.png

This is the multi-store - it doesn't work. - Screen Shot 2018-06-28 at 12.28.23 AM.png (35.47 KiB) Viewed 161 times

Screen Shot 2018-06-28 at 12.22.14 AM.png

This is the single store - it works - Screen Shot 2018-06-28 at 12.22.14 AM.png (68.29 KiB) Viewed 161 times

Last edited by sandraolt on Fri Jun 29, 2018 6:37 am, edited 1 time in total.

Newbie

Posts

Joined
Thu Aug 01, 2013 2:51 am

Post by sandraolt » Thu Jun 28, 2018 1:04 pm

I just followed both stores through to checkout.
The single store is up and running - live with customers. It is working, shows the subtotal and the total at the end of the purchase process and then the space where you enter your credit card details. <https://olacs.us/cshsl/reg/index.php?ro ... t/checkout>
The multi-store, unfortunately does not show the subtotal or the total when you get to the last step of the checkout, and in fact refuses to let me use my credit card due to "invalid amount".<https://olacs.us/cshsl/ec/index.php?rou ... t/checkout>

Attachments

Screen Shot 2018-06-28 at 12.59.14 AM.png

Single store - subtotal and total work - Screen Shot 2018-06-28 at 12.59.14 AM.png (75.12 KiB) Viewed 152 times

Screen Shot 2018-06-28 at 12.59.03 AM.png

multi-store - subtotal and total don't work. - Screen Shot 2018-06-28 at 12.59.03 AM.png (84.93 KiB) Viewed 152 times


Newbie

Posts

Joined
Thu Aug 01, 2013 2:51 am

Post by sandraolt » Thu Jun 28, 2018 1:12 pm

OK, right now I am feeling a bit foolish - I just manually went into the extensions and turned on the totals - now the checkout is working in the default theme with no modifications. Next I will try to customize the store, and install the themes and modifications that I want.

Newbie

Posts

Joined
Thu Aug 01, 2013 2:51 am
Who is online

Users browsing this forum: No registered users and 7 guests