Post by james1810 » Thu Jun 07, 2018 3:36 am

I'm trying to move a store from one domain to another. Not just a different domain but also on a different hosting server

Done all the usual when it comes to moving DB and files and making the quick edits to both config files but started with tons of errors and quickly realised that the old server and new serer had totally different home directories.

The working website on old domain and server config below

// DIR
define('DIR_APPLICATION', '/var/www/vhosts/domainname/httpdocs/catalog/');
define('DIR_SYSTEM', '/var/www/vhosts/domainname/httpdocs/system/');
define('DIR_IMAGE', '/var/www/vhosts/domainname/httpdocs/image/');
define('DIR_STORAGE', '/var/www/vhosts/domainname/httpdocs/storage/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/theme/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/')

After making changes to the config I now have this config file setup on the new one below, i have also tried using absolute paths and not relative as other opencart sites on the new hosting server on a normal install use absolute paths so gave it a try to remove errors as you will see below.

The site now on new domain and server config below

// DIR
define('DIR_APPLICATION', '/home/domainname/public_html/catalog/');
define('DIR_SYSTEM', '/home/domainname/public_html/system/');
define('DIR_IMAGE', '/home/domainname/public_html/image/');
define('DIR_STORAGE', '/home/domainname/public_html/storage/');
define('DIR_LANGUAGE', DIR_APPLICATION . '/home/domainname/public_html/catalog/language/');
define('DIR_TEMPLATE', DIR_APPLICATION . '/home/domainname/public_html/catalog/view/theme//');
define('DIR_CONFIG', DIR_SYSTEM . '/home/domainname/public_html/system/config/');
define('DIR_CACHE', DIR_STORAGE . '/home/domainname/public_html/system/storage/cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . '/home/domainname/public_html/system/storage/download/');
define('DIR_LOGS', DIR_STORAGE . '/home/domainname/public_html/system/storage/logs/');
define('DIR_MODIFICATION', DIR_STORAGE . '/home/domainname/public_html/system/storage/modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . '/home/domainname/public_html/system/storage/upload/');

With the config above I have removed all the cant find and cannot load errors but now have a vqmod error below

Notice: Error: Could not load config default! in /home/domainname/public_html/vqmod/vqcache/vq2-system_library_config.php on line 63

Does anyone know what im doing wrong, or what the next steps would be to get this migrated correctly so it loads ok?

thanks

James

Newbie

Posts

Joined
Thu Nov 19, 2015 11:56 pm

Post by IP_CAM » Thu Jun 07, 2018 4:33 am

.... /view/theme//'); ???

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by james1810 » Fri Jun 08, 2018 6:22 pm

thanks :)

always the little things

Newbie

Posts

Joined
Thu Nov 19, 2015 11:56 pm
Who is online

Users browsing this forum: No registered users and 6 guests