Post by snirp » Thu May 03, 2018 4:53 pm

I did an upgrade from 2.0.0 to 3.0.2 and ran into an error:

Code: Select all

[:error] [pid 26459] [client 92.108.86.200:57305] PHP Fatal error:  Uncaught TypeError: Argument 2 passed to Event::trigger() must be of the type array, string given, called in /var/www/html/system/storage/modification/system/engine/loader.php on line 119 and defined in /var/www/html/system/engine/event.php:59\nStack trace:\n#0 /var/www/html/system/storage/modification/system/engine/loader.php(119): Event->trigger('language/en-gb/...', 'en-gb')\n#1 /var/www/html/system/framework.php(139): Loader->language('en-gb')\n#2 /var/www/html/system/startup.php(104): require_once('/var/www/html/s...')\n#3 /var/www/html/install/index.php(37): start('install')\n#4 {main}\n  thrown in /var/www/html/system/engine/event.php on line 59
The key bit seems to be that:

Code: Select all

Argument 2 passed to Event::trigger() must be of the type array, string given
, and indeed the argument is

Code: Select all

'en-gb'
.

From looking around, it seems that the error is most likely related to changes made in version 2.3.0, but I was not able to find the exact cause, nor how to resolve this.

Please advise.

Newbie

Posts

Joined
Thu May 03, 2018 4:48 pm

Post by IP_CAM » Fri May 04, 2018 1:18 am

Well, did you get your old Version DB upgraded by a Professional, or did you
really expect it to still function, without beeing modified, to match OC-3?
But then, you did not read about it first around here ... 8)
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 4 guests