Post by cybertai » Wed Apr 04, 2018 4:35 pm

Hi, after copying all the files via FTP, i head on to /install and it shows me

Code: Select all

Error: A theme has not been assigned to this store!
I tried to enter admin and it shows me this:
Image

Newbie

Posts

Joined
Wed Apr 04, 2018 4:17 pm

Post by straightlight » Wed Apr 04, 2018 10:39 pm

In your OC database setting table, ensure the theme_default_status 's value is set to 1 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by olhutch » Tue Apr 10, 2018 1:28 am

Hi, I've got the same problem, my theme_default_status is set to 1. I have a few more options on the menu though (everything but the extentions options).
In System Setting my Theme is set to "heading_title" and its the only option in the drop down box, I was previously using a Big Shop Theme.
Any other Idea's? Thanks is advance for any help.

Cheers

Newbie

Posts

Joined
Tue Apr 10, 2018 1:22 am

Post by bne » Fri May 11, 2018 7:21 pm

Hello, same issue here. After upgrading from 1.5.6 to 3.0.2.0 the message "Error: A theme has not been assigned to this store!" appears. In Backend under "System" / "Settings" in the corresponding Shop Entry under "Theme" we have the only option "heading_title". If the entry is saved withoud changes (therefore it will save the "heading_title" as Theme :) an error "Warning: Please check the form carefully for errors! " is thrown. Any ideas how i can put in the theme?

bne
Newbie

Posts

Joined
Fri May 11, 2018 7:15 pm

Post by ms_cjohansson » Fri May 25, 2018 2:33 pm

Hey I was able to fix this, the problem is that the default theme is not activated when you have performed an upgrade.

* First verify that your admin users group has all the permissions by clicking System > Users > Your user and then System > Users > User Groups.
* Second visit Extensions > Extensions, select Themes, then press the + button to active default theme
* Third visit System > Settings > Main Store > Select default theme and then save
* Fourth visit front-page to verify that problem is solved

Newbie

Posts

Joined
Thu May 24, 2018 8:32 pm

Post by laurietabg » Fri Aug 31, 2018 2:28 pm

ms_cjohansson wrote:
Fri May 25, 2018 2:33 pm
Hey I was able to fix this, the problem is that the default theme is not activated when you have performed an upgrade.

* First verify that your admin users group has all the permissions by clicking System > Users > Your user and then System > Users > User Groups.
* Second visit Extensions > Extensions, select Themes, then press the + button to active default theme
* Third visit System > Settings > Main Store > Select default theme and then save
* Fourth visit front-page to verify that problem is solved
Okay and what if IT IS assigned? I see my theme in Modules (and it is forbidden) , but not in Themes. Been stuck 3 days and can`t manage to enable it.

Newbie

Posts

Joined
Tue Aug 21, 2018 4:10 pm

Post by olahmyde » Sat Sep 01, 2018 3:08 am

laurietabg wrote:
Fri Aug 31, 2018 2:28 pm
ms_cjohansson wrote:
Fri May 25, 2018 2:33 pm
Hey I was able to fix this, the problem is that the default theme is not activated when you have performed an upgrade.

* First verify that your admin users group has all the permissions by clicking System > Users > Your user and then System > Users > User Groups.
* Second visit Extensions > Extensions, select Themes, then press the + button to active default theme
* Third visit System > Settings > Main Store > Select default theme and then save
* Fourth visit front-page to verify that problem is solved
Okay and what if IT IS assigned? I see my theme in Modules (and it is forbidden) , but not in Themes. Been stuck 3 days and can`t manage to enable it.
I could help out? if you're ready, hit me up. I wouldn't request for your admin details dont worry. I have been in a situation like this, so i might be able to help

New member

Posts

Joined
Tue Apr 10, 2018 1:24 am

Post by straightlight » Mon Sep 03, 2018 1:42 am

Regarding the heading_title key, the language code must be properly defined in the oc_language table.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by rlmodranski » Fri Sep 14, 2018 2:29 am

Laurietagb's fix worked to restore my dashboard; however, I still have the error on my store frontpage. Any other ideas????

Newbie

Posts

Joined
Wed Nov 21, 2012 10:44 am

Post by rlmodranski » Fri Sep 14, 2018 3:15 am

ms_cjohansson wrote:
Fri May 25, 2018 2:33 pm
Hey I was able to fix this, the problem is that the default theme is not activated when you have performed an upgrade.

* First verify that your admin users group has all the permissions by clicking System > Users > Your user and then System > Users > User Groups.
* Second visit Extensions > Extensions, select Themes, then press the + button to active default theme
* Third visit System > Settings > Main Store > Select default theme and then save
* Fourth visit front-page to verify that problem is solved
This fixed a dashboard problem I had; however, I still have no theme, and now I don't have permission to change anything. I get this warning in a pretty pink strip across the top of the page: Warning: You do not have permission to modify settings! And a similar warning in all other modules. HELP!!!

Newbie

Posts

Joined
Wed Nov 21, 2012 10:44 am

Post by rlmodranski » Fri Sep 14, 2018 10:56 am

Could you give us all a heads up on how to fix this?
It's not letting me upgrade my permissions, so I can't change to the default theme . . .

olahmyde wrote:
Sat Sep 01, 2018 3:08 am
laurietabg wrote:
Fri Aug 31, 2018 2:28 pm
ms_cjohansson wrote:
Fri May 25, 2018 2:33 pm
Hey I was able to fix this, the problem is that the default theme is not activated when you have performed an upgrade.

* First verify that your admin users group has all the permissions by clicking System > Users > Your user and then System > Users > User Groups.
* Second visit Extensions > Extensions, select Themes, then press the + button to active default theme
* Third visit System > Settings > Main Store > Select default theme and then save
* Fourth visit front-page to verify that problem is solved
Okay and what if IT IS assigned? I see my theme in Modules (and it is forbidden) , but not in Themes. Been stuck 3 days and can`t manage to enable it.
I could help out? if you're ready, hit me up. I wouldn't request for your admin details dont worry. I have been in a situation like this, so i might be able to help

Newbie

Posts

Joined
Wed Nov 21, 2012 10:44 am
Who is online

Users browsing this forum: No registered users and 7 guests