Post by bmeek » Sun Apr 01, 2018 4:25 am

I upgraded my website from version 1.5.2.1 to 3.0.2.0. The link is http://www.knives-novelties.com. I'm getting a page full of gibberish. Can someone tell me what I did wrong or what I didn't do?

Newbie

Posts

Joined
Mon Mar 19, 2012 5:36 pm

Post by straightlight » Sun Apr 01, 2018 4:27 am

Caused by missing defined statement in your config.php and admin/config.php files. See this post to import all the defined constants OC requires: viewtopic.php?f=199&t=198781&p=699560#p699560

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by bmeek » Sun Apr 01, 2018 5:07 am

I went to that website but not sure on how or what I need to do.

Newbie

Posts

Joined
Mon Mar 19, 2012 5:36 pm

Post by straightlight » Sun Apr 01, 2018 5:42 am

The steps are provided on that post. Of course, the StackOverFlow step is optional.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by bmeek » Sun Apr 01, 2018 8:29 am

The instructions are not clear on exactly what to do. Not sure if I add to the config file or replace all that is in the config file?

I replaced the directory part only of the config file and now getting these errors:

When going to http://www.knives-novelties.com I am getting "Error: A theme has not been assigned to this store!"

When going to http://www.knives-novelties.com/admin/ I am getting "Warning: fopen(/home/bmeek/public_html/knives-novelties.com/catalog/view/theme//stylesheet/stylesheet.css): failed to open stream: No such file or directory in /home/bmeek/public_html/knives-novelties.com/catalog/controller/startup/sass.php on line 14Warning: flock() expects parameter 1 to be resource, boolean given in /home/bmeek/public_html/knives-novelties.com/catalog/controller/startup/sass.php on line 16Warning: fwrite() expects parameter 1 to be resource, boolean given in /home/bmeek/public_html/knives-novelties.com/catalog/controller/startup/sass.php on line 18Warning: fflush() expects parameter 1 to be resource, boolean given in /home/bmeek/public_html/knives-novelties.com/catalog/controller/startup/sass.php on line 20Warning: flock() expects parameter 1 to be resource, boolean given in /home/bmeek/public_html/knives-novelties.com/catalog/controller/startup/sass.php on line 22Warning: fclose() expects parameter 1 to be resource, boolean given in /home/bmeek/public_html/knives-novelties.com/catalog/controller/startup/sass.php on line 24"

Newbie

Posts

Joined
Mon Mar 19, 2012 5:36 pm

Post by IP_CAM » Sun Apr 01, 2018 1:50 pm

Well, you should better have been reading this before, it would have possibly saved you
a lot of time. But it's a Secret, I don't want everybody to know about , so, keep it for you,
since such attempts might easy end up like this: ..... done as a custom job.,
as mentioned by someone on the other page... :choke:
Good Luck! ;)
Ernie
---
viewtopic.php?f=199&t=203243&p=719160#p719160
---

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Sun Apr 01, 2018 7:18 pm

Based on the last error message, since it's not the same error message as your first post, in your PHPMyAdmin console in your Opencart database, use the search tab to your right and query: theme_default_status . Ensure to select the setting table on the list below.

Change the value field's value to: 1.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by bmeek » Sun Apr 01, 2018 8:30 pm

Since I believe I have hosed my website at knives-novelties.com I have done a clean install of 3.0.2.0 at bm-toys.com. Seems to be working. Before I attempted all this I did backup the database within admin system backup. I went to the restore database in the new install and I'm getting internal server error. Can I get the old database restored to the new install? I'm thinking now I lost over 1000 items that I had in my store.

Newbie

Posts

Joined
Mon Mar 19, 2012 5:36 pm

Post by straightlight » Sun Apr 01, 2018 10:04 pm

The OC Admin-end has a restore feature. You could also use PHPMyAdmin to restore your database or your server restoration point from your server backup.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 6 guests