Post by Sokonomi » Mon Mar 12, 2018 9:56 pm

I am trying to migrate my shop from one server to another.
The front end seems to be functioning well, but I cant seem to get into the backend.
Warning: require_once(/customers/3/e/0/bekerhuislambregts.nl/httpd.www/system/startup.php): failed to open stream: No such file or directory in C:\xampp\htdocs\customers\3\e\0\bekerhuislambregts.nl\httpd.www\admin\index.php on line 21

Fatal error: require_once(): Failed opening required '/customers/3/e/0/bekerhuislambregts.nl/httpd.www/system/startup.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\customers\3\e\0\bekerhuislambregts.nl\httpd.www\admin\index.php on line 21
I have checked by putting the full file path in my browser, it certainly is there.

My /admin/config.php:
<?php
// HTTP
define('HTTP_SERVER', 'http://REDACTED/customers/3/e/0/bhl.nl/httpd.www/admin/');
define('HTTP_CATALOG', 'http://REDACTED/customers/3/e/0/bhl.nl/httpd.www/shop/');

// HTTPS
define('HTTPS_SERVER', 'http://REDACTED/customers/3/e/0/bhl.nl/httpd.www/admin/');
define('HTTPS_CATALOG', 'http://REDACTED/customers/3/e/0/bhl.nl/httpd.www/');

// DIR
define('DIR_APPLICATION', '/customers/3/e/0/bhl.nl/httpd.www/admin/');
define('DIR_SYSTEM', '/customers/3/e/0/bhl.nl/httpd.www/system/');
define('DIR_IMAGE', '/customers/3/e/0/bhl.nl/httpd.www/image/');
define('DIR_STORAGE', '/customers/3/e/0/bhl.nl/httpd.www/storage/');
define('DIR_CATALOG', '/customers/3/e/0/bhl.nl/httpd.www/catalog/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/template/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');

// DB
define('DB_DRIVER', 'mysqli');
define('DB_HOSTNAME', 'REDACTED');
define('DB_USERNAME', 'bhl');
define('DB_PASSWORD', 'REDACTED');
define('DB_DATABASE', 'bhl');
define('DB_PORT', '3306');
define('DB_PREFIX', 'bhl_');

// OpenCart API
define('OPENCART_SERVER', 'https://www.opencart.com/');

Anyone have any idea what could be causing this?

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am

Post by Sokonomi » Mon Mar 12, 2018 10:33 pm

I managed to get it going by changing the relative paths to absolute ones.
This works on my home server, but I doubt my host will let me path back to C:\ ::)
How do I go about doing this once its time to migrate it to my host?

Active Member

Posts

Joined
Sun Sep 30, 2012 4:52 am

Post by IP_CAM » Tue Mar 13, 2018 2:12 am

Well, this is sure no URL, but a mix of Site URL and Server Path! :'(
Ernie

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://REDACTED/customers/3/e/0/bhl.nl/httpd.www/admin/');
define('HTTP_CATALOG', 'http://REDACTED/customers/3/e/0/bhl.nl/httpd.www/shop/');
// HTTPS
define('HTTPS_SERVER', 'http://REDACTED/customers/3/e/0/bhl.nl/httpd.www/admin/');
define('HTTPS_CATALOG', 'http://REDACTED/customers/3/e/0/bhl.nl/httpd.www/');

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 3 guests