Post by gabe_avila » Mon Mar 12, 2018 6:09 am

"PreInstallation 2/4 Check your server is set-up correctly" shows Extension "GD" off.

OS: "Ubuntu 16.04.3 LTS"
PHP packages installed: php7.0 libapache2-mod-php7.0 php7.0-gd

What's the latest PHP version that will work?

Thanks!

Newbie

Posts

Joined
Sun Mar 11, 2018 3:41 am

Post by gabe_avila » Tue Mar 13, 2018 2:12 am

Figured it out. The following packages list seems to have done the trick:
php7.2 php-pear php7.2-curl php7.2-dev php7.2-gd php7.2-mbstring php7.2-zip php7.2-mysql php7.2-xml

Newbie

Posts

Joined
Sun Mar 11, 2018 3:41 am

Post by IP_CAM » Tue Mar 13, 2018 2:26 am

Well, latest Versions usually still have some not yet known failures and bugs,
regardless of beeing PHP or any other software, as history confirms. But latest
releases of PHP 7.0.x and 7.1.x should already be relatively stable. For Testers,
it would not make a difference, but if one really plans to to do business, one
should never rely on something like a 'latest' release, not by Microsoft, nor
anywhere else.
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Tue Mar 13, 2018 4:08 am

Testing the latest version on a DEV server environment is indeed one of the best way to find out if the latest version of PHP is compatible before launching a live store. Upgrading PHP may be for many reasons. Although, it should not be used without knowing the changelogs and / or without contacting the provider.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 7 guests