Post by wackychick » Mon Feb 12, 2018 12:00 am

I get the frequently mentioned error about moving the storage directory but cannot make it work. but what confuses me is it seems like the OC admin dashboard will let me do it but it is all greyed out (see attached screenshot) so I have to do it by hand. which is not working. I've installed several versions of OC (just not recently) but this is so frustrating. I've read the instructions posted here over and over and have done it over and over with the same results. I'm running the latest OC 3.0.2.0 and on linux server with php 7.1 - shop folder is under my main domain /home/blahblahblah/public_html/blahblahblah.com/shop and when I move the storage folder from system to /home/blahblahblah/public_html/blahblahblah.com/storage and make the same edit in the config file, and then comment out the line in the htaccess file, I get several errors - see below. (obviously I've replaced my domain name with blahblahblah). Any clues on what I'm doing wrong?

Warning: fopen(/home/blahblahblah/public_html/blahblahblah.com/shop/system/storage/logs/openbay.log): failed to open stream: No such file or directory in /home/blahblahblah/public_html/blahblahblah.com/shop/system/library/log.php on line 22Warning: fopen(/home/blahblahblah/public_html/blahblahblah.com/shop/system/storage/logs/openbay.log): failed to open stream: No such file or directory in /home/blahblahblah/public_html/blahblahblah.com/shop/system/library/log.php on line 22Warning: fclose() expects parameter 1 to be resource, boolean given in /home/blahblahblah/public_html/blahblahblah.com/shop/system/library/log.php on line 39Warning: fopen(/home/blahblahblah/public_html/blahblahblah.com/shop/system/storage/logs/error.log): failed to open stream: No such file or directory in /home/blahblahblah/public_html/blahblahblah.com/shop/system/library/log.php on line 22

Attachments

ss_oc_storagedirectory.jpg

ss_oc_storagedirectory.jpg (293.3 KiB) Viewed 962 times


User avatar
Newbie

Posts

Joined
Tue Jan 27, 2015 8:05 pm

Post by straightlight » Mon Feb 12, 2018 2:05 am

Any clues on what I'm doing wrong?

Warning: fopen(/home/blahblahblah/public_html/blahblahblah.com/shop/system/storage/logs/openbay.log)
When was this moved exactly? The same original path is displaying in your error message ...

There are enough posts on my behalf on the forum showing how to do this: viewtopic.php?f=202&t=201745#p713479

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by wackychick » Wed Feb 14, 2018 5:16 am

I'm not sure I understand "when" - when I did it... I mean I installed, got the greyed out message about moving the storage directory, and then moved it. then I got all the errors - yes the errors do show the storage folder in its original spot but its not. i can't figure it out. And yes - as I mentioned I found several posts about it - that's how I got the instructions for doing it. And apparently I'm doing it wrong. I do not understand where to find how to clear my OC cache as you describe though. There isnt' anything like that in the admin ->dashboard, or the other admin location you mention. I know how to clear my cache in my browser which I've done as well. I'm at a point where I've done this 4 times. I'm about to try it again. I've shed tears and torn hair out. I have an opencart cart that I've used for about 3-4 years, and now i'm completely stuck. I have a couple hundred products in it and I'm about to burst into flames from frustration. I can't conceive of switching to another cart, after that is what brought me to opencart several years ago. I'm on godaddy hosting and they have a kind of weird setup from what I've worked with on other hosts. I'm just at my wits end. But I still don't see why I can't use the little thing in the admin that pops up when I login telling me to move the directory - its all greyed out (screenshot that I attached to original post). Doesn't this work somehow?

From your link:
Ensure your system/storage folder is outside your public_html folder. (Did that) Edit your config.php and admin/config.php files and set the new location for your DIR_STORAGE. (did that) Remove the entire line in your .htaccess where it says: ^system/storage . (other instructions say to comment it out, which I did) Set recursive permission settings to your storage folder. (it's at 755) Clear all OC cache from your admin - > dashboard and from your admin - > extensions - > modifications - > refresh button. (this part I don't get)

User avatar
Newbie

Posts

Joined
Tue Jan 27, 2015 8:05 pm

Post by wackychick » Wed Feb 14, 2018 6:26 am

Thanks for trying to help but I just give up in desperation. I've tried every variation of path name I can and it still thinks that directory is still in the System file. I will be going to another shopping cart that can import my opencart backup. I've spent hours on something that should have taken me thirty minutes tops. it's this crazy Godaddy setup. nothing works like it did on my old hosts.

User avatar
Newbie

Posts

Joined
Tue Jan 27, 2015 8:05 pm

Post by straightlight » Wed Feb 14, 2018 6:36 am

Set recursive permission settings to your storage folder. (it's at 755) Clear all OC cache from your admin - > dashboard and from your admin - > extensions - > modifications - > refresh button. (this part I don't get)
I've spent hours on something that should have taken me thirty minutes tops. it's this crazy Godaddy setup. nothing works like it did on my old hosts.
This is still unofficial since you mentioned to be unable to find the admin - > dashboard - > blue button that should be located on the right-end side of your dashboard as well as being unable to find the admin - > extensions - > modifications - > refresh button. Use the left menu and go to these pages. As for the refresh button, once being in the modifications page, roll-over on each top-right buttons and one will say: Refresh (which should be the first one on the left).

As for the .htaccess line, either commenting out or removing the line is the same in this case - no difference.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by wackychick » Wed Feb 14, 2018 7:24 am

yeah no go. I also discovered that the storage directory is somehow reappearing in the system folder after I move it, even though it also exists where I moved it, but now both have nothing but a cache folder inside - all those other folders are gone from inside the storage directory now. I found the refresh buttons, but the one on the admin/dashboard was greyed out and I'm unable to click either refresh button it shows me. The refresh button in the extensions/modification area didn't do anything but there aren't any modifications on that list either whatever that may mean.

User avatar
Newbie

Posts

Joined
Tue Jan 27, 2015 8:05 pm

Post by straightlight » Wed Feb 14, 2018 7:27 am

If both cache options are grayed out, ensure both options are enabled from that modal window before actually clearing those caches. As for the storage folder, you need to edit your DIR_STORAGE from both config.php and admin/config.php after moving the storage folder outside your public_html folder as indicated from the pointed topic.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by wackychick » Wed Feb 14, 2018 7:53 am

modal window? did the edits on both config files too. Should the htaccess be .htaccess or .htaccess.txt? Opencart has always been so easy for me til now. this is insane.

User avatar
Newbie

Posts

Joined
Tue Jan 27, 2015 8:05 pm

Post by straightlight » Wed Feb 14, 2018 7:56 am

The modal window I was referring is from your admin - > dashboard page. Ensure both cache inside the blue button on the right-end side they are both installed before clearing the cache.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by wackychick » Wed Feb 14, 2018 8:04 am

OMG I FINALLY FIGURED OUT THE CORRECT PATH NAME! ADMIN BACKEND WORKING WITHOUT ERRORS!!!!!!!!! FRONT END WORKING WITHOUT ERRORS!!! Oh lordy this last few days has been exhausting... Thank you again for sticking with me!!! I knew it was something I was doing wrong with this wacky godaddy setup... Now I just have to import my backup - wish me luck.

User avatar
Newbie

Posts

Joined
Tue Jan 27, 2015 8:05 pm

Post by LordThanatos » Mon Feb 26, 2018 3:20 pm

It seems I had the same issue, and I was apparently able to solve the problem with this guide. I've only been messing with OC for a short while, but I see your name all over the forum helping out. So, thank you, straightlight! ;D

So, I've put the storage folder outside of what my host named 'httpdocs'. The 'problem' is that I have no rights to create any folders in in the /home/vhosts/xxx.com folder. I do, however, have an existing folder there called 'private'. I moved the storage folder there... Seems to work, but would there ever be any kind of problem with that? Or should I ask my host to make (or allow me to make) a storage folder in /home/vhosts/xxx.com?

There's a lot of work to do before I can launch my webshop, so I don't want to redo all that stuff later if this would be a problem :)

OpenCart 3.0.2.0. in English & Dutch
Extensions: Inverted Dark Opencart Theme // Dependent Options // PDF Invoice Pro // (2.x/3.x) New Returns E-mail // iSenseLabs GDPR // (2.x/3.x) Total-Based Shipping // PostNL Wereld OC3.x


User avatar
Newbie

Posts

Joined
Sun Feb 18, 2018 5:54 am

Post by IP_CAM » Tue Feb 27, 2018 2:49 am

Some Solutions for this exist already, as it looks:
---
Remove "Important Security Notification" 3.x
https://www.opencart.com/index.php?rout ... n_id=31807
---
GGW Installer fix Allow ALL directories to be written
https://www.opencart.com/index.php?rout ... n_id=31130
---

For Sale: Top URL's, including an OpenCart V-Pro Installation, similar to:
http://www.bigmax.ch - http://www.ipcam.li - http://www.jti.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 4 guests